E: Package 'qt5-default' has no installation candidate


Rob Robinett
 

I'm glad you got it installed on that new Raspian "bullseye".  I wasn't aware there was a successor to buster and will add testing of installation on that version to my 'todo' list.
As I recall, the qt5 package is required by components of WSJT-x which aren't used by WD.  So a fake installation should work and you may have helped my debugging of installation on bullseye

The easiest way to view the status of WD's connection to your Kiwis is to go to the Kiwi's Admin->Users page.
There is a uploading daemon log file which can be viewed with some difficulty on v2.10k.
In another forum thread I describe how to enable and view that logging.
In WD v3.0 I will make it much easier to see those logs.


Gur Lavie
 

ok.
It works great.
Amazing. Really amazing. both the simplicity and quality.
I see now that the "version" on http://wsprd.vk7jj.com/  is listed as "WD_2.10k"

I had to go with the "fake" package for "qr5-default" as listed in the link I posted below.
But I guess since I am just using it for wspr it is good enough.

Just curious, if I am running the daemon on one computer, is there a way to connect from a remote computer with a "UI" for the FT8 and other digital modes ?


Gur Lavie
 

Hi,

Another piece of information which might be important is that I am trying to set it as "headless".
No GUI, automatic WSPR spot uploading.

Is there a simple way to test if the connection to the KIWISDR system is active ? 
Is there a log of decoded Sports ?

I guess this is really trivial question. From my reading in the forum it looks like everyone here are super experienced, while I am really just doing first steps.

Thanks !

Gur


Gur Lavie
 

Hi,

Its :
Raspberry Pi 3 Model B Rev 1.2
Linux raspberrypi 5.10.63-v7+ #1459 SMP Wed Oct 6 16:41:10 BST 2021 armv7l GNU/Linux
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
 


Rob Robinett
 

What Pi and what version of Raspian?  I test installation only on the latest 'buster'

On Wed, Nov 10, 2021 at 2:37 PM Gur Lavie <gurlavie@...> wrote:
Hi,

Fresh install on RaspberryPi.
I cant work around this error - "E: Package 'qt5-default' has no installation candidate". "FATAL ERROR: Failed to install 'qt5-default' which is needed to run the 'jt9' copmmand in wsprd V2.3.xxxx"

I am reading in this link, about creating a fake package, to by pass the error - https://askubuntu.com/questions/1335184/qt5-default-not-in-ubuntu-21-04

I didnt find any reference to this in the forum messages.
Thanks! 

Gur



--
Rob Robinett
AI6VN
mobile: +1 650 218 8896


Gur Lavie
 

Hi,

Fresh install on RaspberryPi.
I cant work around this error - "E: Package 'qt5-default' has no installation candidate". "FATAL ERROR: Failed to install 'qt5-default' which is needed to run the 'jt9' copmmand in wsprd V2.3.xxxx"

I am reading in this link, about creating a fake package, to by pass the error - https://askubuntu.com/questions/1335184/qt5-default-not-in-ubuntu-21-04

I didnt find any reference to this in the forum messages.
Thanks! 

Gur