migrate wsprdaemon to Atomicpi


I spent 3 days trying to get port forwarding to work with SSH server and access with Putty from my windows machine. No problems when I use the local NAT addresses.
But no joy when out on the Internet. I have found that I am behind the ISP fiber router in the house that also provides voice service. I have no access to this router so cannot enable port forwarding I have settled on TeamViewer for remote access.


I hope this will be a long and productive thread.

I have been trying to make the move from a good working arrangement with RaspberryPi 4 to Atomicpi.
I have tried many paths but not found one that provides a good working environment, yet!
 I am asking the group to help me out while Rob works on many more important tasks.
Things that I have tried that have not worked:
I installed the X86 version of Raspbian on the Atomicpi. It installed OK  and wsprdaemon also installed
but I ended up with no spots. wd -s looks ok but still no spots. X86 Raspbian does not come with VNC and I was not able to find an X86 version to install.
I was hoping to use VNC to provide remote access to provide for some remote support. I gave up on the X86 Raspbian.

I have since loaded version 20.04 of UBUNTU. the lite version that still has the GUI but none of the User Apps.
I had to install git to install wsprdaemon. I started with an ID of pi but then also added an ID of wsordaemon, Both in the SUDO group.
This has turned into a big pain as I am asked for the password for all invocations of the SUDO command. UBUNTU would not allow me the short nnnn password and insisted that I have 8 long with Upper and special charters. 
With the install of wsprdaemon I have even more errors.

First: on all starts of wd Error -- LC_numeric 'es_CR.UFT-8 ' on your server is not expected If spot frequency is not correct change the local...
The system sees that I am in Costa Rica and assumes Spanish (es). I do not know where to change this.

when I wd -s my KIWI and MERG stack look normal, But, KIWI_2 is normally loaded with all 12 assignments (good China KIWI), But, KIWI_1 has no channels assigned a frequency. I have not found the source of this problem.
And:  I have no spots. I only get the message that there are no spots for the empty files are purged.

Sooooo. I need some guidance.  First -- Should I change the OS? I am getting good at loading new OS on the Atomicpi.
Can I get help here to make this machine visible on the Internet for secure remote access? Hoping for more direct support.

I thought of asking to use PM (private mail) but then I think that there may be others that could benefit from my forthcoming educition.

So now I will QSX for a week.