Re: WD 3.0 beta testing


WA2TP - Tom
 

I too just updated to 3.0. 
Unfortunately something went wrong.
I see connections on all kiwis with 3.0, however they drop after 20-30 seconds with no uploads.

On May 3, 2022, at 10:39 AM, Rob Robinett <rob@...> wrote:


Hi Cathal,

Thanks for the report.  I was wondering about who was reporting from that HB9 call.
My WD 3.0 beta testing work has been centered for the last couple of days on getting WD to install on 'bullseye' the Python libraries needed to generate noise graphs and the sunrise/sunset times.  It seems you have found the commands needed to do that faster than I did.  I am working on the code in WD needed to detect when to run those commands instead of the installation using the legacy procedure.

When that work is done I will check in what will be V 3.0.0

Rob

On Tue, May 3, 2022 at 5:30 AM Cathal Ferris <groups.io@...> wrote:
Solved my runtime errors at least, the graphs will take a bit of time to verify:
sudo pip install numpy --upgrade ; sudo apt update ; sudo apt-get install libatlas3-base

Unsure why numpy was multi-versioned for me, but it now works when the global version is up to date as per the installation via pip
After that I was seeing errors related to a missing libcblas.so.3 library. Installing libatlas3-base provides the functionality that was needed there.

v3 wsprdaemon script now executes as one would expect.



--
Rob Robinett
AI6VN
mobile: +1 650 218 8896

Join wsprdaemon@groups.io to automatically receive all group messages.