Any way to save audio for each digital application #help


KG5KS
 

I run about three different digital programs and when setting up the computer for those, Fldigi is still too hot.  I need to decrease its tx audio WITHOUT moving the Computer sound card settings.  Is there some kind of program that could save each or is there another way to do this ?  I use the Kenwood TS-590SG radio with usb cable connected only.

Thank you
73
Ken


Michael Black
 

What 3 programs are you running?

I'm surprised if FLDigi is running "hot" -- what you mean when you say that?  For the most part you want the signal bar to show 50dB or so on a quiet spot.


Mike W9MDB




On Wednesday, January 19, 2022, 06:47:08 PM CST, KG5KS <hamming49@...> wrote:


I run about three different digital programs and when setting up the computer for those, Fldigi is still too hot.  I need to decrease its tx audio WITHOUT moving the Computer sound card settings.  Is there some kind of program that could save each or is there another way to do this ?  I use the Kenwood TS-590SG radio with usb cable connected only.

Thank you
73
Ken


Rosenthal Nathan H.
 

How are you interfacing your radio to the computer? If it is a direct input, you can change the Fldigi default  transmit audio setting in the lower right corner from -3.0 db to a lower value - say -6.0 db. If that is still too high, keep reducing the audio by 3 db increments. This will not affect the computer audio level for your other programs.

Once you have a setting you like, remember to save it. That procedure is slightly different for various versions of Fldig. 


Cliff
 

Yes, but remember this is for the Transmit audio level only.

73,
Cliff, AE5ZA

On Jan 20, 2022, at 11:31, Rosenthal Nathan H. <nate01pa@...> wrote:

How are you interfacing your radio to the computer? If it is a direct input, you can change the Fldigi default  transmit audio setting in the lower right corner from -3.0 db to a lower value - say -6.0 db. If that is still too high, keep reducing the audio by 3 db increments. This will not affect the computer audio level for your other programs.

Once you have a setting you like, remember to save it. That procedure is slightly different for various versions of Fldig. 


K3EUI Barry
 

Nate's suggestion feels right to me.

Lately, the FLDIGI has defaulted the TX level attenuation to  -3dB.
I turn it way back for my rig -  say  -10dB  and all TX works fine.

Then when I open FLDIGI again, with the same sound card and radio, it defaults BACK TO  -3 dB.
UGH....   

You can now SAVE the config with the lower TX audio level  (more TX attenuation) as Nate suggests.
Config -  MISC -  choose or check TX atten level to SAVE
That should fix the TX  hot audio issue.
When you restart FLDIGI it now defaults to YOUR setting, not  -3dB/

Of course, this has no affect on RX audio.

Watch out on the Knwd 590 HF SSB rig internal USB audio TX mod level settings.
Don't have this set to  "too hot"  for USB (internal sound card) audio codec.

Barry  k3eui


Michael Black
 

I've worked with a couple of TS-590 users with harmonics and this fixes the problem.  One of the few rigs where you have to lower the computer playback leve.

TS590 Menu 64/65 USB In/Out both to 1 and Windows playback to -12dB

With these settings the rig won't be "too hot".

Mike W9MDB



On Friday, January 21, 2022, 07:08:08 AM CST, K3EUI Barry <k3euibarry@...> wrote:


Nate's suggestion feels right to me.

Lately, the FLDIGI has defaulted the TX level attenuation to  -3dB.
I turn it way back for my rig -  say  -10dB  and all TX works fine.

Then when I open FLDIGI again, with the same sound card and radio, it defaults BACK TO  -3 dB.
UGH....   

You can now SAVE the config with the lower TX audio level  (more TX attenuation) as Nate suggests.
Config -  MISC -  choose or check TX atten level to SAVE
That should fix the TX  hot audio issue.
When you restart FLDIGI it now defaults to YOUR setting, not  -3dB/

Of course, this has no affect on RX audio.

Watch out on the Knwd 590 HF SSB rig internal USB audio TX mod level settings.
Don't have this set to  "too hot"  for USB (internal sound card) audio codec.

Barry  k3eui


Cliff
 

Barry,

Just go to fldigi Config/Misc/Save Parameters and set the ones you want saved by mode. Then it won’t keep coming back to -3 every time. 



73,
Cliff, AE5ZA

On Jan 21, 2022, at 07:08, K3EUI Barry <k3euibarry@...> wrote:

Nate's suggestion feels right to me.

Lately, the FLDIGI has defaulted the TX level attenuation to  -3dB.
I turn it way back for my rig -  say  -10dB  and all TX works fine.

Then when I open FLDIGI again, with the same sound card and radio, it defaults BACK TO  -3 dB.
UGH....   

You can now SAVE the config with the lower TX audio level  (more TX attenuation) as Nate suggests.
Config -  MISC -  choose or check TX atten level to SAVE
That should fix the TX  hot audio issue.
When you restart FLDIGI it now defaults to YOUR setting, not  -3dB/

Of course, this has no affect on RX audio.

Watch out on the Knwd 590 HF SSB rig internal USB audio TX mod level settings.
Don't have this set to  "too hot"  for USB (internal sound card) audio codec.

Barry  k3eui


Dave
 

After doing what Cliff suggests you can then open the file mode_state.prefs to be found in the fldigi.files folder.  It is an ASCII text file, so use a programmer's text editor such as Notepad++ or Geany.

; FLTK preferences file format 1.0
; vendor: w1hkj.com
; application: mode_state

[.]

NULL.squelch_level:5
NULL.squelch_state:1
NULL.tx_atten:-30
NULL.afc_state:1
CW.squelch_level:37
CW.squelch_state:1
CW.tx_atten:-60
CW.afc_state:1
Contestia.squelch_level:5
Contestia.squelch_state:1
Contestia.tx_atten:-30
Contestia.afc_state:1
Cont4-125.squelch_level:5
Cont4-125.squelch_state:1
Cont4-125.tx_atten:-30
Cont4-125.afc_state:1
Cont4-250.squelch_level:5
Cont4-250.squelch_state:1
Cont4-250.tx_atten:-30
Cont4-250.afc_state:1
Cont4-500.squelch_level:5
Cont4-500.squelch_state:1
Cont4-500.tx_atten:-30
Cont4-500.afc_state:1
...

It is a big file.  Set each of the mode states to fit your operating needs, save the file, and start fldigi.  The levels should be those you set in the file.  Make changes in fldigi and the mode state values will save as the changed settings when you exit fldigi.

73, David, W1HKJ

On 1/21/22 08:13, Cliff wrote:
Barry,

Just go to fldigi Config/Misc/Save Parameters and set the ones you want saved by mode. Then it won’t keep coming back to -3 every time. 



73,
Cliff, AE5ZA

On Jan 21, 2022, at 07:08, K3EUI Barry <k3euibarry@...> wrote:

Nate's suggestion feels right to me.

Lately, the FLDIGI has defaulted the TX level attenuation to  -3dB.
I turn it way back for my rig -  say  -10dB  and all TX works fine.

Then when I open FLDIGI again, with the same sound card and radio, it defaults BACK TO  -3 dB.
UGH....   

You can now SAVE the config with the lower TX audio level  (more TX attenuation) as Nate suggests.
Config -  MISC -  choose or check TX atten level to SAVE
That should fix the TX  hot audio issue.
When you restart FLDIGI it now defaults to YOUR setting, not  -3dB/

Of course, this has no affect on RX audio.

Watch out on the Knwd 590 HF SSB rig internal USB audio TX mod level settings.
Don't have this set to  "too hot"  for USB (internal sound card) audio codec.

Barry  k3eui



Cliff Fox (KU4GW)
 

Ken,
        I use a free program called 'Sound Volume View' that allows saving as many different sound profiles as you want and naming them whatever you want so whenever you change modes just open Sound Volume View and click on File, Load Sound Profile, and then browse to the folder and file you saved and load the saved sound profile of your choosing. You can download it for free at https://www.nirsoft.net/utils/sound_volume_view.html or at https://m.majorgeeks.com/files/details/soundvolumeview.html  It has worked great for me for many years now.

Very 73,
Cliff, KU4GW


WA4GUD Dave
 

Barry,

I did what Dave Freese suggested.  A few tips (BTW, this is addressing transmit level, not receive level): 

1. You need to edit the C:\Users\<username>\fldigi.files\mode_state.prefs file when the program is NOT running - otherwise the program will overwrite your changes on exit.

2. If you use Notepad++, you can do a Find/Replace ALL.  There are around 150 settings you need to change if you want to cover every mode and variant.  I set the search parameter to be ':-30' and to find Whole Words Only.  Notepad++ would not recognize '-30' in the Whole Word search because it is adjacent to the colon so I included the colon in the search and replace values.  I replaced '-30' with '-280', or -28.0 dB.

3.  The values in the file are in tenths of a dB - so '-30' means -3.0 dB. 

4. I found with my IC-7610 that the best setup for handling multiple digital mode programs was:

a. Set the radio's USB Audio Level = 50%
b. Set the PC Sound Recording driver (USB Audio CODEC) level to 50%
c. Set Fldigi level to -28.0 dB

This yields about 50 watts of output with the radio's RF output level at 100% and the DRIVE GAIN set to the lowest level needed to achieve 100 Watts output, about 28% in my configuration.

Then I have fine grain control in Fldigi to go close to 100 watts if I need it (add ~2 dB) or drop it 3 dB to hit 25 watts.  I can also easily achieve the desired power in WSJT-X and other programs. I never run full power because I don't want to see any ALC action but I will get as close as possible if I have a marginal contact.
--
73, DaveT
WA4GUD


KG5KS
 

Just a note to let you know that worked and -17.6db later I have alc where it needs to be.  Haven't saved it though as did config save, but that wasn't it.

Appreciate all who responded with suggestions.

Thank you
73
Ken