fldigi installation issues


Marty Blaise, AG5T <theblaisepage@...>
 

I am having issues in these two areas:

Rig Control
Use the menu Configure→Rig Control item to set how you will control the rig. If you will key the rig via a serial port, in the Hardware PTT tab select Use serial port PTT, the device name you will use, and which line controls PTT. If in doubt, check both RTS and DTR. You must then press the Initialize button. --

If I select use serial port PTT, then I press initialize and it gets the Yaesu 450D stuck in transmit mode and I have to turn off the power supply or else the rig is stuck in transmit.

If you plan to use CAT control of the rig via the COM port, check Use Hamlib in the Hamlib tab. Select your rig model from the drop-down menu and set the serial port device name, baud rate, and RTS/CTS options as needed. If in addition you wish to use PTT control via CAT, also check PTT via Hamlib command. You must then press the Initialize button.

I am using a CAT cable with WSJT-X and it works ok on changing the frequency. But when I try to set up hamlib, the frequency doesn't change in fldigi. I use com 5 for cat cable and com 3 for serial port for PTT. I used Yaesu 450 but I'm not sure it's the same as Yaesu 450d

When I turn on fldigi, the hf rig clicks like its acknowldeging the program. Flidigi also receives fine. Just does not transmit.

Thanks.


Cliff
 

Marty,

I recommend you use Flrig for rig control. I supports the FT-450D. Set that up as per the flrig manual. Normally the defaults will work as long as you select the correct rig and serial port and baud rate and. Then if you must use a separate PTT line then set that up also in flrig. Note if the rig TX sticks on then you probably have the RTS or DTR lines set incorrectly flrig PTT. In fldigi then for Rig Control select flrig and check the top box on that config page. Do NOT set the Flrig PTT keys modem option since if you run WSJTx as below when it transmits it will also key fldigi and you will have RF Soup going out over the air waves.

To run WSJTx then select flrig as the rig in the WSJTx setup. That way both WSJTx and fldigi will use the same rig control. Of course only transmit on one at a time, but you can receive with both running just fine and control the radio from both.

73,
Cliff, AE5ZA

On Aug 16, 2021, at 13:38, Marty Blaise, AG5T via groups.io <theblaisepage@...> wrote:

I am having issues in these two areas:

Rig Control
Use the menu Configure→Rig Control item to set how you will control the rig. If you will key the rig via a serial port, in the Hardware PTT tab select Use serial port PTT, the device name you will use, and which line controls PTT. If in doubt, check both RTS and DTR. You must then press the Initialize button. --

If I select use serial port PTT, then I press initialize and it gets the Yaesu 450D stuck in transmit mode and I have to turn off the power supply or else the rig is stuck in transmit.

If you plan to use CAT control of the rig via the COM port, check Use Hamlib in the Hamlib tab. Select your rig model from the drop-down menu and set the serial port device name, baud rate, and RTS/CTS options as needed. If in addition you wish to use PTT control via CAT, also check PTT via Hamlib command. You must then press the Initialize button.

I am using a CAT cable with WSJT-X and it works ok on changing the frequency. But when I try to set up hamlib, the frequency doesn't change in fldigi. I use com 5 for cat cable and com 3 for serial port for PTT. I used Yaesu 450 but I'm not sure it's the same as Yaesu 450d

When I turn on fldigi, the hf rig clicks like its acknowldeging the program. Flidigi also receives fine. Just does not transmit.

Thanks.


Bob McGraw - K4TAX <rmcgraw@...>
 

You may wish to download the correct XML file for your radio.   See:  https://sourceforge.net/projects/fldigi/files/xmls/
Install the XML file in the same folder as FLDIGI.

73
Bob, K4TAX