fldigi with IC-M710 #hamlib #fldigi


Bejoy VU3BOJ
 

Hello all,

I am trying to use Fldigi on Windows 10 with Icom IC-M710 radio. Using Hamlib for the cat control. The radio goes to remote mode while launching fldigi but nothing happens when I change the frequencies. I monitored the serial communication and no commands are being sent while changing frequency or mode.

The hamlib of WSJT-X works fine with the radio.

What might be the issue?
73,
Bejoy
VU3BOJ


Cliff
 

How do you know Hamlib has connected to the radio? 

If you can’t change frequencies then it sounds like Hamlib did not connect. When you setup Hamlib and initialized it did the top check mark, Use Hamlib, remain checked? You’re using the same com port and baud rate as you use in WSJT-X I assume as well as nothing else that would use that com port is running.

73,
Cliff, AE5ZA

On Sep 26, 2020, at 12:51, Bejoy VU3BOJ <bejoy.groups@...> wrote:

Hello all,

I am trying to use Fldigi on Windows 10 with Icom IC-M710 radio. Using Hamlib for the cat control. The radio goes to remote mode while launching fldigi but nothing happens when I change the frequencies. I monitored the serial communication and no commands are being sent while changing frequency or mode.

The hamlib of WSJT-X works fine with the radio.

What might be the issue?
73,
Bejoy
VU3BOJ


Bejoy VU3BOJ
 

Thanks for the reply. I confirmed the connection as the radio display would turn "REMOTE" when fldigi starts. Also I ran a serial port monitoring software to sniff the data transfer on the com port and I see the protocol data. But once the initial sequence is done, there is no further communication. The port remains open. No other software is running, that uses the same port.

In the settings page, the 'Use hamlib' checkbox won't stay checked. I looked at the debug dialog and there's an 'hamlib io_error 88 show_dialog' line. The rigctl command line tool (from a separate hamlib installation) works fine too.

73
Bejoy
VU3BOJ


Michael Black
 

Please try the alpha version.  There was a hamlib fix that might apply to your problem.


Mike W9MDB


On Sunday, September 27, 2020, 07:50:35 AM CDT, Bejoy VU3BOJ <bejoy.groups@...> wrote:


Thanks for the reply. I confirmed the connection as the radio display would turn "REMOTE" when fldigi starts. Also I ran a serial port monitoring software to sniff the data transfer on the com port and I see the protocol data. But once the initial sequence is done, there is no further communication. The port remains open. No other software is running, that uses the same port.

In the settings page, the 'Use hamlib' checkbox won't stay checked. I looked at the debug dialog and there's an 'hamlib io_error 88 show_dialog' line. The rigctl command line tool (from a separate hamlib installation) works fine too.

73
Bejoy
VU3BOJ


Bejoy VU3BOJ
 

Thanks Mike. It works in the alpha version! Awesome!

The frequency commands ran terribly slow when I ran first. Then I renamed the config folder and ran a fresh setup. Working flawlessly now.

73,
Bejoy
VU3BOJ