Kenwood 590SG not talking to PC


 

I have a friend with a Kenwood TS-590SG that will not connect to the PC with WSJT-X or FLDigi. It talks to the Kenwood software fine. I set the WSJT-X and FLDigi programs to the settings used by the Kenwood software and nothing. The radio to computer connection is USB on both ends. The sound card is an MFJ 1204. The computer is a laptop. We have no control of the computer. Can I please get some help with this.
The com port is set at 115200 and everything else is defaulted. Also someone suggested that we don't need the sound card with this rig. Does anyone know anything about that?
Thanks in advance for helping,
Dave


Mark Bond
 

The below guide may be helpful. The menu numbers may be different on the TS-590S and TS-590SG although they are titled the same.

http://www.g3nrw.net/ts-590-files/TS-590S_HOWTO_digital_quickstart_v1.4.pdf

Mark, W2MB


On 7/17/2020 5:36 PM, Dave Alexander wrote:
I have a friend with a Kenwood TS-590SG that will not connect to the PC with WSJT-X or FLDigi. It talks to the Kenwood software fine. I set the WSJT-X and FLDigi programs to the settings used by the Kenwood software and nothing. The radio to computer connection is USB on both ends. The sound card is an MFJ 1204. The computer is a laptop. We have no control of the computer. Can I please get some help with this.
The com port is set at 115200 and everything else is defaulted. Also someone suggested that we don't need the sound card with this rig. Does anyone know anything about that?
Thanks in advance for helping,
Dave


Joe Dz
 

Hi Dave,

 

My 590SG works just fine on all, in Windows and Linux, using the USB cable as the only interface.  For fldigi I down loaded the 590 file from the rig area on fldigi.  Also make sure that Kenwood software does not have exclusive access in the Windows settings.  Let all applications have access to the COM port.

 

Below are my rig and WSJT-X settings.  And after you change rig settings, do a power off and restart to be sure that they took.

 

Joe, K1YOW

 

33 SSB Data Low Cut 100 Hz

34 SSB Data Hi Cut 3000 Hz

36 DSP Equalizer OFF

37 DSP Equalizer OFF

68 USB Speed 115200 baud

69 USB line selected for data in

70 REAR input selected (disables the mic)

71 USB Audio In Level at 1 (that way I have more headway in the software to change the Tx volume).

72 USB Audio Out Level at 2

75 USB Beep Tones OFF

76 VOX for DATA is OFF  (unless you are using VOX to trigger the Tx – I am using CAT)

I put the TS-590SG via the front panel in USB mode with DATA selected as well.  You also may have to play with the audio settings in 71 and 72.

Now, if you are also going to run MSK144 for meteor scatter, you want the rig DSP to be as wide as possible. 

29 SSB Data Filter 1  (this changes the front panel control DSP shift to a DSP width and then open it up to 5 KHz via the front panel knob)

For WSJT-X, I have the following settings:

Radio selected: TS-590SG

Poll Interval 1s

Serial Port – whatever comm port Windows installed the USB CODEC driver on

Serial Port Parameter 115200 (or whatever you selected in the rig)

Data bits Eight

Stop Bits One

Handshake NONE

PTT Method CAT

Transmit Audio Source REAR/DATA

Mode NONE

Split Operation RIG

Audio USB CODEC

 

 

 

 


From: winfldigi@groups.io [mailto:winfldigi@groups.io] On Behalf Of Dave Alexander
Sent: Friday, July 17, 2020 5:37 PM
To: winfldigi@groups.io
Subject: [winfldigi] Kenwood 590SG not talking to PC

 

I have a friend with a Kenwood TS-590SG that will not connect to the PC with WSJT-X or FLDigi. It talks to the Kenwood software fine. I set the WSJT-X and FLDigi programs to the settings used by the Kenwood software and nothing. The radio to computer connection is USB on both ends. The sound card is an MFJ 1204. The computer is a laptop. We have no control of the computer. Can I please get some help with this.
The com port is set at 115200 and everything else is defaulted. Also someone suggested that we don't need the sound card with this rig. Does anyone know anything about that?
Thanks in advance for helping,
Dave


K3eui <K3eui@...>
 

I do not own a Kenwood HF SSB rig like the  590S/SG  but I recall that in FLDIGI, you have to go to the Sound Card settings and set up the 

TX audio for  "REVERSE  left/right channels"  or  you can select
TX audio on  BOTH  LEFT/RIGHT  channels.

FLDIGI normally uses the LEFT channel for TX audio and the right channel for "other" purposes.
So maybe it is a simple  FLDIGI  audio setting option error.

The  left/right is fine on RX  audio.

Let us know if that makes a difference.

Just curious why you are using a  MFJ 1204 sound card when the HF rig has an excellent sound card already built in as a usb audio codec.

K3eui
Barry


On Jul 17, 2020, at 5:53 PM, Joe Dz <joedzekevich@...> wrote:

Hi Dave,

 

My 590SG works just fine on all, in Windows and Linux, using the USB cable as the only interface.  For fldigi I down loaded the 590 file from the rig area on fldigi.  Also make sure that Kenwood software does not have exclusive access in the Windows settings.  Let all applications have access to the COM port.

 

Below are my rig and WSJT-X settings.  And after you change rig settings, do a power off and restart to be sure that they took.

 

Joe, K1YOW

 

33 SSB Data Low Cut 100 Hz

34 SSB Data Hi Cut 3000 Hz

36 DSP Equalizer OFF

37 DSP Equalizer OFF

68 USB Speed 115200 baud

69 USB line selected for data in

70 REAR input selected (disables the mic)

71 USB Audio In Level at 1 (that way I have more headway in the software to change the Tx volume).

72 USB Audio Out Level at 2

75 USB Beep Tones OFF

76 VOX for DATA is OFF  (unless you are using VOX to trigger the Tx – I am using CAT)

I put the TS-590SG via the front panel in USB mode with DATA selected as well.  You also may have to play with the audio settings in 71 and 72.

Now, if you are also going to run MSK144 for meteor scatter, you want the rig DSP to be as wide as possible. 

29 SSB Data Filter 1  (this changes the front panel control DSP shift to a DSP width and then open it up to 5 KHz via the front panel knob)

For WSJT-X, I have the following settings:

Radio selected: TS-590SG

Poll Interval 1s

Serial Port – whatever comm port Windows installed the USB CODEC driver on

Serial Port Parameter 115200 (or whatever you selected in the rig)

Data bits Eight

Stop Bits One

Handshake NONE

PTT Method CAT

Transmit Audio Source REAR/DATA

Mode NONE

Split Operation RIG

Audio USB CODEC

 

 

 

 


From: winfldigi@groups.io [mailto:winfldigi@groups.io] On Behalf Of Dave Alexander
Sent: Friday, July 17, 2020 5:37 PM
To: winfldigi@groups.io
Subject: [winfldigi] Kenwood 590SG not talking to PC

 

I have a friend with a Kenwood TS-590SG that will not connect to the PC with WSJT-X or FLDigi. It talks to the Kenwood software fine. I set the WSJT-X and FLDigi programs to the settings used by the Kenwood software and nothing. The radio to computer connection is USB on both ends. The sound card is an MFJ 1204. The computer is a laptop. We have no control of the computer. Can I please get some help with this.
The com port is set at 115200 and everything else is defaulted. Also someone suggested that we don't need the sound card with this rig. Does anyone know anything about that?
Thanks in advance for helping,
Dave