Configuring Fldigi/Flrig for IC-9700 FSQ and MT63


Michele - WB6F <wb6f@...>
 

Hi there,

I am trying to get up and running with Fldigi on my new ic-9700, and I;m at the point where it appears that flrig/fldigi have control of the radio, and I can hear transmissions coming in over the radio but they do not appear in fldigi, and I can see my transmissions going out on the waterfall, however I do not hear them and I do not hear anyone reply to what I send. Something is up in Denmark.

Would appreciate any help that could be provided.

i have screenshots of my configuration.


Cliff
 

What does MT63 have to do with your problem? Your screen shots show that fldigi isn’t in MT63 mode.

What audio connection do you have between the 9700 and fldigi?

Please show a screen shot of your audio configuration in fldigi.

73,
Cliff, AE5ZA

On Oct 15, 2019, at 12:50, Michele - WB6F <wb6f@...> wrote:

Hi there,

I am trying to get up and running with Fldigi on my new ic-9700, and I;m at the point where it appears that flrig/fldigi have control of the radio, and I can hear transmissions coming in over the radio but they do not appear in fldigi, and I can see my transmissions going out on the waterfall, however I do not hear them and I do not hear anyone reply to what I send. Something is up in Denmark.

Would appreciate any help that could be provided.

i have screenshots of my configuration.

<Screenshot 2019-10-15 10.43.55.png><Screenshot 2019-10-15 10.43.08.png> <Screenshot 2019-10-15 10.43.55.png>


Michele - WB6F <wb6f@...>
 

Thanks Cliff,

MT63 and FSQ are relevant to me as those are the modes I would like to be able to operate on with this radio, at the outset, as they are required for my ACS participation. What is showing at the moment is FSQ however the problem I am having is present in both modes.

The 9700 is set to use the USB Audio Codec for both the speaker and the microphone, as recommended in the manuals for fldigi and flrig.

Here is a screenshot.


Cliff
 

Make sure those are the correct USB Codecs. Check in the Device Manager and be sure. I don’t run Windows, but the screenshots I’ve seen don’t have the “microphone” and “speaker” prefixes on the USB Codecs. Maybe Windows does that now, but it looks suspect to me.

73,
Cliff, AE5ZA

On Oct 17, 2019, at 19:28, Michele - WB6F <wb6f@...> wrote:

Thanks Cliff,

MT63 and FSQ are relevant to me as those are the modes I would like to be able to operate on with this radio, at the outset, as they are required for my ACS participation. What is showing at the moment is FSQ however the problem I am having is present in both modes.

The 9700 is set to use the USB Audio Codec for both the speaker and the microphone, as recommended in the manuals for fldigi and flrig.

Here is a screenshot. <Screenshot 2019-10-17 17.24.50.png>


Michele - WB6F <wb6f@...>
 

In the device manager I have two items called :usb audio codec". In the drop down menus in any  windows program i get the choice, if its a microphone preference, of "microphone 6-usb audio codec" or "microphone 4-usb audio codec" or same two choices but for speaker. There is no plain non-prefaced usb audio codec option in the settings dialog windows for any app in my windows 10 installation.

and, i have tried both the 6-usb and the 4-usb audio codec options without success. i do have several other non usb options that don't work either... realtek and others


Cecil at W5DXP.com
 

Cliff, Win10 does have microphone and speaker prefixes. PS Rough copy on FeldHell Net last night but at least I could hear you.


Cliff
 

Ok, Thanks for the clarification Cecil. 

Michele: Can you route the incoming USB Codec to speakers and listen in Windows to verify it’s getting out of the radio? I don’t know on the 9700, but on my 7300 it has to be in digital mode to get the audio to come out via the USB Audio and also other settings in the radio have to be set to get it all routed properly. I have to be in USB Digital and then select MT63 in the Op-Mode to get audio into fldigi.

73,
Cliff, AE5ZA

PS: Cecil: You were barely copyable here. Thankfully W1HKJ had better copy.

On Oct 18, 2019, at 06:33, Cecil at W5DXP.com <w5dxp@...> wrote:

Cliff, Win10 does have microphone and speaker prefixes. PS Rough copy on FeldHell Net last night but at least I could hear you.


Michele - WB6F <wb6f@...>
 

Hi Cliff,

Apologies for not replying until now, I managed not to see your post until this morning.

Do you mean just using windows settings to select the usb codec microphone and speakers, in addition to doing that within the software? I have done that, and it does not make a difference. Also, folks in my ACS team have told me that we need to be operating in FM mode for our purposes, and I have tried it in both FM and USB-D modes. I can send on fm, not usb-d, and I cannot receive on either.

I have played with a lot of settings, including usb-b data function, usb send/keying, data mod and data off mod. these dont appear to be the culprit.

Michele


Glenn O'Connor <ka0lnr37@...>
 

I’m not sure of Michele’s circumstances, but has FM-D been tried?

 

KF0ED

 

From: winfldigi@groups.io <winfldigi@groups.io> On Behalf Of Michele - WB6F
Sent: Sunday, October 27, 2019 11:36 AM
To: winfldigi@groups.io
Subject: Re: [winfldigi] Configuring Fldigi/Flrig for IC-9700 FSQ and MT63

 

Hi Cliff,

Apologies for not replying until now, I managed not to see your post until this morning.

Do you mean just using windows settings to select the usb codec microphone and speakers, in addition to doing that within the software? I have done that, and it does not make a difference. Also, folks in my ACS team have told me that we need to be operating in FM mode for our purposes, and I have tried it in both FM and USB-D modes. I can send on fm, not usb-d, and I cannot receive on either.

I have played with a lot of settings, including usb-b data function, usb send/keying, data mod and data off mod. these dont appear to be the culprit.

Michele


Glenn O'Connor <ka0lnr37@...>
 

I see a potential problem with reception on this particular FSQCall setup,

the monitor window box isn’t checked and subsequently opened.

 

Below the Heard list, where the received calls are populating that window, is

a group of check boxes. One is MON, check that and a another pane will appear.

That’s the rx window.

 

KF0ED

 

From: winfldigi@groups.io <winfldigi@groups.io> On Behalf Of Michele - WB6F
Sent: Sunday, October 27, 2019 11:36 AM
To: winfldigi@groups.io
Subject: Re: [winfldigi] Configuring Fldigi/Flrig for IC-9700 FSQ and MT63

 

Hi Cliff,

Apologies for not replying until now, I managed not to see your post until this morning.

Do you mean just using windows settings to select the usb codec microphone and speakers, in addition to doing that within the software? I have done that, and it does not make a difference. Also, folks in my ACS team have told me that we need to be operating in FM mode for our purposes, and I have tried it in both FM and USB-D modes. I can send on fm, not usb-d, and I cannot receive on either.

I have played with a lot of settings, including usb-b data function, usb send/keying, data mod and data off mod. these dont appear to be the culprit.

Michele


Cliff
 

Michele,

Were you able to hear the radio signal via either headphones or speakers on the PC? That was my intent, to verify that the audio is getting to the PC. If it is not then either the radio mode is wrong and sending the audio via the wrong connector or the radio setup is not set to put the audio out where you expect it to be.

73,
Cliff, AE5ZA

On Oct 27, 2019, at 11:36, Michele - WB6F <wb6f@...> wrote:

Hi Cliff,

Apologies for not replying until now, I managed not to see your post until this morning.

Do you mean just using windows settings to select the usb codec microphone and speakers, in addition to doing that within the software? I have done that, and it does not make a difference. Also, folks in my ACS team have told me that we need to be operating in FM mode for our purposes, and I have tried it in both FM and USB-D modes. I can send on fm, not usb-d, and I cannot receive on either.

I have played with a lot of settings, including usb-b data function, usb send/keying, data mod and data off mod. these dont appear to be the culprit.

Michele


Michele - WB6F <wb6f@...>
 

I have not tried FM-D. Will see if I can try that tomorrow.


Michele - WB6F <wb6f@...>
 

On Mon, Oct 28, 2019 at 12:28 AM, Glenn O'Connor wrote:

I see a potential problem with reception on this particular FSQCall setup,

the monitor window box isn’t checked and subsequently opened.

I had limited real estate so I didn't show it, but I always have the monitor open when I am testing. In other installations where I've operated successfully, the monitor shows all traffic, and the main window shows traffic directed to allcall or specifically to my callsign. So any testing with allcall or my callsign would show regardless, if it was functioning properly.....

Below the Heard list, where the received calls are populating that window, is

a group of check boxes. One is MON, check that and a another pane will appear.

That’s the rx window.

 

KF0ED


Michele - WB6F <wb6f@...>
 

I have done additional testing since posting and have found that I get inconsistent results... I can send on 2 out of 4 sound card options, I can see activity, expressed in green at the bottom right column next to when you set the squelch level in the main window on 2 out of 4 sound card options (these two I cannot send on), one of these gives me so much green (I am calling it noise) at such a fluctuating level that the only "smart" level of squelch is 100% which of course is not smart.

this very noisy sound card, the built in Realtek, is able to receive - i get lots of gobbledy gook in the midst of which i can sometimes discern  portions of an actual message.

The other one, my computer calls 6- usb audio codec, which seems to see noise in the green column at somewhere between 10 and 25%, mostly somewhere around 15%, does not demonstrate any "noise" or gobbledygook in the monitor window, and does not receive messages no matter where I look.

I have isolated my "send" soundcard option to the one called 4- usb audio codec as it is the most consistently successful one for sending.

The last soundcard option called "primary" something does not appear to be useful for any purpose under the sun.

I hear the carrier loud and clear when I have "capture" set to either of the green or noisy soundcard options, so I am assuming it is the pc and not the radio I am hearing since I do not hear that carrier when I use the non-working soundcard options. I do not have headphones.

73,
Michele WB6F


Cliff
 

Michele,

You need to determine which USB-Codec is the radio then you can trace down what ever audio issue is still remaining.

The easiest way I know of to determine which one it is is to disconnect the radio from the computer and see which one goes away. Then reconnect it and note which one comes back. Use that one and forget about all the others. Now route that to the PC speakers and verify that indeed what comes out of the PC speaker matches what comes out of the radio. At that point you know that you are properly connected to the radio for audio once you route it to fldigi.

73,
Cliff, AE5ZA

On Oct 29, 2019, at 01:17, Michele - WB6F <wb6f@...> wrote:

I have done additional testing since posting and have found that I get inconsistent results... I can send on 2 out of 4 sound card options, I can see activity, expressed in green at the bottom right column next to when you set the squelch level in the main window on 2 out of 4 sound card options (these two I cannot send on), one of these gives me so much green (I am calling it noise) at such a fluctuating level that the only "smart" level of squelch is 100% which of course is not smart.

this very noisy sound card, the built in Realtek, is able to receive - i get lots of gobbledy gook in the midst of which i can sometimes discern  portions of an actual message.

The other one, my computer calls 6- usb audio codec, which seems to see noise in the green column at somewhere between 10 and 25%, mostly somewhere around 15%, does not demonstrate any "noise" or gobbledygook in the monitor window, and does not receive messages no matter where I look.

I have isolated my "send" soundcard option to the one called 4- usb audio codec as it is the most consistently successful one for sending.

The last soundcard option called "primary" something does not appear to be useful for any purpose under the sun.

I hear the carrier loud and clear when I have "capture" set to either of the green or noisy soundcard options, so I am assuming it is the pc and not the radio I am hearing since I do not hear that carrier when I use the non-working soundcard options. I do not have headphones.

73,
Michele WB6F


Tim
 

I have several codes going into my computer.

After I determine which codex is for each device, I re-name them. I.E. IC-7200 Mic Codex, IC-7200 Speaker, SignaLink Mic Codex, SignaLink Spraker, etc.

When I want to use a device I click on the codex name of that device I am using. This prevents incorrect choosing  of codexes.


Tim - N8NEU
FN00ah
On Oct 29, 2019, at 10:04, Cliff <ae5zaham@...> wrote:

Michele,

You need to determine which USB-Codec is the radio then you can trace down what ever audio issue is still remaining.

The easiest way I know of to determine which one it is is to disconnect the radio from the computer and see which one goes away. Then reconnect it and note which one comes back. Use that one and forget about all the others. Now route that to the PC speakers and verify that indeed what comes out of the PC speaker matches what comes out of the radio. At that point you know that you are properly connected to the radio for audio once you route it to fldigi.

73,
Cliff, AE5ZA

On Oct 29, 2019, at 01:17, Michele - WB6F < wb6f@...> wrote:

I have done additional testing since posting and have found that I get inconsistent results... I can send on 2 out of 4 sound card options, I can see activity, expressed in green at the bottom right column next to when you set the squelch level in the main window on 2 out of 4 sound card options (these two I cannot send on), one of these gives me so much green (I am calling it noise) at such a fluctuating level that the only "smart" level of squelch is 100% which of course is not smart.

this very noisy sound card, the built in Realtek, is able to receive - i get lots of gobbledy gook in the midst of which i can sometimes discern  portions of an actual message.

The other one, my computer calls 6- usb audio codec, which seems to see noise in the green column at somewhere between 10 and 25%, mostly somewhere around 15%, does not demonstrate any "noise" or gobbledygook in the monitor window, and does not receive messages no matter where I look.

I have isolated my "send" soundcard option to the one called 4- usb audio codec as it is the most consistently successful one for sending.

The last soundcard option called "primary" something does not appear to be useful for any purpose under the sun.

I hear the carrier loud and clear when I have "capture" set to either of the green or noisy soundcard options, so I am assuming it is the pc and not the radio I am hearing since I do not hear that carrier when I use the non-working soundcard options. I do not have headphones.

73,
Michele WB6F


Michele - WB6F <wb6f@...>
 

Tim,

Cliff,

Et al

 

Thanks for the help. After much agida and searching high and low, it turns out my problem was one that is also apparently suffered by many signalink owners. It seems that something is causing Windows 10 to mute the microphone on the usb codec drivers for the radio. This is not something I was able to find by searching through and changing settings visually, I had to go select the individual driver and run windows troubleshooting to get it fixed.

 

Just an aha in case anyone else runs into it.

 

 

Michele

WB6F

 


Dave
 

That is Windows enforcing a privacy policy, a reaction to some malware that enables the microphone input, monitors the audio and periodically sends a compressed audio track to a nefarious recipient.

David

On 10/31/19 2:39 AM, Michele - WB6F wrote:

Tim,

Cliff,

Et al

 

Thanks for the help. After much agida and searching high and low, it turns out my problem was one that is also apparently suffered by many signalink owners. It seems that something is causing Windows 10 to mute the microphone on the usb codec drivers for the radio. This is not something I was able to find by searching through and changing settings visually, I had to go select the individual driver and run windows troubleshooting to get it fixed.

 

Just an aha in case anyone else runs into it.

 

 

Michele

WB6F

 



Michele - WB6F <wb6f@...>
 

Wellll... it seems I am having this problem again after having some work done on my PC. Of course they updated Windows and now everything looks different.

I tried following my own advice above about how to fix the problem, but the same settings available then do not seem to appear now. I have updated my drivers (they say they are up to date) and I have set the computer and the flrig codecs to match. But I'm still stuck not receiving digital traffic from the radio to fldigi. Also, the flrig to fldigi connection appears to work but sending digital clicks the radio but nothing actually goes out.

If anyone knows how to navigate this problem in later iterations of Win10 would love some help.

73,
Michele