Fldigi Enable flrig xcvr control with fldigi as client stopped working


AndyW
 

Hi,

I am using fldigi 4.018 and flrig 1.3.41.30 on Windows 10.  I have checked Enable flrig xcvr control with fldigi as client.  This has been working fine for several months.  Now I cant get it to work at all.  It is set for address 127.0.0.1 and port 12345. I don't remember having to set anything on flrig when I initially set it up, although I maybe wrong.

Could this be a networking issue? I noticed tens of fldigi localhost network connections on one up port numbers 55XXX and up.

I can use RigCat as an alternative, but would rather use the preferred method of flrig control. Has anyone seen anything like this and managed to fix it?

Andy



 


Dave
 

Make sure that Windows is blocking socket access to either fldigi or flrig.  Also make sure there isn't a flrig zombie running in the background.  Easiest way to insure that only a single instance is running is a reboot.

Did you have a Win10 update recently?

David

On 10/15/2018 11:17 AM, AndyW via Groups.Io wrote:
Hi,

I am using fldigi 4.018 and flrig 1.3.41.30 on Windows 10.  I have checked Enable flrig xcvr control with fldigi as client.  This has been working fine for several months.  Now I cant get it to work at all.  It is set for address 127.0.0.1 and port 12345. I don't remember having to set anything on flrig when I initially set it up, although I maybe wrong.

Could this be a networking issue? I noticed tens of fldigi localhost network connections on one up port numbers 55XXX and up.

I can use RigCat as an alternative, but would rather use the preferred method of flrig control. Has anyone seen anything like this and managed to fix it?

Andy


AndyW
 

Windows firewall had somehow decided to block comms between fldigi and flrig.  Removing fldigi and flrig items from inbound rules, starting each program again and letting windows firewall add entries for private network and things all good again.  Odd.

Andy