RTTY - no output audio #arhab


Robert, SP8SN
 

Hallo. I have some problem with tx'ing RTTY via sound card.
It's quiet. I use Icom 7300. I set the sound device: Capture MIC USB, and Playback SPEAKER USB. RX'ing works well, decodes signals, but when I want to transmit is silence. I changed PLAYBACK to the second sound card where I have headphones and I can not hear anything. PSK or TUNE works. PC sends a signal. The problem is only with RTTY. I am asking for advice.
Robert SP8SN


Barry Feierman <barryfeierman@...>
 

Robert:

I am going to guess what might be wrong in your situation.....
You can receive (and decode) RTTY  signals with your radio in  USB, LSB, or  RTTY  (possibly need to "reverse" the mark/space tones).

To Transmit RTTY:
Remember ....  if it is  AFSK  RTTY,  meaning keyed AUDIO  tones, then your radio needs to be in SSB  (LSB or USB)  but  not in  RTTY  mode (if your radio even supports FSK RTTY).  The RTTY mode on radios expect DATA signals (square wave pulses)  from a TNC or computer to a  DATA jack, to toggle from  mark to space, sending what is often called  FSK RTTY   ("real" RTTY by some old-timers).

Another way to send RTTY:
AFSK RTTY  just sends the mark/space as two adjacent AUDIO tones, 170 Hz apart, at  45 baud, where ever you "click" on the waterfall.
With AFSK RTTY  you can use any pitch on the waterfall....  you are not restricted to the typical FSK audio tones.
But  transmitting  AFSK  works out just about as well as transmitting   FKS  RTTY  if you don't overdrive your radio  (ALC = 0).


The same applies to sending CW  with FLDIGI and a sound card, by keying audio tones which enter your rig's AUDIO  DATA  port or even in some cases, the MIC port.   Your radio still needs to be in SSB  (again, USB or LSB) but not in CW mode.  If your rig is in CW, then you must actually key a signal line, not send audio into a data port.

That's my best guess why you can't transmit AFSK RTTY.
Switch your rig to USB,  and when you press the  TUNE button, see if your rig transmits.  If it doesn't, check the  PTT  port  (or a VOX).
If TUNE works, then try  RTTY  by keying on your keyboard at some spot on the waterfall.

Let us know if that is the problem,

Barry  k3eui


On Sep 27, 2018, at 2:14 PM, Robert, SP8SN <r.krokowski@...> wrote:

Hallo. I have some problem with tx'ing RTTY via sound card.
It's quiet. I use Icom 7300. I set the sound device: Capture MIC USB, and Playback SPEAKER USB. RX'ing works well, decodes signals, but when I want to transmit is silence. I changed PLAYBACK to the second sound card where I have headphones and I can not hear anything. PSK or TUNE works. PC sends a signal. The problem is only with RTTY. I am asking for advice.
Robert SP8SN


Robert, SP8SN
 

Thank You Barry for info.
I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.


Gary Woods
 

On Thu, 27 Sep 2018 20:51:06 +0200, you wrote:

It looks as if FLDIGI did not
send sound through the sound card with the RTTY mode setting.
Robert:
Do you get audio drive if you click "tune" in RTTY mode?
I'm not in the shack right now, but the next thing to check would be
the RTTY modem settings in FlDigi.
FlDigi is programmed so if the radio is in Upper sideband mode, the
tones will be "right side up."
Good luck (and let me know where you'll be running RTTY when you get
it working)!


Cliff
 

Robert,

What versions of Fldigi and flrig if you are using it?

Why are you not using the sound card in the radio? With the radio sound card Capture and Playback should be set to the USB Audio Codec for the radio.

I also use a 7300 and RTTY works just fine.

73,
Cliff, AE5ZA

On Sep 27, 2018, at 13:51, Robert, SP8SN <r.krokowski@...> wrote:

Thank You Barry for info.
I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.



Robert, SP8SN
 

Yes, TUNE works in RTTY mode.
This is little video of FLDIGI.
It can be seen that FLDIGI in PSK mode sends a sound, and it is silent in RTTY.

https://www.dropbox.com/s/go8p3222t76zv46/2018-09-27%20at%2021-03-37.mp4?dl=0

W dniu 2018-09-27 o 21:03, Gary Woods pisze:

On Thu, 27 Sep 2018 20:51:06 +0200, you wrote:

It looks as if FLDIGI did not
send sound through the sound card with the RTTY mode setting.
Robert:
Do you get audio drive if you click "tune" in RTTY mode?
I'm not in the shack right now, but the next thing to check would be
the RTTY modem settings in FlDigi.
FlDigi is programmed so if the radio is in Upper sideband mode, the
tones will be "right side up."
Good luck (and let me know where you'll be running RTTY when you get
it working)!




Robert, SP8SN
 

I'm using USB sound card inside IC7300 all the time - USB Audio Codec
Fldigi v4.0.18
Like I said, RX working, and TX in another modes also is ok

W dniu 2018-09-27 o 21:07, Cliff pisze:

Robert,

What versions of Fldigi and flrig if you are using it?

Why are you not using the sound card in the radio? With the radio sound card Capture and Playback should be set to the USB Audio Codec for the radio.

I also use a 7300 and RTTY works just fine.

73,
Cliff, AE5ZA

On Sep 27, 2018, at 13:51, Robert, SP8SN <r.krokowski@...> wrote:

Thank You Barry for info.
I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.



Michael Black
 

Are you changing the rig to RTTY mode?

I think you need to stick with USB-DATA mode.

de Mike W9MDB




On Thursday, September 27, 2018, 2:11:05 PM CDT, Robert, SP8SN <r.krokowski@...> wrote:


I'm using USB sound card inside IC7300 all the time - USB Audio Codec
Fldigi v4.0.18
Like I said, RX working, and TX in another modes also is ok

W dniu 2018-09-27 o 21:07, Cliff pisze:
> Robert,
>
> What versions of Fldigi and flrig if you are using it?
>
> Why are you not using the sound card in the radio? With the radio sound card Capture and Playback should be set to the USB Audio Codec for the radio.
>
> I also use a 7300 and RTTY works just fine.
>
> 73,
> Cliff, AE5ZA
>
>> On Sep 27, 2018, at 13:51, Robert, SP8SN <r.krokowski@...> wrote:
>>
>> Thank You Barry for info.
>> I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.
>>
>>
>>
>
>
>





Robert, SP8SN
 

Yes USB-D in the IC7300

W dniu 2018-09-27 o 21:16, Michael Black via Groups.Io pisze:

Are you changing the rig to RTTY mode?

I think you need to stick with USB-DATA mode.

de Mike W9MDB




On Thursday, September 27, 2018, 2:11:05 PM CDT, Robert, SP8SN <r.krokowski@...> wrote:


I'm using USB sound card inside IC7300 all the time - USB Audio Codec
Fldigi v4.0.18
Like I said, RX working, and TX in another modes also is ok

W dniu 2018-09-27 o 21:07, Cliff pisze:
> Robert,
>
> What versions of Fldigi and flrig if you are using it?
>
> Why are you not using the sound card in the radio? With the radio sound card Capture and Playback should be set to the USB Audio Codec for the radio.
>
> I also use a 7300 and RTTY works just fine.
>
> 73,
> Cliff, AE5ZA
>
>> On Sep 27, 2018, at 13:51, Robert, SP8SN <r.krokowski@...> wrote:
>>
>> Thank You Barry for info.
>> I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.
>>
>>
>>
>
>
>






Robert, SP8SN
 

Problem has been solved !!
The problem was that in the Modem / TTY / NanoIO settings the NanoKeyer was connected, which I use for CW. The RTTY modem thought it should broadcast RTTY using NanoIO by FSK, not a sound card. After disconnection NanoIO, Fldigi transmits RTTY via the sound card. I think this is a small FLdigi bug. When I connect NanoIO (NanoKeyer) via USB in a CW modem, it should not run in the RTTY modem at the same time.
Thank you all for your help. Regards Robert.

W dniu 2018-09-27 o 21:16, Michael Black via Groups.Io pisze:

Are you changing the rig to RTTY mode?

I think you need to stick with USB-DATA mode.

de Mike W9MDB




On Thursday, September 27, 2018, 2:11:05 PM CDT, Robert, SP8SN <r.krokowski@...> wrote:


I'm using USB sound card inside IC7300 all the time - USB Audio Codec
Fldigi v4.0.18
Like I said, RX working, and TX in another modes also is ok

W dniu 2018-09-27 o 21:07, Cliff pisze:
> Robert,
>
> What versions of Fldigi and flrig if you are using it?
>
> Why are you not using the sound card in the radio? With the radio sound card Capture and Playback should be set to the USB Audio Codec for the radio.
>
> I also use a 7300 and RTTY works just fine.
>
> 73,
> Cliff, AE5ZA
>
>> On Sep 27, 2018, at 13:51, Robert, SP8SN <r.krokowski@...> wrote:
>>
>> Thank You Barry for info.
>> I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.
>>
>>
>>
>
>
>






Cliff
 

Hmmm….. It doesn’t make a lot of sense then. RTTY has just always worked for me. If PSK and other modes work, RTTY uses the same sound path so something is preventing it working correctly. Could you send a screen shot of your RTTY TX setting page in fldigi configuration?

Different subject, but Dave has spent a lot of time on flrig for the 7300. It works great and gives you all the controls that normally are needed for digital modes on screen. To go back to just fldigi would be really tough for me now. Give it a try and see what you think. Grab the latest Alpha version at: http://www.w1hkj.com/alpha/flrig/ .

73,
Cliff, AE5ZA

On Sep 27, 2018, at 14:10, Robert, SP8SN <r.krokowski@...> wrote:

I'm using USB sound card inside IC7300 all the time - USB Audio Codec
Fldigi v4.0.18
Like I said, RX working, and TX in another modes also is ok

W dniu 2018-09-27 o 21:07, Cliff pisze:
Robert,

What versions of Fldigi and flrig if you are using it?

Why are you not using the sound card in the radio? With the radio sound card Capture and Playback should be set to the USB Audio Codec for the radio.

I also use a 7300 and RTTY works just fine.

73,
Cliff, AE5ZA

On Sep 27, 2018, at 13:51, Robert, SP8SN <r.krokowski@...> wrote:

Thank You Barry for info.
I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.









Cliff
 

Great. Thanks for letting us know.

73,
Cliff, AE5ZA

On Sep 27, 2018, at 14:34, Robert, SP8SN <r.krokowski@...> wrote:

Problem has been solved !!
The problem was that in the Modem / TTY / NanoIO settings the NanoKeyer was connected, which I use for CW. The RTTY modem thought it should broadcast RTTY using NanoIO by FSK, not a sound card. After disconnection NanoIO, Fldigi transmits RTTY via the sound card. I think this is a small FLdigi bug. When I connect NanoIO (NanoKeyer) via USB in a CW modem, it should not run in the RTTY modem at the same time.
Thank you all for your help. Regards Robert.

W dniu 2018-09-27 o 21:16, Michael Black via Groups.Io pisze:
Are you changing the rig to RTTY mode?

I think you need to stick with USB-DATA mode.

de Mike W9MDB




On Thursday, September 27, 2018, 2:11:05 PM CDT, Robert, SP8SN <r.krokowski@...> wrote: 


I'm using USB sound card inside IC7300 all the time - USB Audio Codec
Fldigi v4.0.18
Like I said, RX working, and TX in another modes also is ok

W dniu 2018-09-27 o 21:07, Cliff pisze:
> Robert,
>
> What versions of Fldigi and flrig if you are using it?
>
> Why are you not using the sound card in the radio? With the radio sound card Capture and Playback should be set to the USB Audio Codec for the radio.
>
> I also use a 7300 and RTTY works just fine.
>
> 73,
> Cliff, AE5ZA
>
>> On Sep 27, 2018, at 13:51, Robert, SP8SN <r.krokowski@...> wrote:
>>
>> Thank You Barry for info.
>> I know how to use digi modes. Transciver mode is USB. All another modes like contesta, psk, olivia etc. works fine. I'm using also WSJT-X and another soft for digi. All works fine. It looks as if FLDIGI did not send sound through the sound card with the RTTY mode setting.
>>
>>
>>
>
> 
>







Dave
 

Glad you discovered the problem Robert.  What is a bug for one might be a feature for another.  If you were using the nanoIO / MORTTY interface for both CW and RTTY then changing modes is accomplished without need of operator intervention.

I will look at the interface code to see if the bug/feature can be easily resolved.

73, David, W1HKJ

On 09/27/2018 02:34 PM, Robert, SP8SN wrote:
Problem has been solved !!
The problem was that in the Modem / TTY / NanoIO settings the NanoKeyer was connected, which I use for CW. The RTTY modem thought it should broadcast RTTY using NanoIO by FSK, not a sound card. After disconnection NanoIO, Fldigi transmits RTTY via the sound card. I think this is a small FLdigi bug. When I connect NanoIO (NanoKeyer) via USB in a CW modem, it should not run in the RTTY modem at the same time.
Thank you all for your help. Regards Robert.


Dave
 

Robert,

Do you want to test an alpha version of fldigi with the code change, or wait until the next general release?

73, David

On 09/27/2018 02:56 PM, Dave wrote:
Glad you discovered the problem Robert.  What is a bug for one might be a feature for another.  If you were using the nanoIO / MORTTY interface for both CW and RTTY then changing modes is accomplished without need of operator intervention.

I will look at the interface code to see if the bug/feature can be easily resolved.

73, David, W1HKJ


On 09/27/2018 02:34 PM, Robert, SP8SN wrote:
Problem has been solved !!
The problem was that in the Modem / TTY / NanoIO settings the NanoKeyer was connected, which I use for CW. The RTTY modem thought it should broadcast RTTY using NanoIO by FSK, not a sound card. After disconnection NanoIO, Fldigi transmits RTTY via the sound card. I think this is a small FLdigi bug. When I connect NanoIO (NanoKeyer) via USB in a CW modem, it should not run in the RTTY modem at the same time.
Thank you all for your help. Regards Robert.



Robert, SP8SN
 

Hallo David. Perhaps I have misrepresented myself - bug. Choice option in rtty modem FSK/sound card it would be a good solution.
Best 73, Robert

W dniu czw., 27.09.2018 o 21:56 Dave <w1hkj@...> napisał(a):

Glad you discovered the problem Robert.  What is a bug for one might be
a feature for another.  If you were using the nanoIO / MORTTY interface
for both CW and RTTY then changing modes is accomplished without need of
operator intervention.

I will look at the interface code to see if the bug/feature can be
easily resolved.

73, David, W1HKJ


On 09/27/2018 02:34 PM, Robert, SP8SN wrote:
> Problem has been solved !!
> The problem was that in the Modem / TTY / NanoIO settings the
> NanoKeyer was connected, which I use for CW. The RTTY modem thought it
> should broadcast RTTY using NanoIO by FSK, not a sound card. After
> disconnection NanoIO, Fldigi transmits RTTY via the sound card. I
> think this is a small FLdigi bug. When I connect NanoIO (NanoKeyer)
> via USB in a CW modem, it should not run in the RTTY modem at the same
> time.
> Thank you all for your help. Regards Robert.




--
Wysłano z iPhone
Sent from iPhone


Robert, SP8SN
 

OK David, I can test it. I'm not a programmer, but I often use FLDIGI and I can test.
Robert