Weird signal behavior

Bill Wilken

I have just begun an effort to equip my entire railroad with Atlas
signals driven by NCE BD-20 block detectors. The railroad is powered
by a NCE PowerCab and PowerPro booster.

I created my first signal block within a considerably longer power
district. When I run an Athearn GP-9 or a BLI Blueline F7 in and out
of the signal block, the signal works properly, showing red when the
block is occupied and green when it is empty. So far so good.

But when I run larger locos like a BLI E8 or a Rapido FA-2 (consisted
or not), the signal is always red whether the loco is in or out of the
block but within the surrounding power district. Once the loco moves
to another power district, the signal turns green.

Importantly the rails within the 40'-long signal block are all properly
gapped. After first getting the anomalous result when I put several
signal bus drops through the BD-20, I decided to try only one drop, and
the signal continued to operate in the same fashion. Similarly, for
testing purposes, I'm powering Atlas signal control board with nothing
but a 9-volt battery. I've not yet tried adding a 500 Ohm resistor to
the BD-20, but it's not clear to me why that would help.

I welcome any clues that might lead to a fix for this problem.