Re: Powering Points


Perry A Pollino
 

John Thanks,
I did not specify which turnout I am using. I am using electrofrog.  I did imply it by saying I am using the new PSX Frog AR boards. My  bad, PSX are the same as a frog juicer.
I will try your sandpaper and Graphite trick. The problem does seem to be the  electric contact with stock rails and point rails. While checking with my meter if I push a bit on point rail I get continuity. I took out the springs in my turnouts since I am using Tortoise switch machines. I also upgraded a larger wire and brass tube to improve the movement.
Perry

On Monday, December 9, 2019, 5:17:39 AM CST, John Heaps <hpod@...> wrote:


Hi Perry,

You did not say if they are electrofrog or insulfrog.

If electrofrog you can solder a wire to the frog and wire so that you get power to the frog from the appropriate rail. This also depends on how you change the points.

To improve the contact with the point blades you can sandpaper with very fine sandpaper, then use a graphite pencil or a soft pencil ( 6B ) on the point blades. This works for me.

Cheers,

John Heaps,
Vic, Australia.



On 9/12/2019 10:45 am, Perry A Pollino wrote:
I have N scale Peco code 55 turnouts. Just started testing y track and it is not going well. I am using DCC NCE powe cab fr testing. I have PSX curcuit breakers and PSX Frog AR's. One of my scale trians 6 axle locos would stutter through and indicate a short. $ axle Atlas Loco only stuttered. I took  meter set for continuity. It seem my points are not being powered well. if I pus point into the rail I get continuity.
How can I improve the contact between the points and the rails?
Perry


Join w4dccqa@groups.io to automatically receive all group messages.