Topics

Puppet Apache Module

Davin Hanlon
 

See below - missed the Vox Pupuli mailing list off the original notification. Let me know your feedback.

Thanks,
Davin


On Thursday, August 23, 2018 at 4:29:49 PM UTC+1, Davin Hanlon wrote:
Hello everyone!

Read on if you use the Puppet Apache module.

Quick note to let you know of some major work that we're performing to the module. As you probably know, Apache 2.2 has been end-of-lifed since the start of 2018 (https://httpd.apache.org/#apache-httpd-22-end-of-life-2018-01-01). Therefore, we're taking steps to remove support for that version of Apache from the module. This also impacts the operating systems that we will support for the module. The following operating systems won't be supported by the Apache module after the changes:
  • RHEL 5
  • RHEL 6
  • CentOS 5
  • CentOS 6
  • Oracle Linux 6
  • Scientific Linux 6
  • SLES 11
Any users that use either Apache 2.2 or use one of the above operating systems should pin to an older version of the module. We will continue to support these operating systems for older versions of the module.

Feel free to reach out if you've any questions or comments.

Thanks,
The Puppet Modules Team
--
Davin Hanlon
Product Owner, Modules
Puppet. The shortest path to better software.

Davin Hanlon
 

Hello everyone!

Read on if you use the Puppet Apache module.

Quick note to let you know of some major work that we're performing to the module. As you probably know, Apache 2.2 has been end-of-lifed since the start of 2018 (https://httpd.apache.org/#apache-httpd-22-end-of-life-2018-01-01). Therefore, we're taking steps to remove support for that version of Apache from the module. This also impacts the operating systems that we will support for the module. The following operating systems won't be supported by the Apache module after the changes:
  • RHEL 5
  • RHEL 6
  • CentOS 5
  • CentOS 6
  • Oracle Linux 6
  • Scientific Linux 6
  • SLES 11
Any users that use either Apache 2.2 or use one of the above operating systems should pin to an older version of the module. We will continue to support these operating systems for older versions of the module.

Feel free to reach out if you've any questions or comments.

Thanks,
The Puppet Modules Team
--
Davin Hanlon
Product Owner, Modules
Puppet. The shortest path to better software.

Ewoud Kohl van Wijngaarden <ewoud@...>
 

I also got the original notification via the VP ML. Anyway, better notified twice than not :) I really appreciate the heads up about these bigger changes. Luckily I'm unaffected.

On Wed, Aug 29, 2018 at 09:47:59AM -0700, Davin Hanlon wrote:
See below - missed the Vox Pupuli mailing list off the original
notification. Let me know your feedback.

Thanks,
Davin


On Thursday, August 23, 2018 at 4:29:49 PM UTC+1, Davin Hanlon wrote:

Hello everyone!

Read on if you use the Puppet Apache module
<https://forge.puppet.com/puppetlabs/apache>.

Quick note to let you know of some major work that we're performing to the
module. As you probably know, Apache 2.2 has been end-of-lifed since the
start of 2018 (
https://httpd.apache.org/#apache-httpd-22-end-of-life-2018-01-01).
Therefore, we're taking steps to remove support for that version of Apache
from the module. This also impacts the operating systems that we will
support for the module. The following operating systems won't be supported
by the Apache module after the changes:

- RHEL 5
- RHEL 6
- CentOS 5
- CentOS 6
- Oracle Linux 6
- Scientific Linux 6
- SLES 11

Any users that use either Apache 2.2 or use one of the above operating
systems should pin to an older version of the module. We will continue to
support these operating systems for older versions of the module.

Feel free to reach out if you've any questions or comments.

Thanks,
The Puppet Modules Team
--
Davin Hanlon
Product Owner, Modules
Puppet. The shortest path to better software.

Martin Alfke
 

Hi Davin,

according to RedHat RHEL 6 has End of maintenance support 2 (Product retirement) until November 30, 2020 and End of extended lifecycle support at June 30, 20124.
(https://access.redhat.com/support/policy/updates/errata#Life_Cycle_Dates)

Will you support the latest apache module with RHEL 6 support until end of RedHat support?

Best,
Martin

On 23. Aug 2018, at 17:29, Davin Hanlon <davin.hanlon@...> wrote:

Hello everyone!

Read on if you use the Puppet Apache module.

Quick note to let you know of some major work that we're performing to the module. As you probably know, Apache 2.2 has been end-of-lifed since the start of 2018 (https://httpd.apache.org/#apache-httpd-22-end-of-life-2018-01-01). Therefore, we're taking steps to remove support for that version of Apache from the module. This also impacts the operating systems that we will support for the module. The following operating systems won't be supported by the Apache module after the changes:
• RHEL 5
• RHEL 6
• CentOS 5
• CentOS 6
• Oracle Linux 6
• Scientific Linux 6
• SLES 11
Any users that use either Apache 2.2 or use one of the above operating systems should pin to an older version of the module. We will continue to support these operating systems for older versions of the module.

Feel free to reach out if you've any questions or comments.

Thanks,
The Puppet Modules Team
--
Davin Hanlon
Product Owner, Modules
Puppet. The shortest path to better software.