Beaker 3 to Beaker 4 migration for puppet modules.

Tp Honey
 

Hi,
    as you may be aware there was a release of Beaker 4 gem in the last week, here are some proof of concept PR's for puppet modules that show the necessary code changes and the dependency changes required for this migration. 
The Beaker team have detailed the technicalities of these beaker changes here Upgrade_from_3_to_4
Longer term we are going to put these changes into puppet-module-gems pinning first to beaker 3 then moving to beaker 4 for supported puppet modules. 

Please feel free to reach out if you have further questions.

Thanks
TP Honey

Join voxpupuli@groups.io to automatically receive all group messages.