Re: Get rid of Puppet4?

David Hollinger
 

Yeah I think >=4.10.x is a good target - there aren't any earlier 4.x series releases that are getting patches, since 4.10.x is the 'last of the line' before 5. It is a very short step from 4.10.x to 5 too, so i'd suggest being generous about dropping 4.x compatibility unless you *know* a module uses some 5.x-only construct.

This is in no way an official Puppet Inc statement but I suspect there will be a longer tail to 4.10 than just October 2018, given its inclusion in Satellite and widespread use out in the world.
Thanks for the input, Eric. With this I think we can justify reducing our support range down to >= 4.10.

--dhollinger

Join voxpupuli@groups.io to automatically receive all group messages.