Topics

Synchronize error message

Bruce Croskey
 

QSO Relay works  fine and loges into my HRD log fine but when I try to sync. the log I get an error message saying "The given key was not present in the dictionary" and when I click on the OK it says unable to sync are you sure your logbook is open and it is... but the JTAlert keeps reporting I need every state that is decoded and I believe it is related to the inability to sync the log... any ideas??
73 Bruce AH0U

Chris VK2BYI
 

Hi Bruce,

Can you read the Reporting an Issue topic and follow the steps to provide the information that will help diagnose your problem?  At the very least, follow step 6 and Zip up all the files in the specified folder.

I suspect you a have 'cached contact' that QSO Relay is trying to log but can't, and the database sync. is not proceeding.

73 Chris
VK2BYI

Joy Rider
 

Hi Chris,

I have the exact same problem, running HRD 6.4.0.780.  I will zip the QSORelay folder and mail it to you.

73's
Roland

Chris VK2BYI
 

Hi Roland,
You have a 'cached' contact that QSO Relay is trying to log in HRD Logbook, but can't because it has embedded carriage return/line feed characters (or newlines) in the Address field.  There is a known bug in HRD Logbook, whereby embedded newlines in the Address field can prevent the record from being processed correctly.  The contact is for QSO Date: 2017-08-19, Time On: 05:21:00, Call: EA6BH, Band: 40m and Mode: FT8, which I note has been successfully logged in your Access database that you sent me.  However, the Address field is only partially populated because of the defect in HRD Logbook, and you will need to perform a 'Lookup' in HRD Logbook itself to complete the Address field correctly.

 

Because you have this contact logged, you can simply delete the 'contact.cache' file in the QSO Relay folder, and you will be able synchronise databases and continue working normally.

 

To prevent this from happening again, you will need to exclude the Address field when logging contacts by changing a setting in JTAlert.  If you open the JTAlert settings and select the Logging node, you will see a checkbox labelled 'Log Address returned from an XML or previous QSO lookup'.  Make sure that this checkbox setting is not checked:

 
The downside to this workaround, is that the Address field will be blank in HRD Logbook for any JT-mode contacts you log while this checkbox is unticked, despite JTAlerts ability to look up the address for you.  If JTAlert gets an address from the lookup that contacts embedded newlines - which is perfectly acceptable and typical - the record will not be logged correctly.
 
This defect has been raised previously with HRD, and I have recently lodged another support request asking for it to be fixed.  I have been talking with them and they are working on a fix.  I don't know when this will be fixed, but I will follow up on it from time to time with them.
 
In the meantime, don't log the address field by keeping this checkbox setting unticked.  You can always perform the lookup and update the Address field after it has been logged in HRD Logbook.  This is what I do, as you will see I have no checkboxes selected in JTAlert in the Logging node as shown above.

73 Chris
VK2BYI
 

Joy Rider
 

Hi Chris,

thank you very much, full ACK. After deleting the file contact.cache in the QSO Relay folder sync is working again. Also I have disabled the Log Address option in JTAlert for now.

TU for this great piece of Software and keep it up !
73's de Roland HB9VQQ

Chris VK2BYI
 

You are most welcome, Roland.
Enjoy!
73 Chris
VK2BYI