Topics

Sync not working on v1.2

Rick
 

Chris,

Installed new version and everything seems to work with the logging, but when I try to sync the databases it deletes all the records in the QSOrelay db as though I did not have any records in my HRD db.  Tried several things but with all the same results.  I have verified that it is pointing to the correct HRD db, and since it is logging properly that should not be a problem.  Using HRD 6.4.0.647.  Any help would be deeply appreciated.

Rick


Chris VK2BYI
 
Edited

There are two data paths involved - relaying JT-mode contacts from QSO Relay to HRD Logbook, and downloading all contacts from HRD Logbook to QSO Relay.  The first path requires the IP Address, TCP Port and Logbook Database values in the QSO configuration settings to be correct, and the second path requires the Connection String setting to be correct.  It may be that your connection string setting is not correct.
Please refer to the Configuring QSO Relay for Microsoft Access Database document in the files section, or on my web site on the QSO Relay page for much greater detail on these related settings.
Let me know how you get on, but due to family commitments, I may not be able to reply again until about 4:00 PM tomorrow my time.
73 Chris
VK2BYI

ON4VT Danny OT4V <danny@...>
 

Rick
 
Same issue here .... the QSOrelay DB has not declined in size though ....  But when trying to DELETE a QSO via QSOrealy it shows NO QSO's
 
The "B4" function in JTAlert also doen't see any B4 QSO ....  

Rick
 
Edited

Chris,

I had verified the paths and had actually read your pdf on configuring QSO Relay for Microsoft Access Database before installing the new version. My post #66 shows the log of the sync.

Rick WB7BOW 73

Hank W6IR
 

I concur that sync is not working in the new version. The entire sql.lite DB was wiped out under the new version. Removed it and reinstalled 1.1 and re-synced. Everything is back in the DB. Will wait for a fix. Chris, I'm happy to help test anything new out, I'm retired from the IT world so I do know my way around.


Hank

Ian@...
 

Hank

You might try turning on trace (look in the V1.2 Doc on how to turn it on) complete a sync, then turn off trace and post the trace.

It should look similar to my one, this will tell you if you have all the parts correctly configured.  I just pulled this down a few minutes ago.

Chris will be able to look at what is going on then from the trace.


Morris WA4MIT
 
Edited

Same here guys have tried everything I know to do uninstalled with Revo deleted relay DB reinstalled 1.2 still not working, verified the paths sync shows 23321 rows in HRD nothing in relay DB

My trace:

2017-05-12 17:54:21.6266 Trace listener started


2017-05-12 17:54:31.7619 Synchronise databases started

2017-05-12 17:54:31.7629 Creating synchronise database lock file

2017-05-12 17:54:31.8004 Checking for cached contacts

2017-05-12 17:54:31.8004 No cached contacts

2017-05-12 17:54:31.8009 Creating HRD dataset

2017-05-12 17:54:34.3446 Refreshing SQLite

2017-05-12 17:54:34.3446 Truncating Log table

2017-05-12 17:54:34.5271 0 rows deleted

2017-05-12 17:54:34.5306 Log Table truncated

2017-05-12 17:54:34.5306 HRD Logbook contains 23321 rows

2017-05-12 17:54:34.6962 Begin transaction

2017-05-12 17:54:34.6962 Time On: 2017-05-12 01:40:00, Call: RV9CX, Band: 20m, Mode: JT65

2017-05-12 17:54:34.6982 Time On: 2017-05-11 10:15:00, Call: M0PXS, Band: 20m, Mode: JT9

2017-05-12 17:54:34.6987 Time On: 2017-05-11 10:09:00, Call: OT4R, Band: 20m, Mode: JT9

A extended long list of contacts ... then ends with this

SQLite error (2067): abort at 292 in [Insert Into [Log] ( QsoId, Address, Age, AIndex, AntAz, AntEl, Band, BandRx, Call, Comment, Cont, ContactedOp, ContestId, Country, Cqz, Distance, Dxcc, EqCall, Email, EqslQslRDate, EqslQslSDat

2017-05-12 18:29:11.3258 constraint failed

UNIQUE constraint failed: Log.Call, Log.Band, Log.Mode, Log.QsoDate, Log.TimeOn

Insert Into [Log] ( QsoId, Address, Age, AIndex, AntAz, AntEl, Band, BandRx, Call, Comment, Cont, ContactedOp, ContestId, Country, Cqz, Distance, Dxcc, EqCall, Email, EqslQslRDate, EqslQslSDate, EqslQslRcvd, EqslQslSent, ForceInit, Freq, FreqRx, GridSquare, Iota, IotaIslandId, Ituz, KIndex, Lat, Lon, MaxBursts, MsShower, MyLat, MyLon, LotwQslRDate, LotwQslSDate, LotwQslRcvd, LotwQslSent, Mode, MyCity, MyCnty, MyCountry, MyCqZone, MyGridSquare, Myiota, MyIotaIslandId, MyItuZone, MyName, MyPostalCode, MyRig, MySig, MySigInfo, MyState, MyStreet, Name, Notes, NrBursts, NrPings, Pfx, TheOperator, OwnerCallsign, Precedence, PropMode, PublicKey, ProgramId, ProgramVersion, QslMsg, QslRDate, QslSDate, QslRcvd, QslRcvdVia, QslSent, QslSentVia, QslVia, QsoComplete, QsoDate, QsoDateOff, QsoRandom, Qth, Rig, Sfi, RstRcvd, RstSent, SatMode, SatName, Sig, SigInfo, Srx, SrxString, State, StationCallsign, Stx, StxString, Swl, TimeOff, TimeOn, ValidatedCallsign, ManualDateTime, Mobile, Qrp, Portable, CallsignUrl, HomepageUrl, Contest, Cnty, AntPath, ArrlSect, ArrlCheck, TheCla

wa4mit Morris


Luca Nerva
 

Hi, I have the same problem here, but if I do some new QSOs they appears in the list of contacts to be deleted. And they are shown also as QSO B4 in JTALERT. Naturally all contacts disappears from list if I resync again. All QSO are logged 100% in HRD Logbook

 

 

Some time ago I had uninstalled LOG4OM, and at the start of JTALERT I had the log error message, the only way to fix the log name was to reinstall it.

 

 

73’s de Luke IW1FZR

 

Mike Davies <face@...>
 
Edited

I concur.  Everything was working well until the update but now I can log to HRD but after Sync the SQL Database is empty which means of course JTAlert thinks everyting is new.  Reverting to V1.1 fixes the issue.
--
Mike, G0KAD

Antony
 

Have you got any duplicate QSOs in your log? I found that I had 4 in mine and the sync stopped at each one. I deleted the dupe and then restarted the sync. Having done this 4 times the sync now works as it should. 73, Antony G4CUS 

Chris VK2BYI
 
Edited

My 100,000 QSO test database does not have duplicates, and I have been careful to avoid creating them in HRD Logbook.  But it has happened to me occasionally.  Unfortunately, HRD Logbook does not prevent duplicate contacts from being created.

QSO Relay always checks for duplicates as they are being logged into its database, and when they are being relayed, to avoid creating them in HRD Logbook.

The next release (1.3), which is being tested as I type this, will check for duplicates in HRD Logbook at the start of the sync.  If it finds any, it will add the details to the "Sync Report <datetime>.txt" file it creates during a sync in the Documents/QSORelay folder, and the sync will stop.  Users will then need to remove the unwanted duplicates, being careful to keep the best up-to-date row as the remaining contact, before attempting the sync again.

73 Chris

VK2BYI

ON4VT Danny OT4V <danny@...>
 

Well this was a good motivation to clean up my HRD log !

Among my 50k+ QSO's I found about 15 duplicates ... all cleaned up and the sync is working !

Took me some time to clean up all, on the other hand it's good to have a clean up now.  If not on this I would have waste my time on something others ... lol

Keep up the good work Chris !


73 ON4VT.be Danny

Chris VK2BYI
 

Hi Danny,

Thank you very much.  I will certainly try!

73 Chris
VK2BYI