Topics

Contact was not logged in QSORelay SQLite database

snack@...
 

Greetings from Finland

First thank you so much that finally we have solution use HRD6 with jtalertx, many of the JTDX users with jtalertx have get this work but some how i just can get this work. Tried with two different PC:s one with Windows 7 and one with Windows 10. I have disabled firewall, uninstalled, reinstalled, checking my settings many times but still when i try log a QSO i got "Contact was not logged in QSORelay SQLitedatabase"

I just not understand what is wrong or what i do wrong because i got same error with two different computers as i said. Only what works to me is Sync with sqlite file and HRD logbook

Sqlite file is 36KB when i create it, sync with HDR works fine no problem, but when i try log a QSO i got error. Please look attachments my pics from my settings. I would appreciate it if someone could help me and show me where i do mistake or wrong or do i have missed something

Best regards
OH8EJW, Mikko

Bruce VK2RT
 

Hi Mikko,

When you created the QSORelay.SQLite database file, it would have been located in the AppData/Roaming/VK2BYI/QSORelay folder, did you copy that file to the folder C:\Users\Documents\QSORelay ?

Make sure the QSORelay.SQLite file is located where you are pointing to it.

It should not matter where you have the QSORelay.SQLite file located but try creating a new QSORelay.SQLite file where it wants to create by default in the Roaming area and then select it there and also point to it there in JTAlertX.

DE Bruce

VK2RT

snack@...
 
Edited

Hi Bruce

I tried first default locations and sympthon was same. Documents folder was the last test to change location to avoid permmission problems, but it not helped. I can retry with default locations later in this day

OH8EJW, Mikko

snack@...
 

Hi,

I tested with default foldes, but still same error

OH8EJW, Mikko

Bruce VK2RT
 

Hi Mikko, from your images everything seems to be setup correctly. You said before that you successfully ran "Synchronise Databases", can you select "Delete a Contact" and show me what is shown in that dialog, I expect it will be empty. We may need to schedule a time and use Teamviewer to access your PC and see what's going on. Teamviewer is available at https://www.teamviewer.com/en/ DE Bruce VK2RT

r8kah@...
 

I have exactly same problem on Windows 10. R8KAH, Oleg

snack@...
 

Hi Bruce
Before sync database is empty like it should, after sync i have all QSO from HRD logbook. In both situations i can use delete command, when i have contacs from HRD it also deletes them. After resync its back again what i deleted, not sure should it do that way.

Teamviever is ok to me. Our time difference is about 8 hours so i think weekend when i am not at work is fine

- Mikko

Bruce VK2RT
 

Hi Mikko The sync is working fine, the SQLite database mirrors the HRD Logbook database. If you remove an entry from the SQLite database it will return after the next sync. If you want an entry totally removed, remove it from HRD and after a sync it will be removed from the SQLite database (or remove from both). OK on Teamviewer, yes we can arrange a time over the weekend Mikko. I will send you an email. DE Bruce VK2RT

r8kah@...
 

Bruce, can you access my PC use Teamviewer? Send me your email for id and password. Thanks. R8KAH, Oleg r8kah@...

Bruce VK2RT
 

Mikko, please go to Options in QSO Relay where you have selected "Digimode Logbook - Access" check the Connection String and make sure you have it pointed to the correct file. I thought that maybe you have other files there and you are pointing to the wrong file. Thanks DE Bruce VK2RT

snack@...
 
Edited

I check this and correct file was pointed.. anyway i got this finally work, i read your post from JTDX FB group. And YES my regional settings uses "," COMMA for the decimal symbol, if i change to "." DOT, restart JTDX JTalertx and QSORelay everything works fine no problemes at all. If i use default value on decimal symbol (COMMA) and restart JTDX JTalertx and QSORelay.. it wont work anymore

So i hope that QSORelay will support my default symbol COMMA in future versions. To be honest i thought some place this problem that it may be something in regional settings what can do this, but i did not test change any of them silly me =)

Anyway, to me problem have now "work around solution" but i hope that you fix this in future version soon or later. Thank you for your support

Mikko, OH8EJW