Date   
Re: Not showing all contacts in delete box.

Chris VK2BYI
 

Hi Bob,

I opened the Access and SQLite databases you provided and they both contain 1,258 rows.  So all of the rows that are in your Access database have been synchronized in QSO Relay.

I wrote two queries to break down the number of contacts per year for each database, and here are the results for Access and SQLite respectively:

      

As you can see the number of contacts per year are identical.  So I am confident that all of contacts have been sync'ed.

QSO Relay only selects rows from, and inserts rows into, HRD Logbook - it does not delete HRD rows.  The Delete Contact feature only deletes rows one at a time from the QSO Relay database.


So I would have to assume you may have accidently deleted all contacts made after the contact with VK3ERW on 2015-05-29 12:25:15.


HRD Logbook creates automatic backups of your database periodically, so you should be able to recover your lost rows if you can locate the archive made immediately before the data loss.


73 Chris

VK2BYI


Not showing all contacts in delete box.

Bob Davet
 

Chris:


Thanks for looking into that for me.

I uninstalled QSORelay completely. I even deleted all files and folders.

Reinstalled it and created the appropriate files.

Synchronized the databases. Ran for 30-40 seconds.

When I pull up the Delete entry box I get the exact same info I did before. I am missing contacts. It stops at 2015. Nothing past that.

I have attached 3 files today for you to check out. I included the SQL file also.

Both the HRD and SQL files should be identical correct? If so, how do I check the SQL file? I have never used that type of file before that I know of.

Thanks


Bob

W8RID

moderated Re: New to this group, install questions

Chris VK2BYI
 

Hi Bob,

I have had chance to register your database in HRD Logbook and configure QSO Relay to work with it.  I then created a new QSO Relay SQLite database file and performed a database sync which ran for about 30 odd seconds.

Everything worked without issue - all of your contacts came down and without any errors or warnings.  So, at this stage I would suggest you re-boot/re-install QSO Relay and try again.

The next release will include an enhancement that will display the number of rows in the SQLite database in the Delete a Contact... dialog, along with a Search for Contact feature.

We are working on this release and hope to have it ready in the next couple of days time permitting.

73 Chris
VK2BYI

Re: Stopped logging to HRD

Bruce VK2RT
 

Hi Ian,

Please look in the AppData folder for the application - C:\Users\<your username>\AppData\Roaming\VK2BYI\QSORelay, and see if any exceptions have occurred during the sync.

If there is an exception log there (Exception yyyy-mm-dd.log), can you send it to me via bruce@...

Also, what JT software are you using (WSJT-X/JTDX etc), and what versions of JTAlertX and HRD.


DE Bruce

VK2RT

Stopped logging to HRD

Ian Morrow
 

Hello

I would like to say that you software is great and doing a great job.  I am new to JT65 and have been using you software all day. I set it up to your quick setup guide and it worked right away.  Everything was logging 100% until about 12 midday and then it stopped logging to HRD but it was still logging to the QSORelay SQLite database. I have 4 contacts in my log since the last one to log in HRD ,but they will not come over to my HRD log.  I have tried to synchronise Databases a few times but it still has not helped. Hope you can help in some way?  I have changed no setting since I first set it up and it was working.

 

If you need access to my setup , I have TeamViewer on my computer.

 

Best Regards

MI1CCU Ian


QSO Relay Logging Issue to do with Windows Regional Settings - Please Read

Bruce VK2RT
 

There is currently an issue with Windows Regional Settings where a comma "," is being used as the Mhz separator as shown in the WSJT-X/JTDX etc. frequency window.

Quick FIx - if your Windows Regional Setting is a comma "," change it to is a dot "."

A new release of QSO Relay will be available shortly that fixes this issue.


DE Bruce

VK2RT

Re: QSO Relay

snack@...
 

Thanks goes to Bruce, i got this hint from him in FB group. Anyway nice to know, this works

- Mikko

Re: HRD needs refresh after logging .

f1vev@...
 

Thank you to all and that did the trick polling / sharing was not set 73s to everyone who answered

Re: QSO Relay

Arnolds Preiss
 

Thank you very much Mikko, yes  it work now, tnx. GL 73

Arnolds

YL2CA

Re: QSO Relay

snack@...
 
Edited

Hi Arnolds,

Try change your default decimal symbol form "COMMA" to "DOT" in windows regional settings, to me that trick works. AND do not forget restart your JT program JTalertx and QSORelay

- Mikko

Re: Contact was not logged in QSORelay SQLite database

snack@...
 
Edited

I check this and correct file was pointed.. anyway i got this finally work, i read your post from JTDX FB group. And YES my regional settings uses "," COMMA for the decimal symbol, if i change to "." DOT, restart JTDX JTalertx and QSORelay everything works fine no problemes at all. If i use default value on decimal symbol (COMMA) and restart JTDX JTalertx and QSORelay.. it wont work anymore

So i hope that QSORelay will support my default symbol COMMA in future versions. To be honest i thought some place this problem that it may be something in regional settings what can do this, but i did not test change any of them silly me =)

Anyway, to me problem have now "work around solution" but i hope that you fix this in future version soon or later. Thank you for your support

Mikko, OH8EJW

Re: Thanks from the UK

Chris VK2BYI
 

Hi Mike, Thank you for the feedback and we are glad to hear that you find QSO Relay useful. 73 Chris, VK2BYI and Bruce, VK2RT

Re: HRD needs refresh after logging .

Chris VK2BYI
 

Thanks Mike, yes that is a workaround. But as I said above it should happen automatically. I don't have it set, but every contact being logged displays immediately for me and my colleagues. :)

Re: Contact was not logged in QSORelay SQLite database

Bruce VK2RT
 

Mikko, please go to Options in QSO Relay where you have selected "Digimode Logbook - Access" check the Connection String and make sure you have it pointed to the correct file. I thought that maybe you have other files there and you are pointing to the wrong file. Thanks DE Bruce VK2RT

Re: HRD needs refresh after logging .

Mike Davies <face@...>
 

Not sure if this is the solution as I already had this set but have a look in HRD Log under Tools, Configure, Sharing and make sure the Poll for Updates box is ticked. 5 seconds should be sufficient. Mike, G0KAD

Thanks from the UK

Mike Davies <face@...>
 

Bruce,

Downloaded and installed as per the instructions.  Windows 10 prompts for an exception for the UDP for but otherwise the instructions were absolutely precise.  Everything is working as it should.  An excellent utility.  A small donation is on it's way.

Many Thanks

--
Mike, G0KAD

Re: HRD needs refresh after logging .

Chris VK2BYI
 

Hi Jacques,

Thank you for the feedback.

You shouldn't have to refresh HRD for the new row to appear.  As long as the grid in HRD is sorted in Time On descending order - that is, with the most recent contacts at the top - the row should appear automatically.  That is what happens on my setup and others that I know.  This might be a question better asked of the HRD Support Group forum.  For a workaround, there is an option on the Settings menu in HRD Logbook called Sharing that allows you set a periodic refresh every 5 seconds - but I repeat this shouldn't be necessary, it should happen after HRD accepts the new contact.


With regards to your second question, it is "normal".  The only columns that are populated are those where values have been provided by JTAlertX, if a value is not provided, it is left 'null' or empty.  So at first it looks like LoTW Sent, eQSL Sent, QSL Sent etc. appear empty, but when you open the contact in HRD and press F7, HRD writes the row back with 'N' values in those sort of columns.

QSO Relay

Arnolds Preiss
 

 

Hello Bruce,

I am YL2CA, I have same problem as Mikko – QSO did not logged in HRD logbook but logged in QRZ.com c/o HRD logbook options, all settings are as in Mikko pictures, maybe my HRD options are wrong?

Here is message from QSO Relay folder after traying log QSO:

 

2017-05-04 10:16:54.2850 ERROR System.FormatException: Input string was not in a correct format.

   at System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)

   at QSORelay.Entities.SqliteLogbook.BuildInsertStatement(Dictionary`2 fields, SQLiteConnection dbConnection)

   at QSORelay.Entities.SqliteLogbook.LogContact(Dictionary`2 fields)

 

Will look in group messages , maybe someone have solution…

 

GL 73

 

Arnolds

YL2CA

Re: Contact was not logged in QSORelay SQLite database

r8kah@...
 

Bruce, can you access my PC use Teamviewer? Send me your email for id and password. Thanks. R8KAH, Oleg r8kah@...

Re: Contact was not logged in QSORelay SQLite database

Bruce VK2RT
 

Hi Mikko The sync is working fine, the SQLite database mirrors the HRD Logbook database. If you remove an entry from the SQLite database it will return after the next sync. If you want an entry totally removed, remove it from HRD and after a sync it will be removed from the SQLite database (or remove from both). OK on Teamviewer, yes we can arrange a time over the weekend Mikko. I will send you an email. DE Bruce VK2RT