Topics

No input devices


David J Taylor
 

Just setting up on a new PC. Copied all the files from a working installation. Program starts, asks for VCRUNTIME. Installed both 32- and 64-bit versions.

Program now starts, but doesn't show the expected input devices. HackRF works with Spektrum, not seen in the SDRangel list. Pluto likewise. Feel I must be missing something obvious (again!).

Thanks,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


Edouard Griffiths
 

Hi David,

did you run Zadig on the new computer?

Brgds, Edouard.


David J Taylor
 

Hi David,

did you run Zadig on the new computer?

Brgds, Edouard.
======================================

No, but I'm not using any RTL devices so I didn't think that was required.

I tried with Zadig 2.4 installing the WinUSB driver for the Pluto (IIO (interface 5) is that the one?) and the HackRF One (where a downgrade from v10.0.17763.1 was required). The devices are still not available. In loaded plug-ins, neither the HackRF nor the Pluto are listed, but the "RTL-SDR input" is listed.

Puzzled!

Cheers,
David
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


David J Taylor
 

Hi David,

did you run Zadig on the new computer?

Brgds, Edouard.
==============================================

Updated.

No, but I'm not using any RTL devices so I didn't think that was required.

I tried with Zadig 2.4 installing the WinUSB driver for the Pluto (IIO (interface 5) is that the one?) and the HackRF One (where a downgrade from v10.0.17763.1 was required). The devices are still not available in SDRangel, but still work in their own native programs (e.g. IIO Oscilloscope and Spektran v4.1.2).

In loaded plug-ins, neither the HackRF nor the Pluto are listed, but the "RTL-SDR input" is listed. An RTL-SDR works as expected. I tried a complete re-install (re-expanded the .z) but no difference.

In SDRangel\pugins\samplesource\

inputplutosdr.dll - 631.296 bytes
inputhackrf.dll - 606.720 bytes

In SDRangel:

libhackrf.dll - 24.576 bytes

excuse any typos! SDRangellms-v4.3.2.7, Win-10/64 home

Puzzled!

Thanks,
David
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


David J Taylor
 

Further update - a second person has confirmed that a recent SDRangel doesn't work with either the Pluto or HackRF. In my case: v4.3.2.7 cannot see these input devices, but v4.2.4 can. I hope that helps.

Cheers,
David
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


David J Taylor
 

Further update - a second person has confirmed that a recent SDRangel
doesn't work with either the Pluto or HackRF. In my case: v4.3.2.7 cannot
see these input devices, but v4.2.4 can. I hope that helps.

Cheers,
David
==============================

Edouard,

Just tried v4.4.3.7 and there are still no input hardware devices show, just file etc. Possibly, it works on 10/Pro with a lot of stuff installed, but not on 10/Home with much less stuff installed.

Has anyone found a solution to this issue, please?

Thanks,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


Siegfried Jackstien
 

edouard and david

i have just checked ...

my pluto is found in win10 on my tablett ... and in win7 on my "crappy old laptop" (core2duo) ...

version 4.4.3

hope that helps a bit?!?

greetz

sigi dg9bfc

Am 07.02.2019 um 09:30 schrieb David J Taylor via Groups.Io:

Further update - a second person has confirmed that a recent SDRangel
doesn't work with either the Pluto or HackRF.  In my case: v4.3.2.7 cannot
see these input devices, but v4.2.4 can.  I hope that helps.

Cheers,
David
==============================

Edouard,

Just tried v4.4.3.7 and there are still no input hardware devices show, just file etc.  Possibly, it works on 10/Pro with a lot of stuff installed, but not on 10/Home with much less stuff installed.

Has anyone found a solution to this issue, please?

Thanks,
David GM8ARV


David J Taylor
 

edouard and david

i have just checked ...

my pluto is found in win10 on my tablett ... and in win7 on my "crappy
old laptop" (core2duo) ...

version 4.4.3

hope that helps a bit?!?

greetz

sigi dg9bfc
====================================

It's a useful data point, but others have also reported the same problem. Here, on my main PC v4.4.3 works as expected, but it doesn't on my portable (which I want to take to an amateur radio event to give a talk). Both are Win-10/64. And it's not the "microphone permission" issue.

If it's of any help, the versions which don't work are the ones with "MS" in the archive, so I guess versions compiled with MS tools. Perhaps a required RTL version is missing?

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


Siegfried Jackstien
 

pluto drivers installed?!?

dg9bfc sigi

Am 07.02.2019 um 10:15 schrieb David J Taylor via Groups.Io:

edouard and david

i have just checked ...

my pluto is found in win10 on my tablett ... and in win7 on my "crappy
old laptop" (core2duo) ...

version 4.4.3

hope that helps a bit?!?

greetz

sigi dg9bfc
====================================

It's a useful data point, but others have also reported the same problem. Here, on my main PC v4.4.3 works as expected, but it doesn't on my portable (which I want to take to an amateur radio event to give a talk).  Both are Win-10/64.  And it's not the "microphone permission" issue.

If it's of any help, the versions which don't work are the ones with "MS" in the archive, so I guess versions compiled with MS tools.  Perhaps a required RTL version is missing?

73,
David GM8ARV


David J Taylor
 

From: Siegfried Jackstien

pluto drivers installed?!?

dg9bfc sigi
=======================================

Sigi,

I'm testing with an Airspy mini - in this application the 25 ppm accuracy of the Pluto is inadequate.

I'll test with a Pluto, though, for comparison.

4.2.4 - Pluto OK.
4.3.2 - Pluto not seen.
4.4.3 - Pluto not seen.

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


Siegfried Jackstien
 

that is strange ...

i have installed the newest version on both of my pc and both do find the pluto ... thats why i asked if the drivers were proper installed ... but hey i am talking with doc taylor .... you sure know what you are doing :-)

greetz

sigi dg9bfc

Am 07.02.2019 um 15:25 schrieb David J Taylor via Groups.Io:

From: Siegfried Jackstien

pluto drivers installed?!?

dg9bfc sigi
=======================================

Sigi,

I'm testing with an Airspy mini - in this application the 25 ppm accuracy of the Pluto is inadequate.

I'll test with a Pluto, though, for comparison.

4.2.4 - Pluto OK.
4.3.2 - Pluto not seen.
4.4.3 - Pluto not seen.

73,
David GM8ARV


David J Taylor
 

that is strange ...

i have installed the newest version on both of my pc and both do find
the pluto ... thats why i asked if the drivers were proper installed ...
but hey i am talking with doc taylor .... you sure know what you are
doing :-)

greetz
sigi dg9bfc
================================

Yes, it makes it more frustrating when normally you would be helping with other people's problems! I suspect it's a missing (Microsoft?) DLL which the newer newer builds of the drivers are using, and when it's missing the driver simply fails to load rather than reporting the missing library. For the Airspy, ones listed which can't be found for inputairspy.dll are:

sdrbase.dll
sdrgui.dll
swagger.dll
libairspy.dll

For inputplutosdr.dll the list is as above, but libairspy.dll is replaced by devices.dll. The missing DLLs are all in the main SDRangel.exe directory, so perhaps it's a pathing error?

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


David J Taylor
 

I've tried to add an attachment from Process Monitor (https://docs.microsoft.com/en-us/sysinternals/downloads/procmon) which show what happens when opening sdrangel.exe. I've filtered on sdrangel.exe (I have the full file if it helps) and you can use the Search button to look for strings containing e.g. "airspy" which may help locate the problem. I do see MSVCR100.dll as a fiile it's seeking and not finding, so I will try installing the relevant runtimes later today.


David J Taylor
 

SOLVED!

Fixed by installing: https://www.microsoft.com/en-us/download/details.aspx?id=14632

I see that using the Web interface to the group appears not to include the original text to which you are replying. This can make nonsense to those of us using e-mail, putting a reply such as "Yes" or "No" completely out of context. Could I ask that you include enough of the original material to add context to your reply.

Personally I prefer to see items in order - the reply after the question, not before it - but I appreciate that's not to everyone's taste.

73,
David GM8ARV
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


Siegfried Jackstien
 

ahh .... the c++ thingy was missing :-)

dg9bfc sigi

Am 08.02.2019 um 07:57 schrieb David J Taylor via Groups.Io:

SOLVED!

Fixed by installing: https://www.microsoft.com/en-us/download/details.aspx?id=14632

I see that using the Web interface to the group appears not to include the original text to which you are replying.  This can make nonsense to those of us using e-mail, putting a reply such as "Yes" or "No" completely out of context.  Could I ask that you include enough of the original material to add context to your reply.

Personally I prefer to see items in order - the reply after the question, not before it - but I appreciate that's not to everyone's taste.

73,
David GM8ARV


ne0xron@...
 

What would be nice for us non computers fellows and ladies is a live iso to burn and use for our sir setup. Dreamer ron ne0x


On Fri, Feb 8, 2019, 2:47 AM Siegfried Jackstien <siegfried.jackstien@... wrote:
ahh .... the c++ thingy was missing :-)

dg9bfc sigi

Am 08.02.2019 um 07:57 schrieb David J Taylor via Groups.Io:
> SOLVED!
>
> Fixed by installing:
> https://www.microsoft.com/en-us/download/details.aspx?id=14632
>
> I see that using the Web interface to the group appears not to include
> the original text to which you are replying.  This can make nonsense
> to those of us using e-mail, putting a reply such as "Yes" or "No"
> completely out of context.  Could I ask that you include enough of the
> original material to add context to your reply.
>
> Personally I prefer to see items in order - the reply after the
> question, not before it - but I appreciate that's not to everyone's
> taste.
>
> 73,
> David GM8ARV




David J Taylor
 

From: Ron-NE0X story

What would be nice for us non computers fellows and ladies is a live iso to burn and use for our sir setup. Dreamer ron ne0x
=================================

I don't see how your reply relates to the topic, but under Windows all that is needed is unzipping a .7z file, and double-clicking on the resulting .EXE (executable file). If that means nothing to you, ask a younger family member.

If you are a non-computer person you may have more difficulties with the Linux or Mac version.

Cheers,
David
--
SatSignal Software - Quality software for you
Web: http://www.satsignal.eu
Email: david-taylor@...
Twitter: @gm8arv


Siegfried Jackstien
 

you can imagine lots of things

even a plug and play iso for an sd card on a raspi or other sbc

a set and forget thingy

like the portsdown transmitter is for datv

but that would only work for one setup ... if you change things then you have also to change the software

....

so what you are asking for is not so easy

greetz sigi dg9bfc


Am 08.02.2019 um 11:17 schrieb Ron-NE0X story:

What would be nice for us non computers fellows and ladies is a live iso to burn and use for our sir setup. Dreamer ron ne0x

On Fri, Feb 8, 2019, 2:47 AM Siegfried Jackstien <siegfried.jackstien@... wrote:
ahh .... the c++ thingy was missing :-)

dg9bfc sigi

Am 08.02.2019 um 07:57 schrieb David J Taylor via Groups.Io:
> SOLVED!
>
> Fixed by installing:
> https://www.microsoft.com/en-us/download/details.aspx?id=14632
>
> I see that using the Web interface to the group appears not to include
> the original text to which you are replying.  This can make nonsense
> to those of us using e-mail, putting a reply such as "Yes" or "No"
> completely out of context.  Could I ask that you include enough of the
> original material to add context to your reply.
>
> Personally I prefer to see items in order - the reply after the
> question, not before it - but I appreciate that's not to everyone's
> taste.
>
> 73,
> David GM8ARV




Edouard Griffiths
 

Hello,

I would rather go in the direction of compiling from source and running inside a Docker container but I haven't put too much thinking into it yet.

Brgds, Edouard.