Topics

Debain Buster Deb package error on running


pseudonoise@...
 

Hi,
I've just upgraded to Buster and just installed the  sdrangel_4.9.0-1_amd64_buster.deb package. Unfortunately when I run the package from the console I get the following error -


2019-06-07 13:17:04.929 (I) PluginManager::loadPluginsDir: loaded plugin libudpsource.so Illegal instruction

Can someone please provide some pointers to a solution.

I've run the previous stretch version on Debian with a Pluto SDR to access QO-100 with great success - but I'm still learning how to use this great example of Linux programming.

Thanks,

James G1PVZ


Edouard Griffiths
 

Hi James,

some AVX instructions have leaked through which explains the 'illegal instruction' you are experiencing since your CPU may not support AVX. This issue has been already reported: https://github.com/f4exb/sdrangel/issues/360 

It should have been fixed in the 4.9.1 release published today.

Brgds, Edouard.


pseudonoise@...
 

Thanks Edouard - I'll try that release soonest.

Regards,

James