Topics

Audio Settings in SDRAngel for Windows not holding or disappearing


Marty Wittrock
 
Edited

Edouard / All -

Using the Windows version of SDRAngel I'm having a strange issue where the only audio preference setting that I can use is for the system default and no other setting. I've also seen the observed default audio sources that I should be able to select, and do try to select, have their 'D' disappear in the Audio Prefs menu the next time I enter to see if the setting held. The only setting I can get reliably is the system default that won't serve me well for setting up the audio for WSJT-X. This issue doesn't really affect me for receive - I use the system default and it runs fine. But for transmit I'm trying to set up an audio path that, initially, is a default and capable of being set up, but it neither 'holds' and when I go back in to set it up again it's no longer a default (the 'D' disappears next to the audio selection).

What's the most reliable way (other than switching OSs to Linux) to achieve this for Windows 10? Please let me know - I have some testing I would like to accomplish with my VOX RF Switch that I know works with the audio setting that I want to set up.

Let me know - TNX es 73 de Marty, KN0CK


Marty Wittrock
 

Okay - I've kind of answered my own question here...The only way to make your system defaults work in Windows is to SET THEM THAT WAY. I ended up setting my receive input audio port to the PC's audio resources and then set my transmit output up to work from a USB audio dongle. This way the my VOX RF Switch works because audio is present at the USB dongle and SDRAngel pulls the audio from the dongle's audio stream.

So, it's fixed..! I just have to set Windows audio resources in the WINDOWS AUDIO CONTROL PANEL IN WINDOWS SETTINGS and then force the defaults (i.e. 'Set as Default'). 

Working perfectly with SDRAngel on Windows now... :)

73 de Marty, KN0CK