Topics

SDRAngel troubles with audio input and file input


Edouard Griffiths
 

Hello Steve,

well I do not quite understand what you are trying to achieve. Maybe you should describe it step by step. But anyway the file recording feature is going to be reworked completely making a File Recorder channel plugin in its own right instead of being a feature of each device plugin. It makes more sense will add functionality like elapsed recording time and file size, the ability to record a part of the baseband and combine several of them in the same baseband and put the code in a single place. This will also make the combination Local Sink -> Local input with file recording obsolete. Issue https://github.com/f4exb/sdrangel/issues/543 refers.Please be patient...

Brgds,
Edouard.


steve@...
 

> BUMP <

No change.


steve@...
 

I have experimented off and on with SDRangel for a while.  However, the same problems that are show-stoppers keep coming up.  I have tried it on a couple of windows machines, and more importantly built the server version and also the GUI version on a linux server.  Everything appears normal.  I don't have an SDR but I'm trying to test decoding of DV/AMBE signals.  However, when I select LocalInput and a source, pressing "play" with signal coming in does nothing.  If I press the record button and then save the file, when I switch to FilleInput and try to load the .sdriq file it doesn't even show up.  This happens in both Linux and windows.  I've tried creating many files an converting them to the correct format with sox.  Oddly though, opening the file open dialog they simply don't even appear.  I see them in the OS's file browser, but SDRanger acts like they're not even there.  A few files do show up that I guess are being saved when I push the save button, but they all have zero byte lengths so that's not good.  Has anyone had any problems with this?  I've used this across multiple platforms, docker (where I just get a cryptic HTTP error) and for some reason it just doesn't work.  What are all the people that have it working doing?
Thanks,
Steve