Topics

Ubuntu Focal Fossa 20.04 LTS and libraries


Ethan Miller K8GU
 

Mick, et al,

Just an update: I had some time to play with it last night and this
morning. I was running sdrangel with sudo because I had not yet set
up all of the udev rules, etc, for the ADALM-Pluto via USB (not
Ethernet---a future activity). It appears that running it as a
privileged user broke the connection to pulseaudio, hence the NFM
crashes. Everything *appears* to be working now to the limited extent
I have tested so far.

For those interested in Ubuntu 20.04:

I am running SDRangel 4.14.6 that I pulled from github last night and
I built according to the step-by-step instructions (for 18.04) on the
github Wiki, only deviating to include only and exactly the set of
hardware I have: Pluto, RTL, and RSP-1a. I'm running the latest
Xubuntu 20.04LTS patches as of 00:00 UTC 20 May 2020 before I
compiled. Hardware is a NUC i5-4250U w/ 8 gB RAM.

Great software and support! Thanks, Edouard and the group!

73,

--Ethan, K8GU.

On 5/8/20, G1EUZ via groups.io <mickhannam=yahoo.com@groups.io> wrote:
[Edited Message Follows]

Ethan,

I have NFM Rx working with the apt install of limesuite:
limesuite is already the newest version (20.01.0+dfsg-2).

Here is a screenshot of my config on a 2m FM gateway:



--
http://www.k8gu.com/
Repair. Re-use. Re-purpose. Recycle.


Mick
 
Edited

Ethan,

I have NFM Rx working with the apt install of limesuite:
limesuite is already the newest version (20.01.0+dfsg-2).

Here is a screenshot of my config on a 2m FM gateway:

 


Ethan Miller K8GU
 

Mick/Edouard,

I am also playing with SDRAngel on 20.04 (having seen and disregarded
the 18.04 advice). However, I was building none of the LimeSDR
functionality nor paying attention to the TV libraries.

I'm having difficulty with the audio output for NFM from a Pluto, but
I have not spent a lot of time troubleshooting yet! I will correspond
once I have 1) made progress or 2) downgraded to 18.04. :)

73,

--Ethan, K8GU.

On 5/8/20, G1EUZ via groups.io <mickhannam=yahoo.com@groups.io> wrote:
[Edited Message Follows]

Edouard,

Apologies, I havent been on the forum for a while.

No problem.

Mick



--
http://www.k8gu.com/
Repair. Re-use. Re-purpose. Recycle.


Mick
 
Edited

Edouard,

Apologies, I havent been on the forum for a while.

No problem.

Mick


Edouard Griffiths
 

Hi Mick,

I thought I made it clear that only Ubuntu 18.04 is supported at the moment. However someone else might have an idea.

Brgds,
Edouard.


Mick
 

Edouard,

I see the snap available in 20.04 LTS is an old 5.1.0. When I run it it does not detect my LimeSDR Mini, so I move on.

I have grabbed the release version 4.14.5-1 and due to the nuances of 20.04 LTS I have to install using dpkg -i, this works and it detects my lime mini and functions with the decoders that make it through the install. But does grumble about the following libraries, which I guess is down to the 20.04 package list (libavcodec58 is the version in 20.04, etc):

sudo dpkg -i sdrangel_4.14.5-1_amd64.deb 
Selecting previously unselected package sdrangel.
(Reading database ... 434854 files and directories currently installed.)
Preparing to unpack sdrangel_4.14.5-1_amd64.deb ...
Unpacking sdrangel (4.14.5-1) ...
dpkg: dependency problems prevent configuration of sdrangel:
 sdrangel depends on libavcodec57 (>= 7:3.4.6) | libavcodec-extra57 (>= 7:3.4.6); however:
  Package libavcodec57 is not installed.
  Package libavcodec-extra57 is not installed.
 sdrangel depends on libavformat57 (>= 7:3.4.6); however:
  Package libavformat57 is not installed.
 sdrangel depends on libavutil55 (>= 7:3.4.6); however:
  Package libavutil55 is not installed.
 sdrangel depends on libopencv-core3.2; however:
  Package libopencv-core3.2 is not installed.
 sdrangel depends on libopencv-imgcodecs3.2; however:
  Package libopencv-imgcodecs3.2 is not installed.
 sdrangel depends on libopencv-imgproc3.2; however:
  Package libopencv-imgproc3.2 is not installed.
 sdrangel depends on libopencv-videoio3.2; however:
  Package libopencv-videoio3.2 is not installed.
 sdrangel depends on libqt5websockets5 (>= 5.6.0); however:
  Package libqt5websockets5 is not installed.
 sdrangel depends on libswresample2 (>= 7:3.4.6); however:
  Package libswresample2 is not installed.
 sdrangel depends on libswscale4 (>= 7:3.4.6); however:
  Package libswscale4 is not installed.
 
dpkg: error processing package sdrangel (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 sdrangel
 
I am happy to use the part broken build as I am not currently using DATV, DMR, etc.

I thought you might like the info above to help with any upcoming releases, hopefully I am not making a mistake and it is only package dependencies.

Kind regards

Mick