Test sdrangel port for Mac OSX Mojave #osx

Dana Shtun


I noted that with the SDRPlay Pro2 Decimation doesnt seem to show on the screen, 
ie. the frequency limits don’t change as you increase decimation.
Im using the SDR to monitor the IF of my K3 @ 8.214 Mhz…so decimation 
is helpful in narrowing down the displayed bandwidth, I think (? ) am I doing this correctly?

73 Dana VE3DS

On Jan 8, 2019, at 12:01, Žiga S. <ziga.svetina@...> wrote:

Dear Fabio,

Thanks for your interest and willingness to share your experiences.

I must admit that, I do not own LimeSDR mini, but maybe someday in future.
Everything I can do for now is read your reports, check the code and afterwards maybe find a solution to fix that "odd behaviours".
But first we would have to properly identify what this odd behaviours are.
I will trust your eyes and ears, whenever you are confident enough, that your have a simple explanation to what is going on wrong.
The going wrong is usually not having only one step to it, it could have more than one trigger and they can also be totally unrelated.

Useful test is already there, that what you were doing by using the sdrangel at first place.
Secondly, when discrepancies occur, please make sure to observe everything that could potentially be a trigger for the specific problem.
Try not to observe more than one problem at the same time.... on the end,
you will have to play with app quite a few times and your brain will eventually link the good explanation for the odd behaviour.
Most of the time simple behaviours are often reproducible, but when things get's nasty they are voodoo and random :)

These findings played out by your time and your intelligence, will be ours invaluable report for specific HW sink/source driver.

I hope my writing have cleared out some way or a plan of finding tests for unpleasant behaviours,
and I am looking forward for your more accurate report of the behaviours you experienced/experimented! 

Thanks and Best Regards,

Žiga S.

Hi Dana,

Thanks for your report.
I don't know, but I could test on the SDRplay HW in near future.
Is this the only problem you are observing,
have you been using SSB demod with RSP2Pro?

Cheerz, Z

Dana Shtun

Yes, using SSB Demodulator with SDRPlay.
HackRF works fine!
Running on Mojave.

73 Dana VE3DS

On Jan 21, 2019, at 03:32, Žiga S. <ziga.svetina@...> wrote:

Hi Dana,

Thanks for your report.
I don't know, but I could test on the SDRplay HW in near future.
Is this the only problem you are observing,
have you been using SSB demod with RSP2Pro?

Cheerz, Z

Keith Laaks

Hi Ziga,

I tested your "SDRangel-v4.3.2_20190103_003001-Qt5.12.0.dmg" over the weekend using a LimeSDR Mini.
I got the RX to work properly, using the SSB demodulator.
But I do find that after having started the receiver by clicking the 'triangle', if I stop the receive for whatever reason, I am not able to restart the receive again.
The only way I can get back to receiving in that condition is then to unplug the LimeSDR Mini, exit sdrangel plug lime back in; restart the program; click on the "start receive" button. 

I also tried TX. But having a similar issue - as soon as I stop the TX, I have to go through the above process to get anything to work again.
When in TX mode, the spectrogram does not seem to update consistently. But does sometimes come to life in flashes with some information displayed when hovering over it and moving the mouse. 

I have actually tried building the project myself using QT - but having some really odd errors.
For example in "qrtp-lib" 

On the first: #include <list> - compile fails with: 
/Users/keith.laaks/src/sdrangel_bundle/sdrangel/qrtplib/rtpudptransmitter.cpp:33: In file included from ../../sdrangel/qrtplib/rtpudptransmitter.cpp:33:
/Users/keith.laaks/src/sdrangel_bundle/sdrangel/qrtplib/rtpudptransmitter.h:37: In file included from ../../sdrangel/qrtplib/rtpudptransmitter.h:37:
/Applications/ error: invalid operands to binary expression ('const std::__1::__list_const_iterator<qrtplib::RTPAddress, void *>::value_type' (aka 'const qrtplib::RTPAddress') and 'const std::__1::list<qrtplib::RTPAddress, std::__1::allocator<qrtplib::RTPAddress> >::value_type' (aka 'const qrtplib::RTPAddress'))
        if (*__i == __x)
            ~~~~ ^  ~~~

Any advice?



Fabio IZ0IBA 2220156

Keith i confirm the i have the same behaviour with iMac Mojave and SDRAngel with LimeSDR Mini.  
The first reception starts correctly but if i stop rx i cannot restart it again. I also have to unplug LimeSDR ,close strangel, replug device and restart again.
Very annoying. It is surely some bug.  I guess that is related to SoapySDR driver.  
Have you also troubles in regulating gain as i have shown in this video ??