HackRF one with SDRangel under Windows 10 #windows

Thierry F4EWI

I installed SDR Console V3 and my HackRF One had be seen at the frist running. After that, I restarted my SDRangel and in the "Select from list" my HackRF is present.
Now when I try to listen a frequency I have the following message "Could not start sample source" ... An idea???


I have the same problem exactly, but can not find any solution.
I have an idea that the firmware is old.
When did you buy your HackRF ?

Kees van der Wal

I had the same problem and updated the firmware!  

Met vriendelijke groet,
Kees van der Wal

Thierry F4EWI

I didn't check the firmware and I don't know how to check it under Windows. The latest firmware version is 2018.01.1

William van Sutphen

Found the same problem.
Also upgrade the firmware to 2018.01.1 (most recent ?)

Got the same error

anybody any clues ?


Yes you must upgrade the firmware and the problem dissapears

Read the instructions "how to update firmware"

Download Linux 
Linux in USB stick or CD 
Download the bin file (HackRF firmware)
Run the command to upgrade the firmware

William van Sutphen

Thanks elfores,

Unfortunally, i did.
The firmware is upgraded to 2018.01.1 
today i did it again to be shure and of course, no change.
Still get the "could not start sample source"error

both the sdr# and sdr console v3 is working fine.
Perhaps i missed some driver or addon in the sdrangle software ?

hope someone can point me the right direction :-)