SDRangel install from source - kubunto 18.10


Freddy ON7VQ
 

Hi all, I tried to install SDRangel on my Kubuntu 18.10 and therefor followed the instructions I found here:

https://github.com/f4exb/sdrangel/wiki/Compile-from-source-in-LinuxI remarked and corrected that "libLMS7Support.so" is in directory ../modules0.8 and not ../modules0.7.
I decided to install as proposed in /opt/build and /opt/install that I chowned to this user and usergroup.
I try to include PlutoSDR, LimeSDR USB and Hackrf (this one for my Rad1o), and I use also Funcube Dongle .
I installed all the non-hardware dependencies, and the hardware dependencies for the hardware mentioned. This went well.
I also installed SoapySDR and the hardware plugins for my hardware described above.
I remarked and corrected that "libLMS7Support.so" is in directory ../modules0.8 and not ../modules0.7.
But then I could not manage to install correctly sdrangel. Executing  "make -j4 install" ended with a "error 2" after errors and warnings while installing freedv, sdrbase and lime-software.
I also remarked that while executing cmake, some packages were found in other directories. I have gnuradio-companion and LimeSuiteGiu installed on my system, the cmake command found libraries in these installs.
Could this be the cause of my install problem, and if so, who knows how to cure without the need to remove gnuradio and LimeSuiteGUI? I definitely do not wont to do this anyway.
Thanks for any help!
Freddy ON7VQ

Join sdrangel@groups.io to automatically receive all group messages.