Ubuntu Focal Fossa 20.04 LTS and libraries


Mick
 

Edouard,

I see the snap available in 20.04 LTS is an old 5.1.0. When I run it it does not detect my LimeSDR Mini, so I move on.

I have grabbed the release version 4.14.5-1 and due to the nuances of 20.04 LTS I have to install using dpkg -i, this works and it detects my lime mini and functions with the decoders that make it through the install. But does grumble about the following libraries, which I guess is down to the 20.04 package list (libavcodec58 is the version in 20.04, etc):

sudo dpkg -i sdrangel_4.14.5-1_amd64.deb 
Selecting previously unselected package sdrangel.
(Reading database ... 434854 files and directories currently installed.)
Preparing to unpack sdrangel_4.14.5-1_amd64.deb ...
Unpacking sdrangel (4.14.5-1) ...
dpkg: dependency problems prevent configuration of sdrangel:
 sdrangel depends on libavcodec57 (>= 7:3.4.6) | libavcodec-extra57 (>= 7:3.4.6); however:
  Package libavcodec57 is not installed.
  Package libavcodec-extra57 is not installed.
 sdrangel depends on libavformat57 (>= 7:3.4.6); however:
  Package libavformat57 is not installed.
 sdrangel depends on libavutil55 (>= 7:3.4.6); however:
  Package libavutil55 is not installed.
 sdrangel depends on libopencv-core3.2; however:
  Package libopencv-core3.2 is not installed.
 sdrangel depends on libopencv-imgcodecs3.2; however:
  Package libopencv-imgcodecs3.2 is not installed.
 sdrangel depends on libopencv-imgproc3.2; however:
  Package libopencv-imgproc3.2 is not installed.
 sdrangel depends on libopencv-videoio3.2; however:
  Package libopencv-videoio3.2 is not installed.
 sdrangel depends on libqt5websockets5 (>= 5.6.0); however:
  Package libqt5websockets5 is not installed.
 sdrangel depends on libswresample2 (>= 7:3.4.6); however:
  Package libswresample2 is not installed.
 sdrangel depends on libswscale4 (>= 7:3.4.6); however:
  Package libswscale4 is not installed.
 
dpkg: error processing package sdrangel (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 sdrangel
 
I am happy to use the part broken build as I am not currently using DATV, DMR, etc.

I thought you might like the info above to help with any upcoming releases, hopefully I am not making a mistake and it is only package dependencies.

Kind regards

Mick

Join sdrangel@groups.io to automatically receive all group messages.