Re: RQuantLib v4.0.0 for Ubuntu 20


Dirk Eddelbuettel
 

On 14 May 2020 at 09:17, John Paul Broussard wrote:
| Thanks Dirk.  Unfortunately, I have loaded the latest QuantLib (1.18 I think) - still same RQuantLib install error.  I loaded the items you indicate, still same RQuantLib install error. Could there a library still "lingering" somewhere in my system from a previous "bad" install?  How might I completely purge QuantLib so that I can restart from the tar file downloaded from quantlib.org?

We would need more details. I am on 19.10, everything works and should / will
once upgraded. I would recommend you check and double-check all components: R
(works, I presume), Rcpp, QuantLib and then RQuantLib.

edd@rob:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.10
Release: 19.10
Codename: eoan
edd@rob:~$ dpkg -l|grep quantlib|cut -c-79
ii libquantlib0-dev 1.18-1.1910.1
ii libquantlib0v5 1.18-1.1910.1
ii quantlib-examples 1.18-1.1910.1
ii quantlib-python 1.16-1.1904.0
edd@rob:~$ Rscript -e 'library(RQuantLib); packageVersion("RQuantLib")'
[1] ‘0.4.12’
edd@rob:~$

So my RQuantLib is from source.

Dirk

--
http://dirk.eddelbuettel.com | @eddelbuettel | @edd

Join rquantlib@groups.io to automatically receive all group messages.