Re: Error installing package on CentOS 7


Dirk Eddelbuettel
 

On 11 September 2019 at 04:50, beppeg@gmail.com wrote:
| Dear all,
| I'm going crazy to install the package on CentOS 7.
| Required QuantLib library installed from EPEL repository via yum seems to be < 1.14 so I installed successfully 1.16 release compiling from sources.
|
| Installing R-package I get following error:
|
| *** caught segfault ***
| address 0x7f2370de92a0, cause 'invalid permissions'
|
| Error occurs loading library after compilation.
|
| Did someone have and solved the problem?
| Ther's some tutorial/hint about installation on CentOS 7?

Segfauls are sometimes a symptom of mismatched libraries. Make sure QuantLib
and Rcpp are built with the same compiler, so if you installed QuantLib from
source, also install Rcpp from sources.

Also, after building QuantLib, it might be a good idea to run its test
suite.

Dirk

--
http://dirk.eddelbuettel.com | @eddelbuettel | edd@debian.org

Join rquantlib@groups.io to automatically receive all group messages.