Topics

pcb-gcode and eagle 8 problems

Quentin Dewolf
 

when I try to use pcb-gcode in either 8.0.0 or 8.0.1 of eagle the system goes into an infinite loop after making the first top etch file. most of the time and I have to click the stop button to do anything. every so often it works to completion.

 I have eagle 7.7 on the same system pointed at all of the same directories and it works fine. help?

Richard Kelly
 

Yes I’ve had the same issue and spent some time exploring why just one of my boards worked correctly.

Its something to do with the top level ‘pour’ polygon and the board outline (The wire one on layer 20)

If there is no polygon it appears to create one that is slightly bigger than the wire one on layer 20, this then stalls the script as your experiencing.

If however you draw a polygon on the top layer around your board - it doesn’t seem to matter what size, just go bigger than your physical board and it then works.

Beware however if you have tried to run PCB-Gcode against a board that has failed you will have multiple (num depends on how many failed attempts you have had) polygons the size of the wire frame that need deleting first.

I haven’t yet understood exactly what is going wrong but this work around has allowed me to create PCB’s using ver 8 and 8.01

Hope this helps you

Ric

mlmcnc
 

Your exploration was correct.
You need to use the wire command to draw a line which represents the perimeter of your board design.
This line is put on the Dimension layer (20) and has a width of 0.

It is also useful to also use the wire command to draw the path of the cutter which you will use to mill out the PCB. This is drawn on the milling layer (46).
In order to properly represent this cutout, it is advisable to set the line width to that of the cutter you will use. Clearly this line will need to be offset by half the width of the cutter. You may wish to to put breaks in this line so as to leave tabs to hold the PCB in place.

peterg1000
 

Hi,

I've had exactly the same problems with revisions 8.0.0 and 8.0.1, though on some occasions 8.0.1 did terminate if the polygon borders did not correspond to the board outline on layer 20.

Revision 8.0.2 is now available, and it seems the problem is cured - at least I have had at least 10 clear runs on one board that failed every time on previous revisions. Layers 1 and 16 polygon outlines were made identical to the board outline for the test runs.

Meanwhile I won't be dumping rev 7.7.0 any time soon, I've lost confidence in 8.x.x - for the time being anyway.

Peter

Hans Boot
 

To add a bit of info:

The image/UI problem issue that was mentioned on phorum (sorry, have not registered there yet) can be solved easily by replacing 
img src='docs
by
img src='" + g_path + "/docs 
on 3 occasions in pcb-gcode-setup.ulp

Remains indeed that there are more problems with 8.x.x, licensing being also one of them.

Hans

 

peterg1000
 

Hans,

Thanks for that fix - works a treat!!

Just downloaded and tested the latest revision (8.2.1). It seems that the problems surrounding polygons and the pcb-gcode ulp have finally been resolved - at least I couldn't break it with a quick test.

No difficulties with licensing the free version - just have to occasionally log in to keep the license current (it seems to last just 2 weeks before requiring renewal).

Peter