Topics

Eagle 8.6.3. on Windows 10 permission denied #eagle #gcode

Jos Raven
 

I cannot solve this problem on my Windows 10 installed EAGLE 8.6.3.

Can't open C:\EAGLE 8.6.3\ulp\viewer\application.windows\data\optimize_me.txt
Permission denied

I have absolutely no idea how to set the permission for Win 10.

Help please!

John Swenson
 

Hi Jos,
this has nothing to do with Windows 10, the viewer pops up when generating a G-code file and is looking at the mentioned file. IF your run generates another G-code file, it tries to pop up a new instance of the viewer to display THAT G-code, since the file is already being used by another instance the OS won't let the new viewer open it.

The solution is to manually kill the first viewer (click the X in the upper right) before starting the generation of the second G-code file.

This whole scenario happens when you have something else enabled other than an "etch", such as milling, or text, or drilling, each of these gets its own G-code file.

I think this will fix your problem.

John S.

On 5/19/2019 5:18 AM, Jos Raven wrote:
I cannot solve this problem on my Windows 10 installed EAGLE 8.6.3.
Can't open C:\EAGLE 8.6.3\ulp\viewer\application.windows\data\optimize_me.txt
Permission denied
I have absolutely no idea how to set the permission for Win 10.
Help please!

Jos Raven
 

Yes, John,
you are right !!
Following your  instruction it works .
On my Win 10 PC I user PCB-GCODE ver. 3.6.2.4

However , on my other PC I have EAGLE 7.2.0 and PCB_GCODE ver. 3.6.0.2 
The problem does not occur with this set-up.
I have, in my configuration, 6 viewer windows open with no problem.
However the windows are reduced to icons on the taskbar.

Thank you for your help,
Regards,
Jos

Jos Raven
 

Edit;

My other PC runs on Windows 7 .

Jos