Date   
Re: changing "allway climb" and "normal" in midst of the job #pcbgcode #development

John Johnson
 

Unfortunately, this is due to the way Eagle creates polygons.
Your best bet is to find some gcode editor that will allow you to reverse the line directions in the files that pcb-gcode creates.

Regards,
JJ

On 30 Jun 2019, at 12:47, harry0099@... wrote:

Hello comrades!

I use pcb-gcode.ulp for some time now and get decent results, probing the copper surface with OpenCNCPilot.

But I realized, that the edges of the second+ rounds are not as good as the first one.

That is easily explained, since the milling bit is rotating cw and the bit moves in the correct direction for the first run, but in the wrong direction ("climbing") for all sucessive rounds.

Now pcb-gcode.ulp has the option to select „always climb“ to change the direction of the bit on its way, but this option changes the behavior for *all* rounds.

I wanted to implement another option which allows for turning on the „always climb“ selection only for the second and all following rounds, but I can’t fiddle out where in the code I may attack.

So my question to all of you:

Can anyone give me a hint, where in the code I can start to look, or even better, where the decision between the first and all successive rounds is made?

Explanation:
I think I observed, that pcb-gcode does one first round in which it surrounds all traces once, so when stopping after this first round, one would have a functioning board with all traces as expected, but with too narrow trenches.
The following rounds only widen the already defined trenches to ease soldering.
All following rounds erode the "other side" of the trenches but this happens in "climb mode", resulting in not so good edges.
So I consider it as good practise to change the moving direction of those following rounds to make them again "normal".

Thanks in advance!

Harry

changing "allway climb" and "normal" in midst of the job #pcbgcode #development

harry0099@...
 

Hello comrades!

I use pcb-gcode.ulp for some time now and get decent results, probing the copper surface with OpenCNCPilot.

But I realized, that the edges of the second+ rounds are not as good as the first one.

That is easily explained, since the milling bit is rotating cw and the bit moves in the correct direction for the first run, but in the wrong direction ("climbing") for all sucessive rounds.

Now pcb-gcode.ulp has the option to select „always climb“ to change the direction of the bit on its way, but this option changes the behavior for all rounds.

I wanted to implement another option which allows for turning on the „always climb“ selection only for the second and all following rounds, but I can’t fiddle out where in the code I may attack.

So my question to all of you:

Can anyone give me a hint, where in the code I can start to look, or even better, where the decision between the first and all successive rounds is made?

Explanation:
I think I observed, that pcb-gcode does one first round in which it surrounds all traces once, so when stopping after this first round, one would have a functioning board with all traces as expected, but with too narrow trenches.
The following rounds only widen the already defined trenches to ease soldering.
All following rounds erode the "other side" of the trenches but this happens in "climb mode", resulting in not so good edges.
So I consider it as good practise to change the moving direction of those following rounds to make them again "normal".


Thanks in advance!

Harry

Re: Eagle 8.6.3. on Windows 10 permission denied #gcode #eagle

Jos Raven
 

Edit;

My other PC runs on Windows 7 .

Jos

Re: Eagle 8.6.3. on Windows 10 permission denied #gcode #eagle

Jos Raven
 

Yes, John,
you are right !!
Following your  instruction it works .
On my Win 10 PC I user PCB-GCODE ver. 3.6.2.4

However , on my other PC I have EAGLE 7.2.0 and PCB_GCODE ver. 3.6.0.2 
The problem does not occur with this set-up.
I have, in my configuration, 6 viewer windows open with no problem.
However the windows are reduced to icons on the taskbar.

Thank you for your help,
Regards,
Jos

Re: Eagle 8.6.3. on Windows 10 permission denied #gcode #eagle

John Swenson
 

Hi Jos,
this has nothing to do with Windows 10, the viewer pops up when generating a G-code file and is looking at the mentioned file. IF your run generates another G-code file, it tries to pop up a new instance of the viewer to display THAT G-code, since the file is already being used by another instance the OS won't let the new viewer open it.

The solution is to manually kill the first viewer (click the X in the upper right) before starting the generation of the second G-code file.

This whole scenario happens when you have something else enabled other than an "etch", such as milling, or text, or drilling, each of these gets its own G-code file.

I think this will fix your problem.

John S.

On 5/19/2019 5:18 AM, Jos Raven wrote:
I cannot solve this problem on my Windows 10 installed EAGLE 8.6.3.
Can't open C:\EAGLE 8.6.3\ulp\viewer\application.windows\data\optimize_me.txt
Permission denied
I have absolutely no idea how to set the permission for Win 10.
Help please!

Eagle 8.6.3. on Windows 10 permission denied #gcode #eagle

Jos Raven
 

I cannot solve this problem on my Windows 10 installed EAGLE 8.6.3.

Can't open C:\EAGLE 8.6.3\ulp\viewer\application.windows\data\optimize_me.txt
Permission denied

I have absolutely no idea how to set the permission for Win 10.

Help please!

Re: New Machine #migration

keith3125
 

I don't know if you're using Windows 10 but the display settings are a little crazy.
I did find a way to see the 'accept' button...portrait to landscape. But navigating the mouse is insane even just to click the button.

On Tuesday, April 23, 2019, 7:57:27 PM MDT, Bruce Gennette <brucegennette@...> wrote:


If you only need to get to the buttons once, how about temporarily changing the screen resolution for the few seconds you need to click the button.

* shrink the application window to the menu bar  [click on the minus symbol at top right]
* right click on desktop
* left click on Display Settings
* left click in Resolution box
***   write down current resolution
* scroll to the left click on 1024 x 768
* left click on Keep changes
* bring the window up to full size (click on it in the menu bar)
* make your choices

Then repeat all above to get your normal resolution restored


I haven't tried this because I don't need it, but it should work fine.  If not try a 'custom' resolution that is taller.
Let me (and everyone else) know how it goes.

bye.



On Wed, 24 Apr 2019 at 06:07, John Johnson <john@...> wrote:
Usually when the window is too large, it means the image displayed at the top,of the window couldn’t be found. You can check your install against the manual, search the forum here for people that have had this issue, or edit the pcbgcode-setup.ulp file and remove the references to the image. 

Hope this helps,
John

-- 
John Johnson

From: keith3125 via Groups.Io <kc1of36@...>
Reply: pcbgcode@groups.io <pcbgcode@groups.io>
Date: April 23, 2019 at 3:47:21 PM
To: pcbgcode@groups.io <pcbgcode@groups.io>
Subject:  Re: [pcbgcode] New Machine #migration

Wish there were hotkeys

On Tuesday, April 23, 2019, 1:32:48 PM MDT, <stock@...> wrote:


I have the same issue... have to use an old square monitor and then i get to the buttons.

Re: New Machine #migration

keith3125
 

Must I 'shrink' the app window? Because in the 'setup screen, there's no '-'. Just an 'X' and a '?'
Anyway around that?

On Tuesday, April 23, 2019, 7:57:27 PM MDT, Bruce Gennette <brucegennette@...> wrote:


If you only need to get to the buttons once, how about temporarily changing the screen resolution for the few seconds you need to click the button.

* shrink the application window to the menu bar  [click on the minus symbol at top right]
* right click on desktop
* left click on Display Settings
* left click in Resolution box
***   write down current resolution
* scroll to the left click on 1024 x 768
* left click on Keep changes
* bring the window up to full size (click on it in the menu bar)
* make your choices

Then repeat all above to get your normal resolution restored


I haven't tried this because I don't need it, but it should work fine.  If not try a 'custom' resolution that is taller.
Let me (and everyone else) know how it goes.

bye.



On Wed, 24 Apr 2019 at 06:07, John Johnson <john@...> wrote:
Usually when the window is too large, it means the image displayed at the top,of the window couldn’t be found. You can check your install against the manual, search the forum here for people that have had this issue, or edit the pcbgcode-setup.ulp file and remove the references to the image. 

Hope this helps,
John

-- 
John Johnson

From: keith3125 via Groups.Io <kc1of36@...>
Reply: pcbgcode@groups.io <pcbgcode@groups.io>
Date: April 23, 2019 at 3:47:21 PM
To: pcbgcode@groups.io <pcbgcode@groups.io>
Subject:  Re: [pcbgcode] New Machine #migration

Wish there were hotkeys

On Tuesday, April 23, 2019, 1:32:48 PM MDT, <stock@...> wrote:


I have the same issue... have to use an old square monitor and then i get to the buttons.

Re: New Machine #migration

Bruce Gennette
 

If you only need to get to the buttons once, how about temporarily changing the screen resolution for the few seconds you need to click the button.

* shrink the application window to the menu bar  [click on the minus symbol at top right]
* right click on desktop
* left click on Display Settings
* left click in Resolution box
***   write down current resolution
* scroll to the left click on 1024 x 768
* left click on Keep changes
* bring the window up to full size (click on it in the menu bar)
* make your choices

Then repeat all above to get your normal resolution restored


I haven't tried this because I don't need it, but it should work fine.  If not try a 'custom' resolution that is taller.
Let me (and everyone else) know how it goes.

bye.



On Wed, 24 Apr 2019 at 06:07, John Johnson <john@...> wrote:
Usually when the window is too large, it means the image displayed at the top,of the window couldn’t be found. You can check your install against the manual, search the forum here for people that have had this issue, or edit the pcbgcode-setup.ulp file and remove the references to the image. 

Hope this helps,
John

-- 
John Johnson

From: keith3125 via Groups.Io <kc1of36@...>
Reply: pcbgcode@groups.io <pcbgcode@groups.io>
Date: April 23, 2019 at 3:47:21 PM
To: pcbgcode@groups.io <pcbgcode@groups.io>
Subject:  Re: [pcbgcode] New Machine #migration

Wish there were hotkeys

On Tuesday, April 23, 2019, 1:32:48 PM MDT, <stock@...> wrote:


I have the same issue... have to use an old square monitor and then i get to the buttons.

Re: New Machine #migration

John Johnson
 

Usually when the window is too large, it means the image displayed at the top,of the window couldn’t be found. You can check your install against the manual, search the forum here for people that have had this issue, or edit the pcbgcode-setup.ulp file and remove the references to the image. 

Hope this helps,
John

-- 
John Johnson

From: keith3125 via Groups.Io <kc1of36@...>
Reply: pcbgcode@groups.io <pcbgcode@groups.io>
Date: April 23, 2019 at 3:47:21 PM
To: pcbgcode@groups.io <pcbgcode@groups.io>
Subject:  Re: [pcbgcode] New Machine #migration

Wish there were hotkeys

On Tuesday, April 23, 2019, 1:32:48 PM MDT, <stock@...> wrote:


I have the same issue... have to use an old square monitor and then i get to the buttons.

Re: New Machine #migration

keith3125
 

Wish there were hotkeys

On Tuesday, April 23, 2019, 1:32:48 PM MDT, <stock@...> wrote:


I have the same issue... have to use an old square monitor and then i get to the buttons.

Re: New Machine #migration

stock@...
 

I have the same issue... have to use an old square monitor and then i get to the buttons.

Latest Mac Setup #eagle #pcbgcode

mswa@...
 

Hi,
Please post latest stable entry level versions of eagle/pcb-gcode versions for mac, now that I have a functional CNC mill ??
thx
jerico

New Machine #migration

keith3125
 

Trying to setup PCBGCODE on a new machine (Windows 10). Got far enough to settings page but can't size the window to see/reach the 'accept' button.
Closed it down and just tried 'run' on a board got message: Windows cannot find 'javaw.exe' Make sure you typed the name correctly and then try again. Closed that and get : Error calling ShellExecuteEx0

Any ideas?

Re: Optimizer not working any more #pcbgcode #eagle

AlbertHall
 

Terrific!   Where do I get it, can you upload files on here?

Re: Optimizer not working any more #pcbgcode #eagle

AlbertHall
 

But this would require changing the control hardware on my mill.  I am not that desperate yet!

Re: Optimizer not working any more #pcbgcode #eagle

morntech asia
 

I have a version from 12-8-2008 for you!! (0_1_7)

Roel

Op vr 19 apr. 2019 om 19:34 schreef Patrick <pknoe3lh@...>:


On Fri, Apr 19, 2019, 13:30 AlbertHall <jim@...> wrote:
I have been using optimizer
"Optimizer for PCB Gcode. By Daniel Purvis and Jay Couture
Version: 1.1 Releases 8/1/2008"
But it doesn't work anymore.  It brings up a dos box with the input and output paths and then just hangs.
Any ideas?
Can I download a new copy?  I couldn't find a download source.

Re: Optimizer not working any more #pcbgcode #eagle

Patrick
 


On Fri, Apr 19, 2019, 13:30 AlbertHall <jim@...> wrote:
I have been using optimizer
"Optimizer for PCB Gcode. By Daniel Purvis and Jay Couture
Version: 1.1 Releases 8/1/2008"
But it doesn't work anymore.  It brings up a dos box with the input and output paths and then just hangs.
Any ideas?
Can I download a new copy?  I couldn't find a download source.

Optimizer not working any more #pcbgcode #eagle

AlbertHall
 

I have been using optimizer
"Optimizer for PCB Gcode. By Daniel Purvis and Jay Couture
Version: 1.1 Releases 8/1/2008"
But it doesn't work anymore.  It brings up a dos box with the input and output paths and then just hangs.
Any ideas?
Can I download a new copy?  I couldn't find a download source.

Re: Can't open 'c:\storage.nv' permission denied #pcbgcode

abyset2105@...
 

Mine worked just fine in win10 as "C:\EAGLE-9.3.0" after i elevated all permissions for that folder (including subfolders).
But i like the solution of putting the files in server and i think i will go for it, thanks Chipteck.