Topics

Installing openssl_tpm2_engine-2.3.0...

James Bottomley
 

[adding the list because we actually have one now]

On Wed, 2019-05-29 at 18:48 +0000, Sievert, James wrote:
Hi James,

I've configured openssl_tpm2_engine-2.3.0<https://git.kernel.org/pub/
scm/linux/kernel/git/jejb/openssl_tpm2_engine.git/snapshot/openssl_tp
m2_engine-2.3.0.tar.gz> as follows:

CFLAGS=-I../rootfs/include LDFLAGS="-L../rootfs/lib" ./configure --
prefix=$(pwd)/../rootfs

I'm finding that "make install" doesn't abide by the --prefix option:

ubuntu@ip-10-132-42-78:~/platforms/vss/CS/Tempest/src/packages/src/Op
ensslTpm2EnginePackage/openssl_tpm2_engine-2.3.0$ make install
Making install in tests
make[1]: Entering directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/tests'
make[2]: Entering directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/tests'
make[2]: Nothing to be done for 'install-exec-am'.
make[2]: Nothing to be done for 'install-data-am'.
make[2]: Leaving directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/tests'
make[1]: Leaving directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/tests'
make[1]: Entering directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0'
make[2]: Entering directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0'
/bin/mkdir -p
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/../rootfs/bin'
/bin/bash ./libtool --mode=install /usr/bin/install -c
create_tpm2_key load_tpm2_key
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/../rootfs/bin'
libtool: install: /usr/bin/install -c create_tpm2_key
/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2Eng
inePackage/openssl_tpm2_engine-2.3.0/../rootfs/bin/create_tpm2_key
libtool: install: /usr/bin/install -c load_tpm2_key
/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2Eng
inePackage/openssl_tpm2_engine-2.3.0/../rootfs/bin/load_tpm2_key
/bin/mkdir -p
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/../rootfs/share/man/man1'
/usr/bin/install -c -m 644 create_tpm2_key.1 load_tpm2_key.1
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0/../rootfs/share/man/man1'
/bin/mkdir -p '/usr/lib/x86_64-linux-gnu/engines-1.1'
/bin/bash ./libtool --mode=install /usr/bin/install -c libtpm2.la
'/usr/lib/x86_64-linux-gnu/engines-1.1'
libtool: install: /usr/bin/install -c .libs/libtpm2.so
/usr/lib/x86_64-linux-gnu/engines-1.1/libtpm2.so
/usr/bin/install: cannot create regular file '/usr/lib/x86_64-linux-
gnu/engines-1.1/libtpm2.so': Permission denied
Makefile:474: recipe for target 'install-openssl_engineLTLIBRARIES'
failed
make[2]: *** [install-openssl_engineLTLIBRARIES] Error 1
make[2]: Leaving directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0'
Makefile:1046: recipe for target 'install-am' failed
make[1]: *** [install-am] Error 2
make[1]: Leaving directory
'/home/ubuntu/platforms/vss/CS/Tempest/src/packages/src/OpensslTpm2En
ginePackage/openssl_tpm2_engine-2.3.0'
Makefile:745: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1
Got to confess, this isn't something I've tried directly (so I will
test it out and see what the problem is). However, both the openSUSE
and debian packages which are built from this, use the --prefix option
in some form and they all seem to install correctly, so there's
something different about the way you did it that I'll have to figure
out.

James