Re: Feature on 500e Embroidery-only machine

Kathy Strabel
 

Thank you to those who replied to my thread breakage/no warning from my machine (500e).  I have checked and re-checked all the usual things, even put ANOTHER new needle in -topstitch style, which is my usual for embroidery. I was able to finish that design from yesterday (the bird made of swirls), but I still had to stop a few more times for broken thread--and no announcement or stopping of the needle from my machine.   SO now I am working on another design--I checked the upper thread sensor setting and the box is checked that it is "ON". I even turned it off, waited a minute, then turned it back on. My new design is stitching along as I am typing this, but it has already had one thread break, and the machine did not stop; I am not leaving the room while stitching!!   Does anyone know "where" the upper thread sensor is located in the machine? Maybe I have a piece of lint or thread blocking that sensor? I did clean and oil the machine about 2 weeks ago, and have used it before the last couple of days for these gifts I am making.  I had no trouble at all. It appears that the thread sensor is malfunctioning---I don't want to take it to the dealer if there is just a piece of errant thread or lint blocking its way, so if anyone can tell me where to look to locate the thread sensor--what it looks like, etc. Then I could just put my mini-vacuum attachment near it and get it cleaned out. If that does not work, then I would take it in. Can't do without the warning about a thread break and the machine stopping. Does the low bobbin warning also work off of the thread sensor? My bobbin has not yet been low enough to trigger that warning.   Oh, and also, there is no tension issue, and no burrs on the needle plate, or anywhere that I can determine along the thread path.   ARGHHHH!!!!
Kathy Strabel    Camas WA

Join onlinesewing-janome@groups.io to automatically receive all group messages.