Re-flashing bricked ODY-2


Neoklis Kyriazis
 

Hi all

After several months of waiting (since January 2020!) I at last received the
PICkit and USB blaster that are needed to re-flash my ODY-2, which I bricked
last year. I ordered from Ali Express but was interrupted by the virus!

Anyhow, to avoid making more mistakes and possibly ruining the ODY-2,
I wonder if there are any detailed instructions I can use to repair the SDR.
And also suggestions of what firmware to use for the repair.

My thanks in advance!

--
Best Regards
Neoklis - Ham Radio Call:5B4AZ
http://www.5b4az.org/
https://www.qsl.net/5b4az/index.html


David Fainitski
 

Hello, Neoklis
Read this first
https://groups.io/g/ody-sdr/topic/program_2_1_20_anp_into_a/76521763?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,0,0,76521763


Steven Wilson
 

David,

The radio is currently bricked.  I made the mistake of trying to program it with the radio plugged in and turned on.  

I'm also pretty sure that the Pickit 3 isn't any good in the first place.  Tell me - should it show up as a COM port when I plug it in?? It isn't showing up in the Device Manager at all, nor working under Linux either.

Steve


Sid Boyce
 

One problem here, Bootloader display is all garbled, only ODYSSEY display is OK.
73 ... Sid.

On 17/09/2020 15:44, David Fainitski wrote:
Hello, Neoklis
Read this first
https://groups.io/g/ody-sdr/topic/program_2_1_20_anp_into_a/76521763?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,0,0,76521763
--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
Senior Staff Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks


Steven Wilson
 

I had the same issue with my older mcu code.  It wasn't so much garbled..but looked like many pixels missing. It aged. Odyssey displayed cleanly though.


On Thu, Sep 17, 2020, 2:09 PM Sid Boyce <boyce.sid@...> wrote:
One problem here, Bootloader display is all garbled, only ODYSSEY
display is OK.
73 ... Sid.

On 17/09/2020 15:44, David Fainitski wrote:
> Hello, Neoklis
> Read this first
> https://groups.io/g/ody-sdr/topic/program_2_1_20_anp_into_a/76521763?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,0,0,76521763
>
>


--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
Senior Staff Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks







Sid Boyce
 

Hi Steve,
That's a more fitting description of what I am seeing.
I have no idea what Bootloader version was loaded when it returned from David a very long time ago.
73 ... Sid.

On 17/09/2020 22:26, Steven Wilson wrote:
I had the same issue with my older mcu code.  It wasn't so much garbled..but looked like many pixels missing. It aged. Odyssey displayed cleanly though.

On Thu, Sep 17, 2020, 2:09 PM Sid Boyce <boyce.sid@gmail.com <mailto:boyce.sid@gmail.com>> wrote:

One problem here, Bootloader display is all garbled, only ODYSSEY
display is OK.
73 ... Sid.

On 17/09/2020 15:44, David Fainitski wrote:
> Hello, Neoklis
> Read this first
>
https://groups.io/g/ody-sdr/topic/program_2_1_20_anp_into_a/76521763?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,0,0,76521763

>
>


--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
Senior Staff Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks






--
Sid Boyce ... Hamradio License G3VBV, Licensed Private Pilot
Emeritus IBM/Amdahl Mainframes and Sun/Fujitsu Servers Tech Support
Senior Staff Specialist, Cricket Coach
Microsoft Windows Free Zone - Linux used for all Computing Tasks


David Fainitski
 

Hello, Steven.
Please check the reset pin of MCU.


sshutyayev@...
 

Hi David,

I not want to create new topic, due my problem little related to existed one:

I made my Odyssey-2 bricked by loading to wrong slot firmware (to slot 0). For now Odyssey's OLED dark, all 4 LED indication permanently, not blinking. I found Quartus II V 11.0 and trying to load bootloader back. I got message from Quatus: 


I tried different bootloders, but same result. Any *.pof files corrupted. What could be wrong? Thanks!
I follow instructions like here Tutorial


Reto HB9TRT
 

Use an actual quartus version like 20.1 lite (it's free) there's a programmer included everywhere in the menu (I can't remember without sitting in front of A PC). You will find it. The menu point is clear "Programmer"

I think you have a too old quartus version. The files are compiled with quartus 19.

Vy 73 
Reto 


David Fainitski
 

Hello.
All other versions have been deleted from Github. Only 2.1 is available.
Please download all the repository from here as a zip archive and use files from it.
https://github.com/Dfinitski/Odyssey-2_2017_TRX