FPGA ERROR


Luca Fusari
 

Hi All,
i have implemented the Odyssey II PCB V12, using componets, indicated in BOM,  purchased at Digikey.
Please refer to the attached picture.
Following the Reto's document procedure i have successfully installed , from BL_2.1 repository  : MCU firmware and bootloader.pof.
The installation log results  are exactley the same as indicated in the Reto's document. Please refer to the attached document translated in English , with the support of google transator.
Power consumption is only 220mA and the display continue to indicate "FPGA ERROR" also after the installation of bootloader.pof
I have tried to force bootloader mode connecting together all pins of key connector and power on. Nothing change
I have verified:
-all the voltages values at the voltage regualtors
-all the clock signals at the reference oscillator
-no voltages at the audio amplifier.
 
Please suggest me some troubleshooting actions.

Many Thanks !

73

IK2LRN Luca



Reto HB9TRT
 

Plugin a Headphone to key plug and reboot ody. Should work. 

Vy 73 
Reto 


David Fainitski
 

Behaviour of 4 LEDs is critical in this case.


Luca Fusari
 

Hi David,
i have tried to short the key pins  and power on .but nothing change
All 4 led remains fixed on.


Luca Fusari
 

Hi Davide,
i have connected LAN cable from my PC to Odyssey II. The Ethenet leds does not blink. I have verified all the soldering, including the resistor array but it seams to be OK.
How i can verify is the KSZ chipset work correctly ? For a bad ground soldering of the 3.3V regulator a 5 voltage, instead of 3.3 has been applied for less than one minute. Do you suggest to replace it ?
Thanks
73
Luca


herojh@...
 

HI luca
 some ideas for you hope will be help
1. change the resistor left W25Q64 4.7K Network Resistor to 10K 
2. check all vpp 3.3V  2.5V 1.8V 1.2V
3.check all clock  122.88mhz left FPGA mark c1 c1 ,10MHZ  25MHZ and ksz9031 125mhz output (PIN 55) 
4.
Remove SC189C (phy core 1.2v power supply,)  and around 5 parts (1ps 1uh 2pcs 470r fb 2pcs 4.7uf)  and link the P1.(This problem only for me , when I  use this DC-DC regulators  for phy core vcc ,this part over 60℃)
              yours bg2kkq


Luca Fusari
 

Hi, thanks for your suggestions.
Do you agree that anyway the physical ethernet connection should be established ? The Ethernet led are all off. I have checked all voltages at the regulators.
10M 25M 122M  oscillators are working. 

73
Luca


Luca Fusari
 

Hi
I have verified that 25MHz clock is working and output 125MHZ clock form 
KSZ9031RNX at pin 41 is present and very stable. I think that it menas that Ethernet chipset is working.
I have verified that all the 4K7 resistor arrays, close to KSZ9031RNX are correctly soldered.
I think that the phisical Ethernet connection should be indipendent with the FPGA situation . Do you agree ?
73
Luca


herojh@...
 

HI luca 
  the phy connection under bootloader or  ANP/AOP , your oled show fpga error ,so the system  have some problem 
  use usb blaster program w25q64 with bootloader don't mean the pfga loader the bootloader form rom correctly 
  beacuse in your description of all 4pcs led was not twinkel   
           bg2kkq


Luca Fusari
 

OK, i will purchase the 10k resistor array replacement and i will let you know.
73
Luca IK2LRN


David Fainitski
 

Luca, FPGA is not started. LEDs should to blink when started. Are you sure in quality soldering ?


Luca Fusari
 

Hi Davide,

thank you for your kind support.

I have used the reflow oven for the first time.

For the FPGA soldering i have used infrared reflow oven T962 program 3, as suggested by Reto and Yuri.

I have tinned the  PCB pins thinking that FPGA does not have itself tin.

Maybe i have tinned too much ? I don't know.

I have another Odyssey PCB and a new FPGA. I intend to use reflow oven without tinning the PCB, like in your video.

Any other suggestions?

Regarding the QFN chipset i have previously successfully soldered Radioberry.

I have also successfully implemented two SDR Tulip and PiHPSDR V2

73

Luca IK2LRN 


Reto HB9TRT
 

Hi Luca 

Fpga has tin balls. So the pads should only be tinned. Not e heap of tin. 

Vy 73 
Reto 


David Fainitski
 

Luca, check the FPGA package is moving little bit before finish soldering. Probably not enough temperature or time. Do a calibration if it is possible.


Luca Fusari
 

Hi Davide,
which is the correct behavior of LEDs when only bootloader has been installed ?
Clocks at C1 and C2 points should be already detected is this stage ?
73
Luca IK2LRN 


David Fainitski
 

Luca , that is depended, but they are will to blink. You will see.


David Fainitski
 

Luca, when FPGA will to work good, some info on the OLED will be appeared.
Use correct MCU HEX file from that folder Bootloader you use.