Occhio alle ultime alpha...


Alberto Buffolino
 

Hola lista,
occhio ad aggiornare alle ultime alpha: siamo entrati nella fase dei breaking changes, i cambiamenti che rompono, in tutti i sensi, in vista della 2021.1.
In parole molto povere, è assai probabile che la vostra sintesi vocale smetta di parlare. Sì, anche la sintesi innominabile.
Va comunque detto che NVDA si auto-imposta su una di quelle di Windows, come misura d'emergenza, per cui non si rimane completamente a piedi, ma insomma meglio saperlo prima, direi 😉
Aggiornare le voci non richiede molto lavoro, tutt'altro, non siamo assolutamente nella situazione che ci fu con la 2019.3, per cui tranquilli, anche le Vocalizer si stan già mettendo in pari, ho visto.
Alberto


Gabriele Battaglia
 

Ciao Alberto. Ho letto la cosa questa mattina, su nvda devel la notizia ed ho trepidato un po per la mia sempiterna Eloquence.
Non ho intentenzione di provare le alfa ma ti chiedo: quando uscirà la stable sarà ok o ci sarà bisogno di un nostro intervento da qualche parte?
Se sì, posta le istruzioni!
Ciaoo.
Gabry.


Alberto Buffolino
 

Gabriele Battaglia via groups.io, il 12/03/2021 16.01, ha scritto:
ed ho trepidato un po per la mia sempiterna Eloquence.
Non ho intentenzione di provare le alfa ma ti chiedo: quando uscirà la stable sarà ok o ci sarà bisogno di un nostro intervento da qualche parte?
Se sì, posta le istruzioni!
Alberto:
oh, be', se l'autore latita sì, ci sarà bisogno. Ma tu puoi fare di meglio: prendi eloquence.py, dille che l'ami... modificale da speech.*Command a speech.commands.*Command... e stai sicuro che ti funzionerà 😉 😂
P.S.: cioè, ti funzionerà dalle ultime alpha o dalla prossima stabile in poi, non sulle versioni precedenti; per ottenere questo bisogna lavorarci un attimino di più, ma per ora son stato troppo pigro per imbastire un codice decente.
Alberto


Gabriele Battaglia
 

Reply to the Alberto Buffolino's message, wrote on 12/03/2021 at 16:33:
oh, be', se l'autore latita sì, ci sarà bisogno. Ma tu puoi fare di meglio: prendi eloquence.py, dille che l'ami... modificale da speech.*Command a speech.commands.*Command... e stai sicuro che ti funzionerà 😉 😂
P.S.: cioè, ti funzionerà dalle ultime alpha o dalla prossima stabile in poi, non sulle versioni precedenti; per ottenere questo bisogna lavorarci un attimino di più, ma per ora son stato troppo pigro per imbastire un codice decente.
Lo farò. Intanto mi salvo questo messaggio in archivio.
Grazie.
Ciao.
Gabry.
PS: hai iniziato a fare amicizia con VSCode?