Re: Impostazioni NVDA ho risolto.

Fabio Brambilla
 

Ciao,
ci hai preso in pieno era proprio il sintetizzatore.
Ho scaricato una nuova versione e dopo averla installata tutto è tornato magicamente a posto.
Grazie a tutti voi per la collaborazione, in questa lista una risposta si trova sempre.
Buona giornata.
Fabio

----- Original Message -----
From: "Chris" <@Christianlm>
To: <nvda-it@groups.io>
Sent: Tuesday, October 9, 2018 2:35 PM
Subject: Re: [nvda-it] Impostazioni NVDA non funzionano.


Fabio, ad esser sincero, non mi ricordo neppure io come si riavvia NVDA con i componenti aggiuntivi disattivati, ma son sicuro che se ci spendi due minuti nel manuale utente si trovano queste informazioni di base.

Anche se il log è ben lontano da quello richiesto, credo di aver capito il problema dai moduli coinvolti.
Praticamente e molto probabilmente devi disattivare o rimuovere il componente aggiuntivo che usi come sintetizzatore.
Dovresti procurarti e reinstallare i driver per il suddetto sintetizzatore, adatti e compatibili per le recenti impostazioni di configurazione di NVDA.






Chris.

Fabio Brambilla, 09/10/2018 13:17:
Ciao,
purtroppo non miricordo come si fa ad avviare senza i componenti
aggiuntivi.
Comunque ho provato a ricreare l'errore e ti copio sotto il log.
Ho visto sulla guida che se si hanno vecchi componenti sulla propria
cartella andrebbero cancellati, ma non ho idea di dove mettere le mani.
Comunque con l'apposito plug in ho aggiornato tutti i componenti
aggiuntivi, l'unico che avevo tenuto vecchio era Innstant Translate che
adesso ho rimosso senza installare quello nuovo.
Grazie.
Ciao.
Fabio

testo del log dopo l'errore:

INFO - __main__ (12:54:27.530):

Starting NVDA

INFO - core.main (12:54:27.836):

Config dir: C:\Users\FaBr\AppData\Roaming\nvda

INFO - config.ConfigManager._loadConfig (12:54:27.836):

Loading config: C:\Users\FaBr\AppData\Roaming\nvda\nvda.ini

INFO - core.main (12:54:28.632):

NVDA version 2018.3.2

INFO - core.main (12:54:28.632):

Using Windows version 10.0.16299 workstation

INFO - core.main (12:54:28.632):

Using Python version 2.7.15 (v2.7.15:ca079a3ea3, Apr 30 2018, 16:22:17)
[MSC v.1500 32 bit (Intel)]

INFO - core.main (12:54:28.632):

Using comtypes version 1.1.3

INFO - synthDriverHandler.setSynth (12:54:30.335):

Loaded synthDriver xxxx

INFO - core.main (12:54:30.335):

Using wx version 4.0.3 msw (phoenix) wxWidgets 3.0.5

INFO - brailleInput.initialize (12:54:30.338):

Braille input initialized

INFO - braille.initialize (12:54:30.338):

Using liblouis version 3.6.0

INFO - braille.BrailleHandler.setDisplayByName (12:54:30.341):

Loaded braille display driver noBraille, current display has 0 cells.

WARNING - core.main (12:54:32.436):

Java Access Bridge not available

INFO - _UIAHandler.UIAHandler.MTAThreadFunc (12:54:32.480):

UIAutomation: IUIAutomation5

INFO - core.main (12:54:34.226):

NVDA initialized

ERROR - unhandled exception (13:07:44.954):

Traceback (most recent call last):

File "gui\settingsDialogs.pyo", line 600, in onApply

File "gui\settingsDialogs.pyo", line 578, in _doSave

File "gui\settingsDialogs.pyo", line 853, in onSave

File "gui\settingsDialogs.pyo", line 1176, in onSave

File "synthDriverHandler.pyo", line 489, in saveSettings

File "config\__init__.pyo", line 953, in __setitem__

File "validate.pyo", line 602, in check

File "validate.pyo", line 634, in _check_value

File "validate.pyo", line 1083, in is_string

VdtTypeError: the value "1" is of the wrong type.

ERROR - unhandled exception (13:07:46.598):

Traceback (most recent call last):

File "gui\settingsDialogs.pyo", line 584, in onOk

File "gui\settingsDialogs.pyo", line 578, in _doSave

File "gui\settingsDialogs.pyo", line 853, in onSave

File "gui\settingsDialogs.pyo", line 1176, in onSave

File "synthDriverHandler.pyo", line 489, in saveSettings

File "config\__init__.pyo", line 953, in __setitem__

File "validate.pyo", line 602, in check

File "validate.pyo", line 634, in _check_value

File "validate.pyo", line 1083, in is_string

VdtTypeError: the value "1" is of the wrong type.



 

----- Original Message ----- From: "Chris" <@Christianlm>
To: <nvda-it@groups.io>
Sent: Tuesday, October 9, 2018 11:26 AM
Subject: Re: [nvda-it] Impostazioni NVDA non funzionano.


Ok, puoi magari farci sapere se il problema si presenta anche con i
componenti aggiuntivi disattivati?

Controlla anche se nella cartella di configurazione personale di NVDA
c'è il file instantTranslate.ini. In caso va cancellato.

Un file di registro potrebbe aiutarci a capire meglio, fai anche così:
1. Riavvia NVDA per aver un log pulito:
2. Imposta il livello di logging su debug.
3. Esegui le tue impostazioni di configurazione e premi invio sul
pulsante Ok.
4. Subito dopo aver premuto Ok, apri il log con NVDA+F1 e copia tutto.




Chris.

Fabio Brambilla, 09/10/2018 10:57:
Ciao,
allora ho disinstallato Instant Translate.
Ho provato a fare una modifica ma il problema non si è risolto.
Non mi permette nessun cambio di impostazioni e neanche di chiudere le
stesse.
Per uscire mi tocca chiudere e poi riaprire NVDA.

Ho scaricato la versione che mi hai indicato, devo però dirti che
l'avevo già provata ad installare ma non mi funziona; forse proprio per
il motivo che non mi viene permesso di cambiare le impostazioni.

Grazie ancora .
Ciao.
Fabio

P.S. scusate le lettere accentate, ma non sono io ma la maledetta
casella di Alice.
----- Original Message ----- From: "Chris" <@Christianlm>
To: <nvda-it@groups.io>
Sent: Tuesday, October 9, 2018 10:18 AM
Subject: Re: [nvda-it] Impostazioni NVDA non funzionano.


ciao Fabio.
Appunto, tentando di impostare Instant Translator hai sicuramente
aperto una finestra di dialogo come ti ha scritto Simone.
La vecchia versione di Instant traslator non è compatibile con NVDA
2018.3, devi disinstallarla, rimuovere eventuali file pendenti e
installare la versione 4.2 in sviluppo. Scaricala da quì:

https://addons.nvda-project.org/files/get.php?file=it-dev

Puoi provare anche a riavviare NVDA con i componenti aggiuntivi
disattivati, e vedere se il problema si presenta ancora.
Se si ripete il problema servirebbe un file di log per capire meglio.


Chris.

Fabio Brambilla, 09/10/2018 09:58:
Ciao,
no stavo tentando di modificare la lingua di Instant Translate che per
inciso ho in versione vecchia perchè la nuova non mi funziona.
Ho provato poi a chiudere tutto, a riavviare il pc e a fare altri
settaggi alle impostazioni ma il problema persiste.
Ciao.

Fabio
----- Original Message ----- From: "Simone Dal Maso"
<simone.dalmaso@...>
To: <nvda-it@groups.io>
Sent: Tuesday, October 9, 2018 9:34 AM
Subject: Re: [nvda-it] Impostazioni NVDA non funzionano.


Ciao,
una sola domandina: per caso avevi qualche finestra di componente
aggiuntivo aperta?
Comunque è successo ad altri sta cosa, non mi ricordo se sia mai
stata
trovata una soluzione...
Il 09/10/2018 09:29, Fabio Brambilla ha scritto:
Ciao a tutti.
Andando in NVDA, impostazioni, facendo delle modifiche e poi
attivando prima applica e poi ok, non mi viene presa la modifica.
Le impostazioni restano aperte, non c'è verso di chiuderle.
Lo posso fare solo chiudendo e riaprendo NVDA, ma quando rientro
nelle impostazioni non ci sono le mie variazioni.
Uso Windows 10 professional versione 1709 e NVDA 2018.3.2.
Grazie a chi mi potrà dare info.
Ciao.
Fabio Brambilla










Join nvda-it@groups.io to automatically receive all group messages.