Topics

The "Microsoft Sound Mapper" does not appear correctly in the list of audio output devices in NVDA


 

Hello all,

Before filing a bug for this, I want to gather some opinions from other people's experience.

I think the strange problem started occurring after the Windows 10 May 2020 update. The "Microsoft Sound Mapper" does not show correctly in the list of audio output devices in NVDA's dialog for selecting a synthesizer. The device can be selected and used, but instead of a name for it, there is only a blank item in the list. On my machine Windows 10 is in bulgarian with all locale settings set to "bulgarian". But I just for the test changed the Windows display language to english and the problem remained. I haven't changed the other locale settings (e.g. the settings for time, date, currency and other similar things format) during that testing. Should I? Could the locale settings affect how that device's name is displayed?

I can reproduce this on at least 3 machines. All of them are running Windows 10 May 2020 update. On 2 of them I'm running the latest alpha snapshot of NVDA. On the 3rd one - NVDA 2020.1. All of the machines have their locale settings set to "bulgarian".

I'm not for now filing a bug against NVDA due to one more reason - I can reproduce similar (if not the same) behavior with Audacity. If I open Audacity and press Shift+O to invoke the dialog for choosing an audio output device, the "Microsoft Sound Mapper" one, which is also selectible in Audacity, is displayed only as " - output" and I think it should be displayed as "Microsoft Sound Mapper - output".

Can someone else reproduce this in NVDA and/or Audacity? If so and it is not an NVDA issue, how to report this to Microsoft, so they can easily reproduce it? Because it is not like the "Microsoft Sound Mapper" is easy to encounter and check out in Windows.

Thanks much in advance!

______
Best wishes,
Kostadin Kolev


Rui Fontes
 

Same here...

NVDA 2020.2 Beta1 and last Alpha (20354)

Windows 10 2004

All language settings in portuguese.


Rui Fontes


Às 10:33 de 22/06/2020, Kostadin Kolev escreveu:

Hello all,

Before filing a bug for this, I want to gather some opinions from other people's experience.

I think the strange problem started occurring after the Windows 10 May 2020 update. The "Microsoft Sound Mapper" does not show correctly in the list of audio output devices in NVDA's dialog for selecting a synthesizer. The device can be selected and used, but instead of a name for it, there is only a blank item in the list. On my machine Windows 10 is in bulgarian with all locale settings set to "bulgarian". But I just for the test changed the Windows display language to english and the problem remained. I haven't changed the other locale settings (e.g. the settings for time, date, currency and other similar things format) during that testing. Should I? Could the locale settings affect how that device's name is displayed?

I can reproduce this on at least 3 machines. All of them are running Windows 10 May 2020 update. On 2 of them I'm running the latest alpha snapshot of NVDA. On the 3rd one - NVDA 2020.1. All of the machines have their locale settings set to "bulgarian".

I'm not for now filing a bug against NVDA due to one more reason - I can reproduce similar (if not the same) behavior with Audacity. If I open Audacity and press Shift+O to invoke the dialog for choosing an audio output device, the "Microsoft Sound Mapper" one, which is also selectible in Audacity, is displayed only as " - output" and I think it should be displayed as "Microsoft Sound Mapper - output".

Can someone else reproduce this in NVDA and/or Audacity? If so and it is not an NVDA issue, how to report this to Microsoft, so they can easily reproduce it? Because it is not like the "Microsoft Sound Mapper" is easy to encounter and check out in Windows.

Thanks much in advance!

______
Best wishes,
Kostadin Kolev


Ralf Kefferpuetz
 

Same here in english and german languages…

 

From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Kostadin Kolev
Sent: Montag, 22. Juni 2020 11:34
To: NVDA screen reader development <nvda-devel@groups.io>
Subject: [nvda-devel] The "Microsoft Sound Mapper" does not appear correctly in the list of audio output devices in NVDA

 

Hello all,

Before filing a bug for this, I want to gather some opinions from other people's experience.

I think the strange problem started occurring after the Windows 10 May 2020 update. The "Microsoft Sound Mapper" does not show correctly in the list of audio output devices in NVDA's dialog for selecting a synthesizer. The device can be selected and used, but instead of a name for it, there is only a blank item in the list. On my machine Windows 10 is in bulgarian with all locale settings set to "bulgarian". But I just for the test changed the Windows display language to english and the problem remained. I haven't changed the other locale settings (e.g. the settings for time, date, currency and other similar things format) during that testing. Should I? Could the locale settings affect how that device's name is displayed?

I can reproduce this on at least 3 machines. All of them are running Windows 10 May 2020 update. On 2 of them I'm running the latest alpha snapshot of NVDA. On the 3rd one - NVDA 2020.1. All of the machines have their locale settings set to "bulgarian".

I'm not for now filing a bug against NVDA due to one more reason - I can reproduce similar (if not the same) behavior with Audacity. If I open Audacity and press Shift+O to invoke the dialog for choosing an audio output device, the "Microsoft Sound Mapper" one, which is also selectible in Audacity, is displayed only as " - output" and I think it should be displayed as "Microsoft Sound Mapper - output".

Can someone else reproduce this in NVDA and/or Audacity? If so and it is not an NVDA issue, how to report this to Microsoft, so they can easily reproduce it? Because it is not like the "Microsoft Sound Mapper" is easy to encounter and check out in Windows.

Thanks much in advance!

______
Best wishes,
Kostadin Kolev