Topics

The Alpha and Java Access Bridge

Karl-Otto Rosenqvist
 

Hi!
I have the version: alpha-18677,348c3500 and it doesn't seem to work with Java Access Bridge. I know it works because JAWS makes the Arduino IDE accessible after I've installed Java Access Bridge but NVDA doesn't work.

Is this due to me running an alpha version or is it something else?


Kind regards

Karl-Otto


Karl-Otto Rosenqvist
Mawingu
Orgnr: 750804-3937
+46 (0)701 75 98 56
karl-otto@...

Jens Gierke
 

Can't confirm that.
Using:
- NVDA alpha 18677
- Win 10 1903 64bit
- OpenJDK 11.0.4.11

"it works with JAWS" is not a helpful information.
Does it work with the latest stable of NVDA? If not, my first guess is
that your Java setup is not correct. When you run the IDE using a 64bit
JVM you must have installed a 32bit JVM which can NVDA use as
interconnect for the 64bit Access Bridge.

Best regards,
Jens

Am 17.09.2019 um 18:52 schrieb Karl-Otto Rosenqvist:

Hi!
I have the version: alpha-18677,348c3500 and it doesn't seem to work
with Java Access Bridge. I know it works because JAWS makes the Arduino
IDE accessible after I've installed Java Access Bridge but NVDA doesn't
work.

Is this due to me running an alpha version or is it something else?


Kind regards

Karl-Otto


Karl-Otto Rosenqvist
Mawingu
Orgnr: 750804-3937
+46 (0)701 75 98 56
karl-otto@...

Karl-Otto Rosenqvist
 

Thanks!
Yes, the problem was that I didn't have the 32-bit version up and running. I found a version of Open JDK 11 for 32-bit Windows and now the Arduino IDE talks to me when I'm running NVDA too.

I do understand that NVAccess can't keep others installation packages around so it's a hard nut to crack, the ease of access to installation that works.

Anyway, big thanks again.

Karl-Otto

Karl-Otto Rosenqvist
Mawingu
Orgnr: 750804-3937
0701- 75 98 56
karl-otto@...
https://mawingu.se

Den 2019-09-18 kl. 15:55, skrev Jens Gierke:

Can't confirm that.
Using:
- NVDA alpha 18677
- Win 10 1903 64bit
- OpenJDK 11.0.4.11
"it works with JAWS" is not a helpful information.
Does it work with the latest stable of NVDA? If not, my first guess is
that your Java setup is not correct. When you run the IDE using a 64bit
JVM you must have installed a 32bit JVM which can NVDA use as
interconnect for the 64bit Access Bridge.
Best regards,
Jens
Am 17.09.2019 um 18:52 schrieb Karl-Otto Rosenqvist:
Hi!
I have the version: alpha-18677,348c3500 and it doesn't seem to work
with Java Access Bridge. I know it works because JAWS makes the Arduino
IDE accessible after I've installed Java Access Bridge but NVDA doesn't
work.

Is this due to me running an alpha version or is it something else?


Kind regards

Karl-Otto


Karl-Otto Rosenqvist
Mawingu
Orgnr: 750804-3937
+46 (0)701 75 98 56
karl-otto@...