Topics

Add-on Updater will require NVDA 2019.3 starting March 10, 2020, a speicla change fro alpha snapshot users

 

Hi all,

 

A few weeks ago I announced to the NVDA community that Add-on Updater will be the last add-on from me to require NVDA 2019.3. This decision was made in consideration for people who may need to use 2019.2.1 and earlier a little longer.

 

But the countdown has begun: after March 10, 2020 (the day Add-on Updater 20.03 is scheduled to be released, which happens to be 30 days after 2019.3 is released), Add-on Updater will require NVDA 2019.3. No exceptions, no extensions.

 

Also, a special change will be implemented in consideration for people using alpha snapshots: starting from Add-on Updater 20.03, those using alpha snapshots (master branch) will no longer receive incompatibility prompts if trying to update add-ons in most cases. The only time you’ll get an incompatibility notice when updating add-ons through Add-on Updater will be when NV Access updates minimum API version for all add-ons (currently set at 2019.3) and the add-on in question does not cover the updated API version in the compatibility range (minimumNVDAVersion <= newAPIVersion <= lastTestedNVDAVersion). This change is destined for alpha snapshot users only – those using betas, RC’s, and stable releases will continue to receive incompatibility notices if an add-on update isn’t compatible with latest NVDA version as seen internally (versionInfo.version_*).

 

Cheers,

Joseph

Brian's Mail list account
 

Which reminds me, on the latest stable, I'm getting prompted to install a version of mozilla enhancements with an issue number lower than the one installed already. This started in the last few days. I've not let it do so, since the old one says its compatible. Strange?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users

----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Monday, February 17, 2020 6:38 AM
Subject: [nvda-devel] Add-on Updater will require NVDA 2019.3 starting March 10, 2020, a speicla change fro alpha snapshot users


Hi all,



A few weeks ago I announced to the NVDA community that Add-on Updater will
be the last add-on from me to require NVDA 2019.3. This decision was made in
consideration for people who may need to use 2019.2.1 and earlier a little
longer.



But the countdown has begun: after March 10, 2020 (the day Add-on Updater
20.03 is scheduled to be released, which happens to be 30 days after 2019.3
is released), Add-on Updater will require NVDA 2019.3. No exceptions, no
extensions.



Also, a special change will be implemented in consideration for people using
alpha snapshots: starting from Add-on Updater 20.03, those using alpha
snapshots (master branch) will no longer receive incompatibility prompts if
trying to update add-ons in most cases. The only time you'll get an
incompatibility notice when updating add-ons through Add-on Updater will be
when NV Access updates minimum API version for all add-ons (currently set at
2019.3) and the add-on in question does not cover the updated API version in
the compatibility range (minimumNVDAVersion <= newAPIVersion <=
lastTestedNVDAVersion). This change is destined for alpha snapshot users
only - those using betas, RC's, and stable releases will continue to receive
incompatibility notices if an add-on update isn't compatible with latest
NVDA version as seen internally (versionInfo.version_*).



Cheers,

Joseph