Topics

Add-on Updater 19.08.2 #addonrelease

 

Hi all,

 

Add-on Updater 19.08.2 is now available. This version resolves key error seen when trying to look for updates for certain add-ons, along with fixing localizations for Arabic and Ukrainian.

 

Note: Add-on Updater 19.09 is coming soon, and that version will require NVDA 2019.2 or later.

Cheers,

Joseph

Brian's Mail list account
 

So will this version if installed in 2019.1.x stop it being installed?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users

----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 6:41 PM
Subject: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi all,



Add-on Updater 19.08.2 is now available. This version resolves key error
seen when trying to look for updates for certain add-ons, along with fixing
localizations for Arabic and Ukrainian.



Note: Add-on Updater 19.09 is coming soon, and that version will require
NVDA 2019.2 or later.

Cheers,

Joseph



 

Hi,
Eh?
19.08.2 is still compatible with 2019.1... and most likely the last one to
be compatible with it.
Cheers,
Joseph

-----Original Message-----
From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Brian's Mail
list account via Groups.Io
Sent: Sunday, August 18, 2019 11:44 AM
To: nvda-devel@groups.io
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease

So will this version if installed in 2019.1.x stop it being installed?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 6:41 PM
Subject: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi all,



Add-on Updater 19.08.2 is now available. This version resolves key error
seen when trying to look for updates for certain add-ons, along with
fixing
localizations for Arabic and Ukrainian.



Note: Add-on Updater 19.09 is coming soon, and that version will require
NVDA 2019.2 or later.

Cheers,

Joseph




Brian's Mail list account
 

OK more explanation required. When you put out the next one which will require the current stable release, will something in this release stop it from being installed on 2019.1.1.
IE if you accidentally install the next version on the older version of nvda what will happen?

Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users

----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 7:45 PM
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi,
Eh?
19.08.2 is still compatible with 2019.1... and most likely the last one to
be compatible with it.
Cheers,
Joseph

-----Original Message-----
From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Brian's Mail
list account via Groups.Io
Sent: Sunday, August 18, 2019 11:44 AM
To: nvda-devel@groups.io
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease

So will this version if installed in 2019.1.x stop it being installed?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 6:41 PM
Subject: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi all,



Add-on Updater 19.08.2 is now available. This version resolves key error
seen when trying to look for updates for certain add-ons, along with
fixing
localizations for Arabic and Ukrainian.



Note: Add-on Updater 19.09 is coming soon, and that version will require
NVDA 2019.2 or later.

Cheers,

Joseph








 

Hi,
Depends on NVDA version in use. If using versions earlier than 2019.1, it'll
install, although the add-on itself won't work properly. The absolute
minimum version the add-on requires is 2019.1 because the add-on will use
concepts provided by 2019.1 to check for compatibility range.
All of this changes later this year: as I noted a few times, once NVDA
2019.3 comes out, Add-on Updater will require 2019.3 because of extensive
use of Python 3 syntax. However, that switch won't occur as soon as 2019.3
comes out - I'll wait a few weeks before releasing a version of Add-on
Updater that will require 2019.3. Once that happens, there is no going back
- you won't be able to install the future Add-on updater release on an older
NVDA release, nor old add-on releases will work on NVDA 2019.3 and later.
Even if you do fool NVDA by "installing" it by copying add-on files, Add-on
Updater will fail to operate properly if what it expects and current NVDA
version do not match.
This isn't limited to Add-on Updater - any add-on that wishes to see light
of day once NVDA 2019.3 ships must be willing to not only declare its
support for 2019.3 in the manifest, source code must also be compliant. This
is the biggest reason why not all add-ons declaring Python 3 compatibility
will not be certified as such until source code is compliant (and for some,
they must be ready to deal with deeper differences between python 2 and 3,
which is perhaps one of the reasons for current difficulty with porting some
speech synthesizer add-ons).
Cheers,
Joseph

-----Original Message-----
From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Brian's Mail
list account via Groups.Io
Sent: Sunday, August 18, 2019 12:27 PM
To: nvda-devel@groups.io
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease

OK more explanation required. When you put out the next one which will
require the current stable release, will something in this release stop it
from being installed on 2019.1.1.
IE if you accidentally install the next version on the older version of
nvda what will happen?

Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 7:45 PM
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi,
Eh?
19.08.2 is still compatible with 2019.1... and most likely the last one to
be compatible with it.
Cheers,
Joseph

-----Original Message-----
From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Brian's
Mail
list account via Groups.Io
Sent: Sunday, August 18, 2019 11:44 AM
To: nvda-devel@groups.io
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease

So will this version if installed in 2019.1.x stop it being installed?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 6:41 PM
Subject: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi all,



Add-on Updater 19.08.2 is now available. This version resolves key error
seen when trying to look for updates for certain add-ons, along with
fixing
localizations for Arabic and Ukrainian.



Note: Add-on Updater 19.09 is coming soon, and that version will require
NVDA 2019.2 or later.

Cheers,

Joseph









Brian's Mail list account
 

OK that makes sense. One assumes though that anyone still on an old version of nvda after that time if they avoid the latest version of updater, and indeed may wish not to have updater installed at all, can still download add ons that were for the older versions from somewhere, or maybe they will carry a flag on the web sit that shows which are for which version to avoid disappointment when downloading them.


Also, does this also mean that addons that still work now in Python three will continue to do so, or are there likely to be changes in nvda before then that might throw the odd spanner in already adapted code, such as Resource checker?


Yes some work would be needed to get pico to work as It seems its not just python 3, but the way sound is handled generally that mucks that one up.
I did also notice that in the try build to stop Explorer crashing with the mouse that Sapi 4 although it works does crash nvda at random times or if you attempt to switch it back to another synth. Not looked into that, as after all that is a try build and may contain other experimental code as I do not know what build of Alpha its based on.
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users

----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 8:49 PM
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi,
Depends on NVDA version in use. If using versions earlier than 2019.1, it'll
install, although the add-on itself won't work properly. The absolute
minimum version the add-on requires is 2019.1 because the add-on will use
concepts provided by 2019.1 to check for compatibility range.
All of this changes later this year: as I noted a few times, once NVDA
2019.3 comes out, Add-on Updater will require 2019.3 because of extensive
use of Python 3 syntax. However, that switch won't occur as soon as 2019.3
comes out - I'll wait a few weeks before releasing a version of Add-on
Updater that will require 2019.3. Once that happens, there is no going back
- you won't be able to install the future Add-on updater release on an older
NVDA release, nor old add-on releases will work on NVDA 2019.3 and later.
Even if you do fool NVDA by "installing" it by copying add-on files, Add-on
Updater will fail to operate properly if what it expects and current NVDA
version do not match.
This isn't limited to Add-on Updater - any add-on that wishes to see light
of day once NVDA 2019.3 ships must be willing to not only declare its
support for 2019.3 in the manifest, source code must also be compliant. This
is the biggest reason why not all add-ons declaring Python 3 compatibility
will not be certified as such until source code is compliant (and for some,
they must be ready to deal with deeper differences between python 2 and 3,
which is perhaps one of the reasons for current difficulty with porting some
speech synthesizer add-ons).
Cheers,
Joseph


-----Original Message-----
From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Brian's Mail
list account via Groups.Io
Sent: Sunday, August 18, 2019 12:27 PM
To: nvda-devel@groups.io
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease

OK more explanation required. When you put out the next one which will
require the current stable release, will something in this release stop it
from being installed on 2019.1.1.
IE if you accidentally install the next version on the older version of
nvda what will happen?

Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 7:45 PM
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi,
Eh?
19.08.2 is still compatible with 2019.1... and most likely the last one to
be compatible with it.
Cheers,
Joseph

-----Original Message-----
From: nvda-devel@groups.io <nvda-devel@groups.io> On Behalf Of Brian's
Mail
list account via Groups.Io
Sent: Sunday, August 18, 2019 11:44 AM
To: nvda-devel@groups.io
Subject: Re: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease

So will this version if installed in 2019.1.x stop it being installed?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message -----
From: "Joseph Lee" <@joslee>
To: <nvda-devel@groups.io>
Sent: Sunday, August 18, 2019 6:41 PM
Subject: [nvda-devel] Add-on Updater 19.08.2 #AddonRelease


Hi all,



Add-on Updater 19.08.2 is now available. This version resolves key error
seen when trying to look for updates for certain add-ons, along with
fixing
localizations for Arabic and Ukrainian.



Note: Add-on Updater 19.09 is coming soon, and that version will require
NVDA 2019.2 or later.

Cheers,

Joseph