Topics

Add-on template: Abdel's sconstruct modification will require Python 3

 

Hi all,

 

For those on development list: Abdel has been working on Python 3 compatible sconstruct for various add-ons.

 

For add-on authors: Abdel’s sconstruct modification will require Python 3. Therefore, I will not implement his changes until NVDA 2019.3 beta is released, at which point add-on template will require Python 3 (regardless of which Python distribution you’re planning to use). For now, please use the one supplied with the add-on template (a dedicated “py3strict” branch will be created in add-on template repo to test Abdel’s changes).

Cheers,

Joseph