Re: Log full of error in NVDA 2020.1beta1


Brian's Mail list account
 

I did try to find out if the program relied on java. and its only recently that jab is bundled and installed by nvda, so it could be a chicken and egg issue with Java before its actually talking properly to your software, which is why think you need to do an issue so somebody can look at it and see if something has gone to use a technical term, arse upwards, for this application. I did see there are demo versions so it might well be possible for a developer to trace the issue.
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users

----- Original Message -----
From: "Cyrille via groups.io" <cyrille.bougot2=laposte.net@groups.io>
To: <nvda-devel@groups.io>
Sent: Monday, April 27, 2020 9:09 AM
Subject: Re: [nvda-devel] Log full of error in NVDA 2020.1beta1


I did not try explicitly different synth because this does not seem
linked to this issue.

Anyway, I have actually used Eloquence when running first the download
manager and then eSpeak when re-starting NVDA with --disable-addons option.


Cheers,


Cyrille

Le 27/04/2020 à 09:40, Brian's Mail list account via groups.io a écrit :
I suppose you have tried different synths as weell as Eloquence and Espeak?
Brian

bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message ----- From: "Brian's Mail list account via groups.io" <bglists=blueyonder.co.uk@groups.io>
To: <nvda-devel@groups.io>
Sent: Monday, April 27, 2020 8:34 AM
Subject: Re: [nvda-devel] Log full of error in NVDA 2020.1beta1


Your problem appears to start here.

IO - speech.speak (23:48:42.362) - MainThread (36088):
Speaking ['Loupe']
IO - speech.speak (23:48:42.368) - MainThread (36088):
Speaking ['Zoom arrière', 'bouton', 'Zoom arrière']
ERROR - unhandled exception (23:48:42.807) - MainThread (36088):
Traceback (most recent call last):
File "_ctypes/callbacks.c", line 232, in 'calling callback function'
File "JABHandler.pyc", line 706, in internal_event_caretChange
File "JABHandler.pyc", line 335, in internalQueueFunction
File "queue.pyc", line 190, in put_nowait
File "queue.pyc", line 136, in put
queue.Full
ERROR - unhandled exception (23:48:42.818) - MainThread (36088):
Traceback (most recent call last):
File "_ctypes/callbacks.c", line 232, in 'calling callback function'
File "JABHandler.pyc", line 706, in internal_event_caretChange
File "JABHandler.pyc", line 335, in internalQueueFunction
File "queue.pyc", line 190, in put_nowait
File "queue.pyc", line 136, in put
queue.Full
ERROR - unhandled exception (23:48:42.830) - MainThread (36088):
Traceback (most recent call last):
File "_ctypes/callbacks.c", line 232, in 'calling callback function'
File "JABHandler.pyc", line 706, in internal_event_caretChange
File "JABHandler.pyc", line 335, in internalQueueFunction
File "queue.pyc", line 190, in put_nowait
File "queue.pyc", line 136, in put
queue.Full
ERROR - unhandled exception (23:48:42.844) - MainThread (36088):


And from then on its an endless repeating loop of the same error. Not sure what is running as its not clear from your log, it just jumps straight in after all the various initialisations.
On a clean portable copy I see no issue on Windows 7 at all on the latest beta.

So what is this program which is actually running that is filling up the cursor move queue, is the mouse to blame, perhaps?
Does this program run in the command prompt or does it have its own interface or what?

I think you will get more attention if you raise an issue, only you know the exact config of your system after all.
Brian
bglists@...
Sent via blueyonder.
Please address personal E-mail to:-
briang1@..., putting 'Brian Gaff'
in the display name field.
Newsgroup monitored: alt.comp.blind-users
----- Original Message ----- From: "Cyrille via groups.io" <cyrille.bougot2=laposte.net@groups.io>
To: <nvda-devel@groups.io>
Sent: Sunday, April 26, 2020 11:08 PM
Subject: [nvda-devel] Log full of error in NVDA 2020.1beta1


Hello all


I am downloading a Matlab demo version with their downloader. Whenever I
start NVDA 2020.1beta1 (even with add-ons disabled), I get the log full
of errors with the error sound. These error sound beep continuously even
if the download progress window is not focused. This prevent NVDA to
speak anything. I had to kill Matlab from task manager. Log is attached.

With NVDA 2019.3.1, there is no such issue.

I do not have time to open and follow an issue about this, and to try
again to download Matlab. However, I send this message to inform and to
know if someone else has this issue.

Cheers,

Cyrille












Join nvda-devel@groups.io to automatically receive all group messages.