Topics

WEFAX reception in FLDIGI losing phasing alignment sync often


roger.tobin@...
 

I have an issue that seems common to all the versions of FLDIGI I’ve kept up with over the past couple of years.

 

When I am receiving a WEFAX from a station like NMC (Pt. Reyes CA), the image will lose the alignment whenever there is other activity on my computer.  If I walk away from the system for an extended period of time, the received images tend to be aligned, even if they are a bit noisy.

 

If the signal is strong (rarely), this can still happen, but perhaps not as often (I don’t have any definite proof of this).

 

I’m using VB-Audio Virtual Cable to pipe the sound from SDRuno, which is being fed by my RSP1-A.  I’m on a Windows machine running the latest builds of W10 from the fast ring.  I have SDRuno set to run at high process priority.

My CPU is an i5-7200U @2.50GHz, and I have 12GB RAM

 

All that I can figure is that something is getting swapped in and the piped signal is being delayed by a very small amount that is then throwing off the logic in FLDIGI.

 

Is there a solution like some switch in FLDIGI that would fix the issue, or do I have to consider using a dedicated machine to avoid the problem?  Is there a better virtual cable program that might fix this?

 

Any thoughts or advice would be welcome!

 

Thanks,

Roger

 

Roger Tobin

Roger.tobin@...

N1EYZ

 


Dave
 

Have you discussed the problem with the seller of the VB-Audio Virtual Cable ?  What are the specifications for that software?

Try saving the incoming audio to a wav file (off-line from fldigi) and then playing back that wav file using fldigi's wav file playback mechanism.  You might also be able to anayze the wav file to see if it contains any obvious missing audio segments.

Have you tried simultaneously receiving that WEFAX signal using a h/w receiver or transceiver with fldigi.  Perhaps on a separate computer.  Your SDR implementation seems to have a number of "black boxes" over which you have little control.

Dave

On 4/3/20 5:43 PM, roger.tobin@... wrote:

I have an issue that seems common to all the versions of FLDIGI I’ve kept up with over the past couple of years.

 

When I am receiving a WEFAX from a station like NMC (Pt. Reyes CA), the image will lose the alignment whenever there is other activity on my computer.  If I walk away from the system for an extended period of time, the received images tend to be aligned, even if they are a bit noisy.

 

If the signal is strong (rarely), this can still happen, but perhaps not as often (I don’t have any definite proof of this).

 

I’m using VB-Audio Virtual Cable to pipe the sound from SDRuno, which is being fed by my RSP1-A.  I’m on a Windows machine running the latest builds of W10 from the fast ring.  I have SDRuno set to run at high process priority.

My CPU is an i5-7200U @2.50GHz, and I have 12GB RAM

 

All that I can figure is that something is getting swapped in and the piped signal is being delayed by a very small amount that is then throwing off the logic in FLDIGI.

 

Is there a solution like some switch in FLDIGI that would fix the issue, or do I have to consider using a dedicated machine to avoid the problem?  Is there a better virtual cable program that might fix this?

 

Any thoughts or advice would be welcome!

 

Thanks,

Roger

 

Roger Tobin

Roger.tobin@...

N1EYZ