Topics

Uncommanded repeat of FLMsg

Dave
 

Please test

Includes this source code change

commit 3355087d05c2db0e0087de68137b398ba09bb740
Author: David Freese <w1hkj@...>
Date:   Tue Jan 1 06:21:54 2019 -0600

    Double click
   
      * add double click timer to AutoSend button
        - ignore multiple clicks of button that occur
          within a 2 second window.

73 & HNY, David, W1HKJ

On 12/31/18 2:13 PM, Ron wrote:
Hi Bart and Dave,

Excuse me for busting in like this.  I've had this happen to me with my impatience or just a nervous double click and I see it often with other people on the nets.  It gets worse when you try to interrupt the second transmission and it stays queued and if you send something else the Flmsg will continue.  I just tried it again and noticed that if you double click the autosend you are prompted to save the message.  Then it only gets sent once.  If you save it first then double, triple click autosend it will send that many times.

73, Ron NY3J

On 12/31/18 2:37 PM, Dave wrote:
I can force as many as 5 repeats by multiple mouse clicks on the AutoSend button.  There may be a bit of operator impatience at play here.  There is a finite, variable amount of time between the AutoSend closure and the onset of fldigi transmission.  The operator may think that the button closure did not occur and press AutoSend a second time.  It might help if I provided a visual confirmation that the data transfer to fldigi took place.  Perhaps a pop up confirmation dialog that the operator needed to acknowledge before any other AutoSend events are allowed.

Dave

On 12/31/18 1:26 PM, bartpearl via Groups.Io wrote:
Dave:

Both are using Windows, I think Windows 10 but I'm not sure.  It's VHF through repeaters.  Don't know about the mouse and buttons, I was going to ask on the next net (Wednesday night). 

It happened with two operators.  One is very proficient, and it only happened to him once.  The other is very new to NBEMS but seems to be catching on pretty quick.  It's happened several times with him.

I was planning on asking him to slow down the double-click speed setting and see if that stopped it. 

Bart N5BLP



Ron
 

Hi Dave,

It worked like a charm on my Windows 10 machine.  Double clicking within two seconds ignores the 2nd click.  After 2 seconds it will send it twice.

On my Linux Mint 18.0 machine the make command failed.  I sent the log to your private email.

Thanks, 73, Ron NY3J

On 1/1/19 7:53 AM, Dave wrote:
Please test

Includes this source code change

commit 3355087d05c2db0e0087de68137b398ba09bb740
Author: David Freese <w1hkj@...>
Date:   Tue Jan 1 06:21:54 2019 -0600

    Double click
   
      * add double click timer to AutoSend button
        - ignore multiple clicks of button that occur
          within a 2 second window.

73 & HNY, David, W1HKJ

On 12/31/18 2:13 PM, Ron wrote:
Hi Bart and Dave,

Excuse me for busting in like this.  I've had this happen to me with my impatience or just a nervous double click and I see it often with other people on the nets.  It gets worse when you try to interrupt the second transmission and it stays queued and if you send something else the Flmsg will continue.  I just tried it again and noticed that if you double click the autosend you are prompted to save the message.  Then it only gets sent once.  If you save it first then double, triple click autosend it will send that many times.

73, Ron NY3J

On 12/31/18 2:37 PM, Dave wrote:
I can force as many as 5 repeats by multiple mouse clicks on the AutoSend button.  There may be a bit of operator impatience at play here.  There is a finite, variable amount of time between the AutoSend closure and the onset of fldigi transmission.  The operator may think that the button closure did not occur and press AutoSend a second time.  It might help if I provided a visual confirmation that the data transfer to fldigi took place.  Perhaps a pop up confirmation dialog that the operator needed to acknowledge before any other AutoSend events are allowed.

Dave

On 12/31/18 1:26 PM, bartpearl via Groups.Io wrote:
Dave:

Both are using Windows, I think Windows 10 but I'm not sure.  It's VHF through repeaters.  Don't know about the mouse and buttons, I was going to ask on the next net (Wednesday night). 

It happened with two operators.  One is very proficient, and it only happened to him once.  The other is very new to NBEMS but seems to be catching on pretty quick.  It's happened several times with him.

I was planning on asking him to slow down the double-click speed setting and see if that stopped it. 

Bart N5BLP




Ron
 

Sorry, I meant Linux Mint 19.0.

Ron NY3J

On 1/1/19 8:23 AM, Ron wrote:
Hi Dave,

It worked like a charm on my Windows 10 machine.  Double clicking within two seconds ignores the 2nd click.  After 2 seconds it will send it twice.

On my Linux Mint 18.0 machine the make command failed.  I sent the log to your private email.

Thanks, 73, Ron NY3J

On 1/1/19 7:53 AM, Dave wrote:
Please test

Includes this source code change

commit 3355087d05c2db0e0087de68137b398ba09bb740
Author: David Freese <w1hkj@...>
Date:   Tue Jan 1 06:21:54 2019 -0600

    Double click
   
      * add double click timer to AutoSend button
        - ignore multiple clicks of button that occur
          within a 2 second window.

73 & HNY, David, W1HKJ

On 12/31/18 2:13 PM, Ron wrote:
Hi Bart and Dave,

Excuse me for busting in like this.  I've had this happen to me with my impatience or just a nervous double click and I see it often with other people on the nets.  It gets worse when you try to interrupt the second transmission and it stays queued and if you send something else the Flmsg will continue.  I just tried it again and noticed that if you double click the autosend you are prompted to save the message.  Then it only gets sent once.  If you save it first then double, triple click autosend it will send that many times.

73, Ron NY3J

On 12/31/18 2:37 PM, Dave wrote:
I can force as many as 5 repeats by multiple mouse clicks on the AutoSend button.  There may be a bit of operator impatience at play here.  There is a finite, variable amount of time between the AutoSend closure and the onset of fldigi transmission.  The operator may think that the button closure did not occur and press AutoSend a second time.  It might help if I provided a visual confirmation that the data transfer to fldigi took place.  Perhaps a pop up confirmation dialog that the operator needed to acknowledge before any other AutoSend events are allowed.

Dave

On 12/31/18 1:26 PM, bartpearl via Groups.Io wrote:
Dave:

Both are using Windows, I think Windows 10 but I'm not sure.  It's VHF through repeaters.  Don't know about the mouse and buttons, I was going to ask on the next net (Wednesday night). 

It happened with two operators.  One is very proficient, and it only happened to him once.  The other is very new to NBEMS but seems to be catching on pretty quick.  It's happened several times with him.

I was planning on asking him to slow down the double-click speed setting and see if that stopped it. 

Bart N5BLP





Dave
 

Thanks Ron.  My Mint 19.0 test build also shows a strcasecmp declaration error

Dave

On 1/1/19 7:27 AM, Ron wrote:
Sorry, I meant Linux Mint 19.0.

Ron NY3J

On 1/1/19 8:23 AM, Ron wrote:
Hi Dave,

It worked like a charm on my Windows 10 machine.  Double clicking within two seconds ignores the 2nd click.  After 2 seconds it will send it twice.

On my Linux Mint 18.0 machine the make command failed.  I sent the log to your private email.

Thanks, 73, Ron NY3J

On 1/1/19 7:53 AM, Dave wrote:
Please test

Includes this source code change

commit 3355087d05c2db0e0087de68137b398ba09bb740
Author: David Freese <w1hkj@...>
Date:   Tue Jan 1 06:21:54 2019 -0600

    Double click
   
      * add double click timer to AutoSend button
        - ignore multiple clicks of button that occur
          within a 2 second window.

73 & HNY, David, W1HKJ

On 12/31/18 2:13 PM, Ron wrote:
Hi Bart and Dave,

Excuse me for busting in like this.  I've had this happen to me with my impatience or just a nervous double click and I see it often with other people on the nets.  It gets worse when you try to interrupt the second transmission and it stays queued and if you send something else the Flmsg will continue.  I just tried it again and noticed that if you double click the autosend you are prompted to save the message.  Then it only gets sent once.  If you save it first then double, triple click autosend it will send that many times.

73, Ron NY3J

On 12/31/18 2:37 PM, Dave wrote:
I can force as many as 5 repeats by multiple mouse clicks on the AutoSend button.  There may be a bit of operator impatience at play here.  There is a finite, variable amount of time between the AutoSend closure and the onset of fldigi transmission.  The operator may think that the button closure did not occur and press AutoSend a second time.  It might help if I provided a visual confirmation that the data transfer to fldigi took place.  Perhaps a pop up confirmation dialog that the operator needed to acknowledge before any other AutoSend events are allowed.

Dave

On 12/31/18 1:26 PM, bartpearl via Groups.Io wrote:
Dave:

Both are using Windows, I think Windows 10 but I'm not sure.  It's VHF through repeaters.  Don't know about the mouse and buttons, I was going to ask on the next net (Wednesday night). 

It happened with two operators.  One is very proficient, and it only happened to him once.  The other is very new to NBEMS but seems to be catching on pretty quick.  It's happened several times with him.

I was planning on asking him to slow down the double-click speed setting and see if that stopped it. 

Bart N5BLP






Mike P.
 

Dave, on Linux Mint 19, I also get strcasecmp
declaration compile error on flmsg-4.0.8.01 alpha.

--- Mike, AE7XB

On 1 Jan 2019 at 8:18, Dave wrote:

Thanks Ron.  My Mint 19.0 test build also shows a strcasecmp declaration error

Dave
Electronics usually don't work after the magic smoke is released.