Topics

FLMsg/FLDigi Interface running on Ubuntu 19.10


Bart N5BLP
 

I've been running this stuff on Windows for years and have begun experimenting with ubuntu linux (version 19.10).

I've got FLDigi versioin 4.1.06 running just fine.

With FLMsg version 4.0.11, I'm having trouble getting it to interface properly with FLDigi.  Here's what I've got going on:
    In FLDigi, I have the NBEMS interface configured as follows (the same way I have it configured on my Windows system):
      NBEMS data file interface enabled. Open in message folder DISabled.
      Transfer direct to executing flmsg enabled.
      Open with flmsg and open in browser DISabled.
    In FLMsg, I have it configured to sync modem to FLDigi (also the same way I have it configured on my Windows system).  All other FLMsg configurations are default.

With the above configuration, the received message apparently never gets transferred to FLMsg.  (And yes, I do have it up and running).  Nothing shows up in the Received Messages window or in the main FLMsg window.  Going the other way, Autosend doesn't work.  Nothing goes out.  Also, changing the modem in FLDigi does NOT result in the modem being changed in FLMsg.

I then tried it with Open with flmsg enabled (in FLDigi) and the proper path specified.  With that configuration, a new iteration of FLMsg is started and the message is displayed.  But this way I wind up with multiple iterations running.  Also, going the other way Autosend still doesn't work and the modem still doesn't follow FLDigi.

Any help getting FLMsg and FLDigi to interface properly would be greatly appreciated.

Bart N5BLP


 

Bart,

Here's a screen shot of my Fldigi, Misc, NBEMS Interface.



Open with flmsg has to be checked. I think you found that out when you said you checked in. So when you receive an Flmsg it will automatically open a new Flmsg if there are no errors or ask you if you want to open it if the checksum doesn't match. When you check Transfer direct to executing flmsg it won't automatically open but it will show you a list of messages that you can open. I don't like this because I've missed messages with errors and didn't know there were errors. I'd rather have every message open. Of course I have 2 monitors and plenty of desktop space :-)

I'm not sure why the Flmsg mode doesn't follow the Fldigi mode. Here's my Flmsg ARQ configuration.



With Sync modem to fldigi checked flmsg should follow fldigi mode changes.

73, Ron NY3J

On 3/26/20 11:37 AM, Bart N5BLP via Groups.Io wrote:
I've been running this stuff on Windows for years and have begun experimenting with ubuntu linux (version 19.10).

I've got FLDigi versioin 4.1.06 running just fine.

With FLMsg version 4.0.11, I'm having trouble getting it to interface properly with FLDigi.  Here's what I've got going on:
    In FLDigi, I have the NBEMS interface configured as follows (the same way I have it configured on my Windows system):
      NBEMS data file interface enabled. Open in message folder DISabled.
      Transfer direct to executing flmsg enabled.
      Open with flmsg and open in browser DISabled.
    In FLMsg, I have it configured to sync modem to FLDigi (also the same way I have it configured on my Windows system).  All other FLMsg configurations are default.

With the above configuration, the received message apparently never gets transferred to FLMsg.  (And yes, I do have it up and running).  Nothing shows up in the Received Messages window or in the main FLMsg window.  Going the other way, Autosend doesn't work.  Nothing goes out.  Also, changing the modem in FLDigi does NOT result in the modem being changed in FLMsg.

I then tried it with Open with flmsg enabled (in FLDigi) and the proper path specified.  With that configuration, a new iteration of FLMsg is started and the message is displayed.  But this way I wind up with multiple iterations running.  Also, going the other way Autosend still doesn't work and the modem still doesn't follow FLDigi.

Any help getting FLMsg and FLDigi to interface properly would be greatly appreciated.

Bart N5BLP


K4IVE
 

Uncheck " Transfer direct to executing flmsg."
 
That function is a special case and causes more problems than it worth.
 
Kevin
K4IVE

 
 
Sent: Thursday, March 26, 2020 at 10:37 AM
From: "Bart N5BLP via Groups.Io" <bartpearl@...>
To: nbems@groups.io
Subject: [nbems] FLMsg/FLDigi Interface running on Ubuntu 19.10
I've been running this stuff on Windows for years and have begun experimenting with ubuntu linux (version 19.10).

I've got FLDigi versioin 4.1.06 running just fine.

With FLMsg version 4.0.11, I'm having trouble getting it to interface properly with FLDigi.  Here's what I've got going on:
    In FLDigi, I have the NBEMS interface configured as follows (the same way I have it configured on my Windows system):
      NBEMS data file interface enabled. Open in message folder DISabled.
      Transfer direct to executing flmsg enabled.
      Open with flmsg and open in browser DISabled.
    In FLMsg, I have it configured to sync modem to FLDigi (also the same way I have it configured on my Windows system).  All other FLMsg configurations are default.

With the above configuration, the received message apparently never gets transferred to FLMsg.  (And yes, I do have it up and running).  Nothing shows up in the Received Messages window or in the main FLMsg window.  Going the other way, Autosend doesn't work.  Nothing goes out.  Also, changing the modem in FLDigi does NOT result in the modem being changed in FLMsg.

I then tried it with Open with flmsg enabled (in FLDigi) and the proper path specified.  With that configuration, a new iteration of FLMsg is started and the message is displayed.  But this way I wind up with multiple iterations running.  Also, going the other way Autosend still doesn't work and the modem still doesn't follow FLDigi.

Any help getting FLMsg and FLDigi to interface properly would be greatly appreciated.

Bart N5BLP


W. T. Jones
 

I'll second that!


73,
WT Jones
WN3LIF
ARRL Amateur Radio Emergency Service
wn3lif@... <---
Eastern PA Section Emergency Coordinator
http://www.w3luz.org
ares County
                Basic Cert epa


On 3/26/20 12:39 PM, K4IVE wrote:
Uncheck " Transfer direct to executing flmsg."
 
That function is a special case and causes more problems than it worth.
 
Kevin
K4IVE
 
 
Sent: Thursday, March 26, 2020 at 10:37 AM
From: "Bart N5BLP via Groups.Io" <bartpearl@...>
To: nbems@groups.io
Subject: [nbems] FLMsg/FLDigi Interface running on Ubuntu 19.10
I've been running this stuff on Windows for years and have begun experimenting with ubuntu linux (version 19.10).

I've got FLDigi versioin 4.1.06 running just fine.

With FLMsg version 4.0.11, I'm having trouble getting it to interface properly with FLDigi.  Here's what I've got going on:
    In FLDigi, I have the NBEMS interface configured as follows (the same way I have it configured on my Windows system):
      NBEMS data file interface enabled. Open in message folder DISabled.
      Transfer direct to executing flmsg enabled.
      Open with flmsg and open in browser DISabled.
    In FLMsg, I have it configured to sync modem to FLDigi (also the same way I have it configured on my Windows system).  All other FLMsg configurations are default.

With the above configuration, the received message apparently never gets transferred to FLMsg.  (And yes, I do have it up and running).  Nothing shows up in the Received Messages window or in the main FLMsg window.  Going the other way, Autosend doesn't work.  Nothing goes out.  Also, changing the modem in FLDigi does NOT result in the modem being changed in FLMsg.

I then tried it with Open with flmsg enabled (in FLDigi) and the proper path specified.  With that configuration, a new iteration of FLMsg is started and the message is displayed.  But this way I wind up with multiple iterations running.  Also, going the other way Autosend still doesn't work and the modem still doesn't follow FLDigi.

Any help getting FLMsg and FLDigi to interface properly would be greatly appreciated.

Bart N5BLP


Bart N5BLP
 

Ah, working with computers is such a never ending joy!

After I posted I shut everything down and went outside to do some yard work.  Couple hours later I fired everything up and tried again.  VOILA!  Everything works.
     FLMsg mode follows FLDigi.
     Autosend works.
     Message reception works.

My guess - and it's a stretch - is that after installation a reboot was required to get the xmlrpc address and port to work.

A word about "Transfer direct to executing flmsg".
     I've been using it that way with the windows versions for years and have never once had a problem.  And it's working now on Ubuntu.

Thanks for the prompt replies everyone.

Bart N5BLP