Topics

Fldigi works, Flrig doesn't...Port set-up problem in OS X? #macos #flrig


Bill de K0AN
 

Rig: Ft-817, w/RT Systems usb cable and a USB UniDigi Interface (both work in Windoze7 via a USB hub on a netbook for field use)
OS: El Capitan 10.11.6 on a Mac mini (late 2009)...so it's maxed out.

This is what works on this system (FlDigi) :




This is what doesn't work in Flrig, either option gives an error, and they are the only options available:




I'm a major noob as far as Mac OS is concerned, so I'm sure I've missed some permissions, or other drivers (have already installed the CP210x Macintosh OS X VCP Driver v5, but haven't seen a difference) or something else...but sure would appreciate some help here.

Bill de K0AN


Ted KK6CSO
 

Hi Bill, 

I’m new to nbems groups so hope you get this msg.  I’m a long time Mac user and trying to get flrig/fldigi set up on my Ft-857D.  For now, everything works EXCEPT my waterfall.  Anyway I noticed a few things, since you’'re new to Mac.

To check that the CP210x driver is installed correctly, click on the Apple Logo  on far upper left of your desktop menu. Then click on:

About this Mac
   System Report
      Software (click on the little arrow to show all software if needed.  They all should already be listed)
           Extensions  (it will take a few moments to all load)   Scroll through the list of Extensions and make sure you see the "SiLabs USBDriver” listed.
Then close up the System Report.

Quit flrig and fldigi if they’re running.  Then make sue your interface USB cable is plugged into your Mac and the radio is turned on.  
THEN, launch flrig and 


you should see two SiLabs USBtoUARTs as a choice on the “Update ”tab.  Select one and click on “Init”  on the lower right.  If it tells you to select the other port, “close” and try the other SiLabs UART and Init.  You should now see your current radio freq on the flrig software display.  (Make sure the baud rate matches your Ft-817s baud setting, too.)



Then, Launch fldigi, and looking at your middle picture below, make sure,  “Enable flrig xcvr control with fldigi as client” is selected.
Fldigi should now also show your radio’s current freq as well.  Click “Save."



Hope this helps.

73
Ted
KK6CSO

_____________

On Mar 12, 2020, at 6:33 PM, Bill <remnant.1@...> wrote:

Rig: Ft-817, w/RT Systems usb cable and a USB UniDigi Interface (both work in Windoze7 via a USB hub on a netbook for field use)
OS: El Capitan 10.11.6 on a Mac mini (late 2009)...so it's maxed out.

This is what works on this system (FlDigi) :

<dummyfile.0.part><dummyfile.1.part>


This is what doesn't work in Flrig, either option gives an error, and they are the only options available:

<dummyfile.2.part>


I'm a major noob as far as Mac OS is concerned, so I'm sure I've missed some permissions, or other drivers (have already installed the CP210x Macintosh OS X VCP Driver v5, but haven't seen a difference) or something else...but sure would appreciate some help here.

Bill de K0AN


Bill de K0AN
 

Hi Ted,

Thank you very much for the advice! Most of my problem is my newness to Mac OS...I've gotten
WSJT-X working and Fldigi working with drivers I downloaded for the RT Systems USB-62C cable
that I bought a couple years ago - that seems to have been the main problem. Drivers were downloaded
from here: https://www.rtsystemsinc.com/kb_results.asp?ID=9
Unfortunately, I still haven't been able to get Flrig to work yet...

I will try your step-by-step instructions for getting Flrig to work, it looks like I might have missed one or two
in the way I was trying to get it to work.

Again, thanks Ted!

Bill de K0AN


Bill de K0AN
 

Flrig is now playing nice on the Mac and with Fldigi thanks to Ted's advice on how to set up the USB drivers:




Thank you again Ted!

Bill de K0AN


Ted KK6CSO
 

Good to hear Bill!
I’ve got flrig and fldigi playing well with my FT-857D except for the waterfall.
More on that to follow...

73
Ted  : )
_________________________

On Mar 15, 2020, at 7:53 AM, Bill <remnant.1@...> wrote:

Flrig is now playing nice on the Mac and with Fldigi thanks to Ted's advice on how to set up the USB drivers:


<dummyfile.0.part>

Thank you again Ted!

Bill de K0AN