Topics

Fldigi & Paspberry PI - Pause on Mode Change

Bill
 

I’ve been a longtime user of the FLDigi suite of programs.

Mostly use it with a windows computer.

 

But I have several Raspberry PI’s set up with the FLDigi suite.

They work great with one small quirk.

 

I’ve noticed that sometime during a Mode Switch (Ie, from MSK32 to BPSK125),

there is a pause of about 15 seconds and then the program continues.

This can occur when sending or when receiving.

It does NOT occur every time and it also does NOT always occur on the

same mode switch.  So I can’t make it repeat.

 

When it happens on send, you try to send, system pauses for 15 seconds,

no transmit during the pause, then the mode switches and program

transmits the message.

 

When it happens on receive, you receive the mode switch ID, system

pauses for 15 seconds, and then continues to operate normally.  Of course

by that time you have missed the first part of the message and quite often the

entire message.

 

Things I have tried:

 

Recompile the latest source.

Switched from PI3 to PI3 Plus.

Lock the PI in Turbo mode.

Yesterday I re-compiled on the new PI4.

Also tried the FLDigi that is in the Buster Repository.

 

All to no avail.  Still get the pause sometimes on mode switch.

 

Question:  Am I missing something in the Compile Options –

should I be setting any special switches?

 

Is there something happening during the mode switch that

would cause FLDigi to pause.

 

Appreciate any help.

 

Thanks

 

Bill

WD9EQD

Smithville, NJ

 

Randy Davenport
 

O am interested in the raspberry pi and fldigi. I am disabled and low income. Im looking for s pi with screen. Can some one help me out?
Randy ka4nma

On Sun, Aug 18, 2019, 12:33 PM Bill <bjbuzzcat@...> wrote:

I’ve been a longtime user of the FLDigi suite of programs.

Mostly use it with a windows computer.

 

But I have several Raspberry PI’s set up with the FLDigi suite.

They work great with one small quirk.

 

I’ve noticed that sometime during a Mode Switch (Ie, from MSK32 to BPSK125),

there is a pause of about 15 seconds and then the program continues.

This can occur when sending or when receiving.

It does NOT occur every time and it also does NOT always occur on the

same mode switch.  So I can’t make it repeat.

 

When it happens on send, you try to send, system pauses for 15 seconds,

no transmit during the pause, then the mode switches and program

transmits the message.

 

When it happens on receive, you receive the mode switch ID, system

pauses for 15 seconds, and then continues to operate normally.  Of course

by that time you have missed the first part of the message and quite often the

entire message.

 

Things I have tried:

 

Recompile the latest source.

Switched from PI3 to PI3 Plus.

Lock the PI in Turbo mode.

Yesterday I re-compiled on the new PI4.

Also tried the FLDigi that is in the Buster Repository.

 

All to no avail.  Still get the pause sometimes on mode switch.

 

Question:  Am I missing something in the Compile Options –

should I be setting any special switches?

 

Is there something happening during the mode switch that

would cause FLDigi to pause.

 

Appreciate any help.

 

Thanks

 

Bill

WD9EQD

Smithville, NJ

 

Bill
 

I am going to reply to my message to bump it to top again.

Is anyone here running fldigi on the Raspberry PI?

If so, have you noticed a pause (almost like the program has frozen)
when a mode change occurs?  Doesn't happen every time, but often
enough that I will miss the fldigi message.  The pause i about 5 seconds long
and then the program continues normally.

I have compiled many versions of fldigi, including the latest alpha versions.
It happens on all versions I have tried.

I also have compiled it on the new Raspberry PI 4, 2GB & 4GB, and it
also happens.

Under normal use, most people wouldn't notice this since most qso's are
not doing a lot of mode switching.

I participate on a weekly  Digital Education net which is over a repeater.
During the net, we experiment with a lot of modes, thus the mode change
is occurring a lot during the net.

Is anyone here using the PI and could you please experiment with it
and see if you experience the same pause?

Thanks,


73
Bill
WD9EQD
Smithville, NJ

Dave
 

Bill,

You need to join linuxham@groups.io  You will find many Pi3 / fldigi users there.  Someone will most like have a nearly identical setup.  What transceiver and how interfaced to fldigi?

Dave

On 9/24/19 5:03 PM, Bill wrote:
I am going to reply to my message to bump it to top again.

Is anyone here running fldigi on the Raspberry PI?

If so, have you noticed a pause (almost like the program has frozen)
when a mode change occurs?  Doesn't happen every time, but often
enough that I will miss the fldigi message.  The pause i about 5 seconds long
and then the program continues normally.

I have compiled many versions of fldigi, including the latest alpha versions.
It happens on all versions I have tried.

I also have compiled it on the new Raspberry PI 4, 2GB & 4GB, and it
also happens.

Under normal use, most people wouldn't notice this since most qso's are
not doing a lot of mode switching.

I participate on a weekly  Digital Education net which is over a repeater.
During the net, we experiment with a lot of modes, thus the mode change
is occurring a lot during the net.

Is anyone here using the PI and could you please experiment with it
and see if you experience the same pause?

Thanks,


73
Bill
WD9EQD
Smithville, NJ

Bill
 

Hi Dave,

 

Thanks – I’ll have to join that group.

 

I did more experimenting today and think I have discovered

what’s causing it.

 

I run with a generic usb sound fob.  When I use the signallink,

I do not have the delay.

 

I found out that if I turn off “Device Supports Full Duplex”, then

the delay disappears.  This corrects it on both of my two

PI’s that are running with the generic USB sound fob.

 

Not sure why having “Full Duplex” on would cause a delay,

but it is totally repeatable.

 

Full Duplex on – Delay

Full Duplex Off – No Delay.

 

I’ll know for sure after next Tuesday night’s digital net.

But I have been testing it for several hours, and with

Duplex Off, everything work fine.

 

73

Bill

WD9EQD

Smithville, NJ

 

 

 

 

 

From: nbems@groups.io [mailto:nbems@groups.io] On Behalf Of Dave
Sent: Tuesday, September 24, 2019 9:32 PM
To: nbems@groups.io
Subject: Re: [nbems] Fldigi & Paspberry PI - Pause on Mode Change

 

Bill,

You need to join linuxham@groups.io  You will find many Pi3 / fldigi users there.  Someone will most like have a nearly identical setup.  What transceiver and how interfaced to fldigi?

Dave

On 9/24/19 5:03 PM, Bill wrote:

I am going to reply to my message to bump it to top again.

Is anyone here running fldigi on the Raspberry PI?

If so, have you noticed a pause (almost like the program has frozen)
when a mode change occurs?  Doesn't happen every time, but often
enough that I will miss the fldigi message.  The pause i about 5 seconds long
and then the program continues normally.

I have compiled many versions of fldigi, including the latest alpha versions.
It happens on all versions I have tried.

I also have compiled it on the new Raspberry PI 4, 2GB & 4GB, and it
also happens.

Under normal use, most people wouldn't notice this since most qso's are
not doing a lot of mode switching.

I participate on a weekly  Digital Education net which is over a repeater.
During the net, we experiment with a lot of modes, thus the mode change
is occurring a lot during the net.

Is anyone here using the PI and could you please experiment with it
and see if you experience the same pause?

Thanks,


73
Bill
WD9EQD
Smithville, NJ